Geth slow syncing the blockchain

hamishmacewanhamishmacewan Member Posts: 5
I'm new to mining and following a guide which said to run geth to sync the blockchain. It has been running for several hours and is now reporting:

I0927 18:46:02.592152 3948 chain_manager.go:722] imported 1 block(s) (0 queued 0 ignored) including 0 txs in 6.048234ms. #299257 [89f9d7a9 / 89f9d7a9]

Its doing this very slowly in 1 block chunks and was previously running much faster. Does this process complete with a message or has it slowed because I am now up to date?

System is Ubuntu 14.04, quad core CPU, 8 GB RAM. Fast broadband connection - 30GB/s

Also, can I stop the process and start where I left off later?

Comments

  • greggreg Member Posts: 14
    When it starts importing blocks by 1 - it means that synchronization is complete and you're up to date.
  • hamishmacewanhamishmacewan Member Posts: 5
    edited September 2015
    Thanks so do I need to leave geth running as a separate process or do I stop and restart with mining options? The mining guides I found are not very explicit about that. Or will the mining process also keep the blocks in sync?
  • eliy7eliy7 Member Posts: 14
    Try this guide made by SilentCicero
    (For AMD GPUs)

    http://forum.ethereum.org/discussion/2695/frontier-mining-setup-notes-ubuntu-15-04-geth-v1-0-amd-ethminer/p1

    "5. Once geth is synced (check stats.ethdev.com to see latest block #), open another terminal (CNTRL + ALT + T) and start "ethminer" w/ with a GPU, below is ethminer running w/ AMD GPU device 0"

    For solo mining:

    $ ethminer -G --opencl-device 0

    If you have more then one GPU
    open another terminal

    $ ethminer -G --opencl-device 1

  • MrYukonCMrYukonC Member Posts: 627 ✭✭✭

    Thanks so do I need to leave geth running as a separate process or do I stop and restart with mining options? The mining guides I found are not very explicit about that. Or will the mining process also keep the blocks in sync?

    @hamishmacewan Mining alone (either via eth or ethminer) will not keep the block chain synced. You need to have a regular Ethereum node of some sort running in order for the block chain to stay synced.

    @eliy7 Pretty much said what you need to do.

    However, I would add that you will want to make sure Geth is started with rpc mode enabled and you might want to start ethminer with a specific address to mine to (the local host if you're running Geth and ethminer on the same machine):

    ethminer -G -F http://127.0.0.1:8545

    The -F specifies "farm" mode.

    Also, if you have more than one GPU, you can tell ethminer to use n-number of GPUs by using the -t flag (specifies the # of threads). For example, with 5 GPUs you would specify:

    ethminer -G -t 5 -F http://127.0.0.1:8545

    P.S. stats.ethdev.com is currently down, so use https://etherchain.org/ or one of the other block explorers.
Sign In or Register to comment.