Issue with Block Sync

oomooomo Member Posts: 31
edited September 2015 in Geth - Go Implementation
I am running a private network with two ethereum nodes, where one is mining and other one is not. it starts fine, with both nodes having same number of blocks, but after running for about maybe few hours, things are not syncing.

Here some node information:

Non-Mining Node -------------
instance: Geth/v1.1.3/linux/go1.5
datadir: /home/ether/ethtest/778/00
coinbase: 0x22deeb2eec86a13590372bc025728ebfe25e11ff
at block: 1248 (Sun, 20 Sep 2015 03:42:08 UTC)
modules: admin:1.0 db:1.0 debug:1.0 eth:1.0 miner:1.0 net:1.0 personal:1.0 shh:1.0 txpool:1.0 web3:1.0

Mining Node -------------
instance: Geth/v1.1.3/linux/go1.5
datadir: /home/ether/ethtest/778/01
coinbase: 0x290a9c68f3128188164bcc7251a2c53fa64e18c2
at block: 7156 (Sun, 20 Sep 2015 20:00:58 UTC)
modules: admin:1.0 db:1.0 debug:1.0 eth:1.0 miner:1.0 net:1.0 personal:1.0 shh:1.0 txpool:1.0 web3:1.0

As you can see that the non-mining node had stopped syncing. I have been noticing this problem for a long time.

New Information:

After restarting the nodes, non-mining node does get synced up. Let's see how long does this stay this way. Though, after using node management APIs I was able to see what might have been doing on - The non-mining node had one peer (and it was itself - doesn't make sense). Here is working peers setting, which makes sense -

> admin.peers (From non-mining node)
[{
Caps: "eth/60, eth/61",
ID: "80a505e1c5ab6e3e51ee2aa66d37ab639a09c45cb5af1427a0708ac0e1566f1713a7524c1eeccf2ce153bae712677d9ffeddbf4f003c009c8de84605a255d72e",
LocalAddress: "l.a.b.c:55420",
Name: "Geth/v1.1.3/linux/go1.5",
RemoteAddress: "r.x.y.z:30301"
}]

> admin.peers (From mining node)
[{
Caps: "eth/60, eth/61",
ID: "9fadc6dbb17533937359531e5a826b2ada8fc55c0e4ed524add2e247fbdb12d8070b02c6bf0bf09b4125ef392a046d48118cff1194fa08d8881531265dc2f4e5",
LocalAddress: "l.x.y.z:30301",
Name: "Geth/v1.1.3/linux/go1.5",
RemoteAddress: "r.a.b.c:55420"
}]



Post edited by oomo on
Sign In or Register to comment.