Naming conventions and best practices

acrosacros Member Posts: 63 ✭✭
It would be great to augment the Solidity tutorial with those. For instance, I noticed that @vbuterin 's standardized contract APIs seem to use cameCase (good!) and some variables that start with an underscore for function parameters. If this is to become standard, it would be a good thing to have it said explicitely in that tutorial!

IMO, even formatting recommendations would be positive, as they contribute to making the code more uniform across dapps.

We could even just link to the said standardized contract APIs' page from that tutorial!

A good example of what I mean is Twitter's 'effective scala' writeup on best practices for the Scala language (I'm not aware of TypeSafe having an official one, regrettably). The sooner such guidelines are put in place, the sooner they can be adopted/optimized!
Sign In or Register to comment.