Any chance you could make it easier to install?

givemecreditgivemecredit Member Posts: 20
OK. So i think i've just about got my head around geth, mix, pip, brew, cpp-ethereum, web3, eth, solc, Alethzero, embark, clang, gmp, go…and i’m about ready to move on to meth :p

I’m exhausted already. I have a very simple application that i want to build using Ethereum, yet, regardless of what i try, i’m confronted by a plethora of error messages. I have attempted to install cpp-ethereum on two different machines and a work colleague has tried on his machine too. So far…not so good.

I had problems with Alethzero (mostly relating to the API) and so i decided to give Embark a go.

When trying to run “brew reinstall cpp-ethereum --devel --build-from-source”, I get “Configuring incomplete, errors occurred!”, as well as, “EVMJIT needs the latest version of LLVM (3.7 or above)”. I’ve tried brew update, brew doctor, brew install llvm --HEAD --with-clang, and then tried to install cpp-ethereum again, to no avail. I then tried “brew install cpp-ethereum” and that seemed to install ok, although now i get “Illegal instruction 4” when i run “solc”.

When i try “embark run”, i get “Local Npm module "grunt-cli" not found. Is it installed?”…and… “Warning: Invalid JSON RPC response Use --force to continue.” The grunt-cli node modules are there and i’m not able to force continue. I assume the invalid JSON error is because i am not using the updated cpp implementation, which i am not able to install.

I eventually managed to get geth installed although it wasn’t clear that i needed to install pip, bitcoin and the genesis block as well. I ended up copying code from a blog written in Vietnamese in order to install the genesis block. i.e.

python mk_genesis_block.py --extradata 0x11bbe8db4e347b4e8c937c1c8370e4b5ed33adb3db69cbdb7a38e1e50b1b82fa > genesis_block.json

I then decided to try another framework called ‘Populus’, although i got various compilation errors when trying to compile the contracts.

So anyway, there are three main error messages which i would like to address…

$ brew reinstall cpp-ethereum --devel --build-from-source
“Configuring incomplete, errors occurred!”

$ embark run
“Local Npm module "grunt-cli" not found. Is it installed?”
“Warning: Invalid JSON RPC response Use --force to continue.”

$ solc
“Illegal instruction 4”

Of course, i have googled these issues but i haven’t yet found anything useful. I appreciate that some of these errors are not directly related to Ethereum, and I also appreciate that it’s still early days for Ethereum, but the installation process is way too complicated!!!
Post edited by givemecredit on
Sign In or Register to comment.