Mining does not work on my Windows laptop

alexey_petrenkoalexey_petrenko RussiaMember Posts: 28
I tried ethminer from C++ eth implementation (I know it is in beta, but miner should work, right?)

I first started geth with: geth --rpc --rpccorsdomain localhost 2>> geth.log

Then I try to launch test CPU mining:
C:\Program Files\Ethereum 0.9.41\Release>ethminer -M -C
Benchmarking on platform: CPU
Preparing DAG...
Warming up...
Trial 1... 0
Trial 2... 0
Trial 3... 0
Trial 4... 0
Trial 5... 0
 !   17:39:53|main  Terminate worker 576 ms
 !   17:39:53|main  Terminate worker 287 ms
 !   17:39:54|main  Terminate worker 104 ms
min/mean/max: 0/0/0 H/s
inner mean: 0 H/s
Same with GPU mining on embedded Intel 4000:
C:\Program Files\Ethereum 0.9.41\Release>ethminer -M -G
Found suitable OpenCL device [Intel(R) HD Graphics 4000] with 1468006400 bytes of GPU memory
Benchmarking on platform: GPU
Preparing DAG...
Warming up...
  i  17:41:13|gpuminer0  workLoop 0 #00000000… #00000000…
  i  17:41:13|gpuminer0  Initialising miner...
Using platform: Intel(R) OpenCL
Using device: Intel(R) HD Graphics 4000(OpenCL 1.2 )
Trial 1... 0
Trial 2... Printing program log
fcl build 1 succeeded.
fcl build 2 succeeded.
bcl build succeeded.

Creating one big buffer for the DAG
Allocating/mapping single buffer failed with: clCreateBuffer(-61). GPU can't allocate the DAG in a single chunk. Bailing.
Trial 3... 0
Trial 4... 0
Trial 5... 0
In this case it at least gives reasonable error message, probably my GPU just doesn't have enough memory (no surprise, this is shitty embedded unit).

Ok, try NVidia GPU:
C:\Program Files\Ethereum 0.9.41\Release>ethminer -M -G --opencl-platform 1
Found suitable OpenCL device [GeForce GT 635M] with 2147483648 bytes of GPU memory
Benchmarking on platform: GPU
Preparing DAG...
  i  17:43Wa:r3m0i|nggp uumpi.n.e.r
0  workLoop 0 #00000000… #00000000…
  i  17:43:30|gpuminer0  Initialising miner...
Using platform: NVIDIA CUDA
Using device: GeForce GT 635M(OpenCL 1.1 CUDA)
Printing program log

Creating one big buffer for the DAG
Loading single big chunk kernels
Mapping one big chunk.
Trial 1... 0
Trial 2... 0
Trial 3... Creating buffer for header.
Creating mining buffer 0
Creating mining buffer 1
Trial 4... clEnqueueMapBuffer(-36)
Trial 5... 0
Doesn't work either. What am I doing wrong? I assume GeForce 635M should do something?


  • cryptletcryptlet Member Posts: 29
    1GB of GPU RAM is required. If there is sufficient RAM available, maybe try deleting the existing pre-generated DAG files, might by corrupted. Or otherwise try the CUDA version of ethminer with -U instead.
  • alexey_petrenkoalexey_petrenko RussiaMember Posts: 28
    Ok, probably my 635M does not have enough memory. In fact I'm not sure if it even has it's own memory, it probably shares it with CPU.
    But why CPU mining is not working? I know it's ineffective, but I'd like to try anyway.

    -U option is not recognized by my ethminer. Ethminer --help do not list it either.
    I assume version on Windows does not support that?
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @alexey_petrenko look up the CUDA miner thread. Got binaries in there. Should run on GT635M, but don't expect miracles..
  • marcelolaumarcelolau Member Posts: 1
    hey there anyone looking at the topic? Same here alexey, same error with intel hd 4000 gpu,.. when check directx, it´s running with 1,7 gb but s not dedicated memory. Did anyone had sucess with Linux.. Or is possible to emulate something that works on this note ?

  • th00berth00ber Member Posts: 213 ✭✭
    HD 4000 is really bad at mining, not even worth to try to set up the miner :(
    Invest in a gaming PC and mine, or invest in ETH with $$

    But with that integrated chipset, you can't mine
  • dddrgonzooodddrgonzooo Member Posts: 145 ✭✭
    You could try nicehash. They have a multi algo miner that will automatically switch to what is the most profitable and you get paid in Bitcoin.

    After you download their software, bench your computer. From there go to and enter in the values returned from your bench along with how much power your computer uses and how much your electricity cost is and see if it's worth mining with that computer.
  • ethermine_rocksethermine_rocks Member Posts: 228
    I mined eth at nicehash for a month. That was a total waste of time&resources. I tried a lot of different pools and solo. Lots of weird behaviour at large/medium pools (unannounced downtimes, unexplained low hash rates, rigs doing mining ok but no return on pool). I asked admin at dwarf to do a manual payout two days ago, still no payout or reply etc. There are still different coins you could mine with your hardware but only for fun because you would pay more for power than earn.
  • ethermine_rocksethermine_rocks Member Posts: 228
    also since I own a T540p I can confirm that its shared memory
Sign In or Register to comment.