Am I mining correctly?

fivedogitfivedogit Member Posts: 21
edited August 2015 in Mining
I finally got my GPU yesterday and have started mining with ethminer. Here's what the output looks like in the ethminer logs:

miner 10:42:22|ethminer Mining on PoWhash #b6d16b84… : 23498964 H/s = 11796480 hashes / 0.502 s
miner 10:42:22|ethminer Mining on PoWhash #b6d16b84… : 24021163 H/s = 12058624 hashes / 0.502 s
miner 10:42:23|ethminer Mining on PoWhash #b6d16b84… : 24021163 H/s = 12058624 hashes / 0.502 s
miner 10:42:23|ethminer Mining on PoWhash #b6d16b84… : 24021163 H/s = 12058624 hashes / 0.502 s
miner 10:42:23|ethminer Got work package:
miner 10:42:23|ethminer Header-hash: bd36ac6c54ae4bade1913525c63e579c1b127f4b89cdfa9b26ff93df54230b5a
miner 10:42:23|ethminer Seedhash: f2e59013a0a379837166b59f871b20a8a0d101d1c355ea85d35329360e69c000
miner 10:42:23|ethminer Target: 00000000002c1080fe2bbcaaf7ec1441e50279dbac985e11cf6c1577d0c7d014
ℹ 10:42:23|gpuminer0 workLoop 1 #f2e59013… #f2e59013…
miner 10:42:24|ethminer Mining on PoWhash #bd36ac6c… : 23068672 H/s = 11534336 hashes / 0.5 s
miner 10:42:24|ethminer Mining on PoWhash #bd36ac6c… : 24069109 H/s = 12058624 hashes / 0.501 s

And here's what it looks like in geth (on a different computer):

I0828 10:42:03.007141 29280 worker.go:540] commit new work on block 156072 with 0 txs & 0 uncles. Took 4.568373ms
I0828 10:42:31.367104 29280 chain_manager.go:661] imported 1 block(s) (0 queued 0 ignored) including 0 txs in 4.882774ms. #156072 [2b1f4ebc / 2b1f4ebc]
I0828 10:42:31.379778 29280 worker.go:540] commit new work on block 156073 with 2 txs & 0 uncles. Took 12.521286ms
I0828 10:42:35.213687 29280 chain_manager.go:661] imported 1 block(s) (0 queued 0 ignored) including 2 txs in 9.771453ms. #156073 [7411d107 / 7411d107]
I0828 10:42:35.223826 29280 worker.go:540] commit new work on block 156074 with 0 txs & 0 uncles. Took 9.964093ms
I0828 10:42:46.706040 29280 chain_manager.go:661] imported 1 block(s) (0 queued 0 ignored) including 0 txs in 5.471305ms. #156074 [1a156ff2 / 1a156ff2]
I0828 10:42:46.716143 29280 worker.go:540] commit new work on block 156075 with 0 txs & 0 uncles. Took 9.805448ms

When I visit http://stats.ethdev.com, I see that it changes blocks at the same time my ethminer does, so that's encouraging.

However, I'm confused about this column on stats.ethdev.com:



What is that column? Those hashes do not match up with anything I'm seeing in my ethminer log: not the "mining on PoWhash", not the header-hash, not the target, and not the seedhash. So am I doing something wrong?

Thanks for your feedback

Comments

  • ethereumpoolethereumpool Member Posts: 108
    It seems everything works fine.
    From what i see you are mining solo with 24mhash. Dont expect any surprises soon. You should try pool mining, then also your doubts will go away when you see balance growing.
    http://ethereumpool.co
  • fivedogitfivedogit Member Posts: 21
    I doubled up to 48 mhash have been running for 3 days and still don't see anything. My calculations were that I'd see something after a day or two. I guess I'm just unlucky. I'll try pool mining at some point.

    And what's that column on stats.ethdev.com between the box and puzzle piece?
  • fivedogitfivedogit Member Posts: 21
    Dumb questions incoming. With 2 GPUs...

    1. Should I have the crossfire bridge installed between the cards?
    2. Should I have 2 windows open, both with their own ethminer processes running at 24 mhash each, or one window open with one ethminer process at 48 mhash?

    Thanks in advance! Don't forget my question about the stats.ethdev.com column please!
  • DaveHDaveH Member Posts: 42
    1. Nope, you don't need the crossfire bridge.

    2. You can have either - no real difference except ability to see individual card hashing performance in individual windows and use of system ram for the extra window.

    So, you can mine from each card in a separate window using the 'ethminer -G --opencl-device X' command where X = the gpu you want to start (ie 0 and 1)

    ; or,

    you can start all you card mining in the same window with ' ethminer -G -t X ' where X is the number of gpus you wan't to mine with (ie 2).

    Hope that helps.
  • hangabershangabers Member Posts: 63
    I don't have the crossfire bridge, but for whatever reason I was forced to have crossfire enabled for both cards to be see. If you can identify what device number and platform number your GPU and CPU sit on, you use the -G --opencl-platform X flag to target whatever GPUs are sitting on platform X.
  • fivedogitfivedogit Member Posts: 21
    And what's that column on stats.ethdev.com between the box and puzzle piece?
  • bartabbartab Member Posts: 4
    edited September 2015
    DaveH said:


    So, you can mine from each card in a separate window using the 'ethminer -G --opencl-device X' command where X = the gpu you want to start (ie 0 and 1)

    let's say on my 1st gpu I mine using ethminer -G --opencl-device 0 -F http://ethereumpool.co/?miner=[hash]@[adresss0]
    can I solo mine on my second GPU on a different address than adress0? or I'm forced to use same pool on same adress ?
  • fivedogitfivedogit Member Posts: 21
    I figured out the column. It's the hash of the block head they're mining on.
Sign In or Register to comment.