geth wallet import - Fatal:???

shawnlearyshawnleary Member Posts: 20
Any idea why I am getting "Fatal: Could not create the account:decrypted addr not equal to expected addr %...."

I know that my Passphrase: entry is perfect. I've heard there was an issue with the format of the .json backup wallet file in terms of compatibility with Frontier? Any help or point in the right direction is greatly appreciated.



  • shawnlearyshawnleary Member Posts: 20
    I'm getting this back "Fatal: Could not create the account: decrypted addr not equal to expected addr % !(EXTRA string=.........., string=................)"

    Does this mean wrong passphrase?
  • KenKKenK Member Posts: 44 admin
    Which client are you using to import your wallet?
  • shawnlearyshawnleary Member Posts: 20
    think my password is wrong. i was using a terminal window on my mac. but kraken is giving me the same response using their browser tool. oh well, someday it might be worth it to brute force it. would love to see what the password instructions were at the time of sale. i wonder if i modified my password based on some recommendations at that time.
  • charleycharley Member Posts: 6
    Receiving the same error. I'm almost sure my password is correct.
  • UTlex92UTlex92 Member Posts: 8
    I am also receiving the same error using what I would call my most likely password.

    I've tried variations of my password at and all give the following error: Invalid password. Error: unable to decrypt data

    Yet only when I use my most likely password I get this error:
    Invalid password. Error: Decoded key mismatch - possibly wrong passphrase

    I confirmed the above using Geth command line tools. Geth gives the following error:
    Fatal: decrypted addr 'resulting address ' not equal to expected addr 'my address'

    Using knowingly wrong password provides:
    Fatal: could not decrypt key with given passphrase.

    Any information regarding this error would be greatly appreciated.
  • bitmasterbitmaster Member Posts: 2
    UTlex92- Did you ever come to a solution for your problem? I have the same exact issue!!! Please help! Thanks!
  • UTlex92UTlex92 Member Posts: 8
    bitmaster said:

    UTlex92- Did you ever come to a solution for your problem? I have the same exact issue!!! Please help! Thanks!

    Bitmaster, not yet but I have uncovered some interesting results. Using the Geth console I tried to login with using my presale wallet json file and the password that gives the mentioned error. I wrote down the address Geth provided as an output (which does not match the address in my presale wallet json file). I then opened my presale wallet json in a text editor, saved as with new name (don't override your existing wallet) and replaced the ethaddress with the address Geth provided as an output, and saved the document.

    I then went through the login process again using geth, this time used the updated json file and the same password that resulted in the above error. To my surprise, geth accepted it. Unfortunately, what appears in mist is the empty wallet for the wrong ethaddress that Geth provided. Scratching my head here. It would be great if someone familiar with coding of the wallets could comment. I think this case history provides sufficient evidence that the passwords are not being entered incorrectly.
  • IndianaIndiana Member Posts: 6
    wow. you could be on to something!! But im of no help. im only getting the same error with my sons json file. a little different though. on myetherwallet the password he thinks is correct got the regular error. then tried 100 slight variations of the correct password one of them gave the error "Please enter a valid password. Error: Decoded key mismatch - possibly wrong passphrase" it was what we think is the correct password but typed out backwards. This actually may have been the original correct password. its up to half a million $$$ now, how high does this have to go before it becomes worth it to create a super quantum computer to crack this dam json?
  • markoffmarkoff Member Posts: 6
    I recently recovered my ethereum that I had acquired through mining about 18 months ago. I had saved the .json file. I had another file with a long name that started with UTC and I had written down the password I used. I put the .json file and the UTC file into my .ethereum/keystore folder then I tried to unlock my account by running the geth command with the --unlock extension but when I entered the correct password I saw an error msg (sorry I don't know which one it was). However when I installed and ran the Etherwall client I found the password that had failed at the console now worked. I got the same result (success) when I tried that password while using the Ethereum Wallet client as well.

    I had about 80 ethereum in my wallet initially ... so far I have been able to transfer 45 of them to a different address. I was surprised I was able to do anything at all prior to completely syncing the blockchain. It has so far been a very pleasant surprise because none of my efforts to completely sync the blockchain have been completely successful. I hope this helps.

    Good Luck everybody. :-)

  • UTlex92UTlex92 Member Posts: 8
    Anyone have any feedback on the issue I described above? If any others out there have encountered this issue how did you resolve?
Sign In or Register to comment.