synchronisation failed: block downloading canceled

etherheadetherhead Member Posts: 3
Been running geth fine since frontier launch. Today I start getting this.

I0810 13:17:39.208866 2141 downloader.go:278] Block synchronisation started
I0810 13:17:40.501748 2141 chain_manager.go:658] imported 0 block(s) (0 queued 1 ignored) including 0 txs in 810.824131ms. #61828 [fe39e7b8 / fe39e7b8]
I0810 13:17:40.506135 2141 chain_manager.go:774] Bad block #61829 (f4c0843086bfc74b8d427feef3c56a63b7299f06cad8f78486ff336b1b043089)
I0810 13:17:40.506179 2141 chain_manager.go:775] Transaction w/ invalid nonce. tx=3 state=0)
I0810 13:17:40.506823 2141 downloader.go:254] Synchronisation failed: block downloading canceled (requested)
I0810 13:17:44.209820 2141 fdtrack.go:109] fd usage 45/1024, tracked 31 [ipc:1 leveldb:26 natpmp:1 p2p:3]
^CI0810 13:17:47.284644 2141 cmd.go:134] Got interrupt, shutting down...
I0810 13:17:47.286379 2141 chain_manager.go:459] Chain manager stopped
I0810 13:17:47.286412 2141 handler.go:165] Stopping ethereum protocol handler...
I0810 13:17:47.286437 2141 handler.go:175] Ethereum protocol handler stopped
I0810 13:17:47.286517 2141 transaction_pool.go:138] Transaction pool stopped
I0810 13:17:47.286559 2141 backend.go:686] Automatic pregeneration of ethash DAG OFF (ethash dir: /home/user/.ethash)
I0810 13:17:47.321900 2141 database.go:167] flushed and closed db: /home/user/.ethereum/chaindata
I0810 13:17:47.322013 2141 database.go:167] flushed and closed db: /home/user/.ethereum/dapp
Running:
-----
Version: 1.0.1
Protocol Versions: [61 60]
Network Id: 1
Go Version: go1.4.2
OS: linux
GOPATH=
GOROOT=/usr/lib/go
------(console) ----
x/go1.4.2
datadir: /home/user/.ethereum
coinbase: XXXXXXXXXXXXXXXXXXX
at block: 61828 (2015-08-09 23:51:58)
modules: admin:1.0 db:1.0 debug:1.0 eth:1.0 miner:1.0 net:1.0 personal:1.0 shh:1.0 txpool:1.0 web3:1.0
--------------------

tried updated geth
tried upgradedb
tried removedb multiple times (seems like it makes no effect)

Still can't get the chain to sync.

Can I just delete the Dapp and Chaindata folders outright?

Any help appreciated.

*corrected post title fixed typo*

--- Issue resolved ---

Order should be from CLI
geth removedb
geth upgradedb

import process begins. once that completes should see:
Import Finished

At that point geth was restarted with no issues.

----
Post edited by etherhead on

Comments

Sign In or Register to comment.