Problem when building with homebrew in Mac OS X 10.9.5

Hello, I tried following the steps described in here, but after installing all dependencies (boost, boost-python, readline, etc.) I'm stuck at this point:
Warning: EVMJIT needs the latest version of LLVM (3.7 or above), currently
only available with --HEAD. If an older version was already installed
or it did not install automatically, make sure to install it with
`brew install llvm --HEAD --with-clang`
  CMakeLists.txt:7 (project)

-- Configuring incomplete, errors occurred!
See also "/tmp/cpp-ethereum20150803-1906-o9o2hi/CMakeFiles/CMakeOutput.log".

If reporting this issue please do so at (not Homebrew/homebrew):
Of course I tried to install the latest version of llvm as instructed there, but after it completed I got this message:
This formula is keg-only, which means it was not symlinked into /usr/local.

Conflicts with V8 in Homebrew/homebrew.

Generally there are no consequences of this for you. If you build your
own software and it requires this formula, you'll need to add to your
build variables:

LDFLAGS: -L/usr/local/opt/v8-315/lib
CPPFLAGS: -I/usr/local/opt/v8-315/include
Which I suspect has a lot to do with the fact that the ethereum installation cannot proceed. If I run the brew command to install ethereum again I get the same message as above. I'm not that experienced with OS X library system so I would appreciate some helpful insight.

Best regards
Nelson R. Pérez


  • BilthonBilthon Member Posts: 10
    edited August 2015
    Well turns out I was missing the qt5 dependency. This made it.

    brew install qt5

    The problem is that homebrew's output is short and misleading, and the CMakeOutput.log referenced does not exist by the time you look at it. So I had to manually compile to see what the problem was.
  • gmkgmk Member Posts: 1
    Hi Bilthon,

    Really great to see that someone else was once at this step of Ethereum's arcane installation process. Initially I got the same issue as you when installing llvm--HEAD--with-clang
    "This formula is keg-only, which means it was not symlinked into /usr/local."

    Then I tried:
    brew install qt5
    And after that when I try to install llvm again, I get
    $ brew install llvm --HEAD --with-clang
    ==> Cloning
    Updating /Library/Caches/Homebrew/llvm--git
    fatal: unable to access '': Failed to connect to port 80: Operation timed out
    Error: Failed to download resource "llvm"
    Failure while executing: git fetch -q origin
    It seems that I'm not able to download the latest version of llvm again anymore. Did you face this too?
Sign In or Register to comment.