Problem running Eth - Couldnt punch through NAT (or no NAT in place)

- im running Windows
- i installed Eth as explained on the homepage with:

bitsadmin /transfer cpp-ethereum " C++ develop branch/Ethereum (++)-win64-latest.exe" %temp%\eth++.exe & %temp%\eth++.exe

- i managed to generate the genesis block with the python script
- and pushed it to eth via: eth --genesis genesis_block.json

I now tried to run Eth with:
eth --frontier --network-id 1 -b --genesis-json path/to/genesis.json -i

but i dont get a connection as you can see in the screenshot below

i tried Portforwarding of the port 30303 to the IP of my Computer that im running Eth on
and i checked that UPnP is enabled but still no connection...

Im clueless what to do... has anybody an idea?



  • Marvell9Marvell9 Member Posts: 593 ✭✭✭
    you might be connected

    i have the same setup on my machine if you are not getting socket errors you are probbaly connected.

    Now the problem I still have and it seems you do too is you cant run eth in interactive mode, i,e type stuff on the console likte get blocks check network etc

    the only way you know if anything is working is run etheminer and see if it connects to your node and mines.

    also you have to somehow set your miningbenifcator and the signer via the eth menu.

    you can get your address via ethconsole
  • CarlWillhelmCarlWillhelm Member Posts: 20
    oh you are right... its mining! Sweet first success jippie :)

    do you know how to switch to gpu mining? i tried the command from the homepage:
    eth --frontier --network-id 1 -b --genesis-json C:\Users\hondo\genesis_block.json -i -m on --G

    but i says invalid argument: --G
  • CarlWillhelmCarlWillhelm Member Posts: 20
    k i figured it out... it has to be -G not --G then it works ...
  • Marvell9Marvell9 Member Posts: 593 ✭✭✭

    k i figured it out... it has to be -G not --G then it works ...

    Great, glad you figured it out, btw what is your hash rate ? seems you found a block really fast
  • CarlWillhelmCarlWillhelm Member Posts: 20
    24,4 MHs with a radeon r9 280x
Sign In or Register to comment.