Gentoo dependencies

Gentoo folks can use

emerge -av dev-lang/yasm dev-libs/crypto++ dev-libs/gmp =dev-libs/boost-1.53.0-r1 dev-util/cmake dev-libs/leveldb net-libs/miniupnpc

To set up most of the dependencies, minus the secp256 lib.
You'll also need to to unmask your platform (~amd64 for me) in make.conf
and add
=dev-libs/boost-1.53.0-r1
=dev-util/boost-build-1.53.0
to your package.unmask file

Then follow the main instructions starting at "Then grab and build the SECP256k1 crypto lib:"
https://github.com/ethereum/cpp-ethereum/wiki/Building
Sign In or Register to comment.