Frontier: Issue loading block into client

agentptagentpt Member Posts: 10
edited July 2015 in Geth - Go Implementation
I seem to have generated the genesis block fine, but then when loading it into the client using this command:
./build/bin/geth --genesis genesis_block.json
I get
-bash: ./build/bin/geth: No such file or directory
Can anyone help? I'm running geth on OSX.

Comments

  • agentptagentpt Member Posts: 10
    This seems to have solved it
    python ./mk_genesis_block.py --extradata 0x11bbe8db4e347b4e8c937c1c8370e4b5ed33adb3db69cbdb7a38e1e50b1b82fa > genesis_block.json
  • CarlWillhelmCarlWillhelm Member Posts: 20
    edited July 2015
    i still have the same error ... what am i missing?

    ./build/eth/eth --genesis genesis_block.json
    -bash: ./build/eth/eth: No such file or directory

    eth on OSX
  • dribudribu Member Posts: 6
    I have the same problem with geth on Linux.
  • MaranMaran Member Posts: 7
    @carl The path should be `./build/bin/geth` not `build/eth/eth`
  • dribudribu Member Posts: 6
    Can anyone explain what I have missed? I also generate the genesis block just fine, but when I enter into the terminal
    ./build/bin/geth --genesis genesis_block.json
    I get
    -bash: ./build/bin/geth: No such file or directory
    I also cannot find any ./build/bin directory (unless I am misinterpreting that, am a total noob. I did find geth under /usr/bin, is that relevant?)
    Geth on Linux, please help by pointing out if I misinterpreted something.
Sign In or Register to comment.