eth says wrong network identifier.

terhechteterhechte Member Posts: 5
I'm probably doing something stupid, but when running eth like so:
eth -b -G -a ... --frontier --genesis-json ./genesis_block.json

I'm always getting this error:

⧎ ◌ 18:08:35|p2p Hello: Geth/v1.0.0-0cdc7647/linux/go1.4.2 V[ 4 ] ##a979fb57… (eth,61) 0
⧎ ◌ 18:08:35|p2p|a979fb57…|Geth/v1.0.0-0cdc7647/linux/go1.4.2 Status: 61 / 1 / #d4e56740… , TD: 27160636278679 = #11ec5660…
⧎ ℹ 18:08:35|p2p|a979fb57…|Geth/v1.0.0-0cdc7647/linux/go1.4.2 DISABLE: Disabling capability ' eth '. Reason: Invalid network identifier.
⧎ ◌ 18:08:35|p2p|a979fb57…|Geth/v1.0.0-0cdc7647/linux/go1.4.2 Disconnect (reason: Unknown reason. )
⧎ ◌ 18:08:35|p2p|a979fb57…|Geth/v1.0.0-0cdc7647/linux/go1.4.2 Closing peer session :-(

Also, do I always have to add the genesis-block parameter? When I'm not doing that it complains that it has the wrong genesis block..

Thanks!
Sign In or Register to comment.