My experience installing on windows.

spraffspraff Member Posts: 15
Hi, everyone.

This is to document my experience installing Frontier on Windows. If you've gone through this and can add some insight, please do. I am technically proficient under Linux, but I'm having unrelated technical problems there so I'm trying this out on a Windows machine. I've encountered a few confusing issues which I'd like to record here to help the developers see it from this angle.

(I'm not here to bitch, by the way. Great work, guys. Just informing you of what happened.)

1) "Installation instructions for Windows" begins with "Installing from Chocolatey". What is chocolatey? Installation instructions for chocolatey were not that easy to find, and requires pasting a choice of text commands into a choice of shells.

2) Running "choco install geth-stable" seemed to work but the obvious next command, "geth", is "not recognised as an internal or external command." You have to cd to where chocolatey installed it (not an obvious location, not even within Program Files).

3) Before I tried hunting down the installation, I tried installing alethzero. This fails because it depends on 7zip yet does not install 7zip as a dependency. When running, it complains that libcurl is missing.

4) Back to the original plan, I am now in the middle of multiple sets of instructions for various things and have to go back to the blog post to get my bearings.

5) could and should be included in the chocolatey package

6) "You now need to install the pybitcointools" but the instructions after that appear to be for installing "bitcoin". After running "pip install bitcoin", have I installed pybitcointools? "pybitcointools is not recognised as an internal or external command."

7) Wait, I have to build from git now? Didn't I install geth in step 2?

8) These instructions seem to have drifted into a linux-only mode. Where are all these directories under Windows?

9) I'm waiting for the hash of block #1028201but seems to be saying we're at block 1507 at the moment.

10) Well, I may as well do a dry run... python --extradata 12345
File "", line 293
print json.dumps(evaluate(), ident=4)
SyntaxError: invalid syntax


Has anyone here actually managed to get all this working on Windows? The instructions seem incomplete, I'd appreciate any help filling out the gaps. Am I expected to change my PATH, for example? If I open a brand new command prompt after installing everything, what should I be doing to run these programs? Does my working directory matter?

Thanks for reading.


Sign In or Register to comment.