Windows miner before launch?

arandyarandy Member Posts: 37
Anyone know if there's a working windows miner available?


  • GeorgeHallamGeorgeHallam Member, Administrator, Moderator Posts: 229 admin
    Hello @arandy,

    Try this:

    This may be slightly out of date but I've seen reports of people using it to get their miners working.

    If you require further assistance, PM me and I'll drop you into the Ethereum Mining Skype channel.
  • VeritasSapereVeritasSapere Member Posts: 4
    edited July 2015
    Personally I would love to mine Ethereum but I am not sure if it would be worthwhile installing Linux on all my gpu rigs just for this. I would have thought this is something that should have been easy to do. I have mined a lot of coins and this is definitely the most difficult it has ever been. In my opinion this release is to early considering the difficulty and lack of support for mining. I am definitly quite disappointed about the state and support that seems to be lacking in this project for mining. I would not be surprised if there are many more people like me. I hope there will be no issues with securing the chain when it launches since I am wondering how large of a hash rate you will have with such lack luster support for the miners.

    Please make it easier for us simple windows users, I might be a simple windows user and not particularly technically inclined but I do see the potential greatness in this project and I am running a GPU farm which I would love to point towards the ethereum network.
    Post edited by VeritasSapere on
  • arandyarandy Member Posts: 37
    edited July 2015
    @GeorgeHallam Tried this yesterday but at point 8 i run into a problem.

    8. Next, cd back into /cpp-ethereum, and run:
    cmake -DETHASHCL=1 -G “Visual Studio 12 2013 Win64”
    This will prepare the project for compiling.

    CMD gives me the error
    C:\ether\cpp-ethereum>cmake -DETHASHCL=1 -G "Visual Studio 12 2013 Win64"
    CMake Error: Could not create named generator ÔÇ£Visual

    Tried allot of combinations nothing worked.
    C:\ether\cpp-ethereum>cmake -DETHASHCL=1 -G "Visual Studio 14 2015 Win64"
    C:\ether\cpp-ethereum>cmake -DETHASHCL=1 -G Visual Studio 14 2015 Win64
    All gave the same error

    Any ideas?
    Post edited by arandy on
  • arandyarandy Member Posts: 37
    Apperently you have to install cmake into the cpp-ethereum folder and give this command in CMD while being in that folder: cmake -G "Visual Studio 1 2015 Win64"
  • arandyarandy Member Posts: 37
    edited July 2015
    pffff i give up 5 errors in Visual and choco won't install geth
  • cryptojunkiecryptojunkie Member Posts: 5
    edited July 2015
    Yeah this is definitely the worst support for mining I've seen and I've mined a lot of coins, should be one installer and a .bat file, two installers max, not visual studio, git, cmake, geth, ethminer, just wow. 18 million doesnt buy GPU support for windows eh?
  • arandyarandy Member Posts: 37
    Yep fair launch my ass
  • rpmxrpmx Member Posts: 21
    edited July 2015
    I've been trying to mine using a file I downloaded from here. It installs ethminer, eth, alethzero and so on. Then again, I've had problems with that version of ethminer, so maybe I've been doing it wrong.
Sign In or Register to comment.