Windowsclient on launch? How to mine or even get my presale ether to an exchange for trading?

arandyarandy Member Posts: 37
Don't shoot me for being to dumb to understand all the ether stuff but for someone who doesn't know how to programm all the info is very wide spread and making me dizzy.

I wanted to setup my mining rig before the genesis block launch and go at it this thursday help the net and start mining.
The problem is i really don't get how to to that on windows. And if i don't get it i won't be the only one out there. probably.

I have found alethzero olympic that seems to work but if i'm right that's an obsolete version which brings me nothing.

Can someone please point me the proper links and an how to to get mining on the wallet adres from the presale?
Also an how to to send ethers to another adress would be welcome.


  • VeritasSapereVeritasSapere Member Posts: 4
    edited July 2015
    This is the best guide I have found for mining on windows:

    which in my opinion is a bit ridiculous that it is going to be this difficult to mine for Etherium on windows. It seems like it is also rather complex on Linux as well. Personally I would love to mine Etherium but I am not sure if it would be worthwhile installing Linux on all my gpu rigs just for this. I would have thought this is something that should have been easy to do. I have mined a lot of coins and this is definitely the most difficult it has ever been. In my opinion this release is to early considering the difficulty and lack of support for mining. I am definitly quite disappointed about the state and support that seems to be lacking in this project for mining. I would not be surprised if there are many more people like me. I hope there will be no issues with securing the chain when it launches since I am wondering how large of a hash rate you will have with such lack luster support for the miners.

    Please make it easier for us simple windows users, I might be a simple windows user and not particularly technically inclined but I do see the potential greatness in this project and I am running a rather large GPU farm.
  • celticwarrior72celticwarrior72 Member Posts: 83
    edited August 2015
    I have tried using this guide ( for mining on Windows 7. I get to step 11 (Ethminer build) but for some reason only 8 builds are successful and 2 fail.

    Can someone who has gotten this to work on Windows perhaps provide some help?
    Post edited by celticwarrior72 on
  • celticwarrior72celticwarrior72 Member Posts: 83
    edited August 2015
    Gave up building anything and just downloaded installable versions. It pulling of hair and gnashing of teeth but I got it working.
    1. Downloaded Geth installer here: (the automated development build)
    2. Downloaded Ethereum here: C++ develop branch/ (the latest Windows c++ build is a .exe file at the bottom)
    3. Then download the genesis JSON file ( and save it somewhere (easiest to save it in the same folder as Geth actually)
    4. Start Geth and open a new account from the DOS CMD line: "geth account new" (save the account name and password you use). Exit that (CRTL+C)
    5. Start Geth with the genesis JSON "geth --genesis [path_to_genesis_JSON_filename] and let it catch up to whatever the current block is on Exit that (CRTL+C)
    6. Start GETH again with the RPC API: "geth --rpc". Now we are ready to start mining.
    7. Open another DOS terminal and start the miner "ethminer -G --opencl-device 0" and if everything goes right you should be mining away
    One more thing, the Geth terminal is super clunky and buggy. If you want to actually use it as a terminal you have to open another instance of the DOS terminal and type "geth attach". This gives you another Geth window into which you can actually type the javascript API commands.
    Post edited by celticwarrior72 on
  • RedRockMiningRedRockMining Member Posts: 1
    edited August 2015
    Hi, thanks for this. I agree with your sentiments about the release. So far your instructions have worked perfectly for me with the exception of step 7: I don't seem to have the program "ethminer"... presumably .exe. What did I miss?

    Updates: found ethminer.exe, next msvcr120.dll is missing but downloaded it here:

    Ok, now Windows just says "Unable to start correctly...".

    So close.... thoughts?

    Update #2: Ok, got the correct msvcr120.dll from the MS VS redist. package here:

    Now, I get the truly helpful error message (no sarcasm, really) that my GPU does not have enough memory which I half expected since I've had zero luck getting it to mine for another project but without the helpful error message. Now I get to go to step 2 which is install my brand new Sapphire Nitro R9 390 which better have enough memory (8 GB).

    Will post results as I get them.
    Post edited by RedRockMining on
  • TheIronmanTheIronman FinlandMember Posts: 43 ✭✭
    edited August 2015
    I cannot get the genesis block to work with geth, it just says fatal: read c:: The handle is invalid. So it finds the genesis block, but.... any ideas?
  • geekhavengeekhaven Member Posts: 56
    Might find some help over in this thread. Not sure if it pertains to your problem though.
  • GinFabGinFab Member Posts: 2
    When I had the missing msvcr120.dll I loaded it from and everything is working now.
  • GinFabGinFab Member Posts: 2
    When I had the missing msvcr120.dll I loaded it from and everything is working now.
Sign In or Register to comment.