Miner works but never mine anything

AlexNaAlexNa Member Posts: 32
edited June 2015 in Mining
This is thread to discuss the non-mining problem. I see other people are experiencing the same situation.

The problem is:

1. The geth/ethminer combination is all configured and running.
2. The ethminer log shows all the proper MH/s numbers and the graphical card makes all the sound
3. The geth node is in sync with the network. It is green most of the time on the https://stats.ethdev.com/ page

...and yet, the miner never mines anything.

In my case the miner shows 17MH/s performance. With the current 4G difficulty I suppose to mine at least some blocks every hour. I am running the thing for 4+ days, and never solved a block.

Let's try to understand what the problem is.

Thank you.

P.S. It is not the problem of mining into some wrong address, or anything like it. The miner for sure never solves a block.

Comments

  • AlexNaAlexNa Member Posts: 32
    I finally mined something!

    The problem was with the ethminer. I tried the build by @Genoil

    https://forum.ethereum.org/discussion/comment/9377/#Comment_9377

    Now I see some ETH coming to my account. I am not sure what @Genoil did exactly to make the build but it works.

    So, be aware, if you compile the GPU miner yourself, you might get a version that looks like real, but in fact not working.


    And thank you @Genoil.
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @AlexNa that's very nice but I just told @o0ragman0o not not use my binaries for mining yet. This morning I resolved a bug (in the CUDA miner) that should theoretically yield double the results as what you mine with the build you tried. The ethcudaminer1106 you are referring to throws away half of the found blocks :)

    Most recent code on my github should be better though.

    As to what I did differently, really not much. You might just have a bit more luck today.
  • AlexNaAlexNa Member Posts: 32
    @Genoil Do you have a new build I can try?
  • AlexNaAlexNa Member Posts: 32
    @Genoil I am having troubles compiling your code. What cmake parameters do you use?
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    -DBUNDLE=miner -DETHASHCU=1
  • AlexNaAlexNa Member Posts: 32
    @Genoil I compiled your version. The result is this. When I run miner with -G (OpenCL) it works beautifully and mines a lot of ETH. When I run it with -U (CUDA) it does what I described before. It works but never mines anything. Exactly what I have with the official miner when I compile it with CUDA.

    It could be great if someone can confirm it.

  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @AlexNa I don't understand what you mean by "Exactly what I have with the official miner when I compile it with CUDA". The offcial miner is OpenCL. But I'll try to replicate this. I'll let the OpenCL miner run for a bit and compare with the CUSA version. Thanks for taking the time to test!
  • AlexNaAlexNa Member Posts: 32
    I downloaded and installed CUDA driver. It installed all the proper *.h files. Then I get the official miner and compile it with no change. When I start it I see CUDA in the name of the device. May be it is still OpenCL, I might be wrong in that.
  • o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
    @AlexNa, Which CUDA drivers did you download? From my understanding they are part of the normal NVIDIA drivers. I was also having problems until I updated to the latest drivers. When I did try to mine with ethcudaminer though, it was throwing an unknown error but I just assumed that to be among the bugs @Genoil spoke of.
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @AlexNa CUDA is a larger thing than just an API to NVidia's GPUs. It's like APP (accelerated parallel processing) from AMD. OpenCL is AMD's primary API to APP, and NVidia has the CUDA runtime as well as OpenCL as an API to their CUDA platform. So that's why you still see CUDA when using the OpenCL implementation of ethminer on an NVidia card.
Sign In or Register to comment.