CUDA miner

1568101169

Comments

  • o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
    @buechling,

    On linux, Nvidia System Managment Interface (nvidia-smi) is the command line tool for everything we need to do. Useful commands are:
    nvidia-smi -l displays table of live stats for all cards.

    sudo nvidia-smi -pl xLimit's power to x watts (30 to 38.5 on the 750/750Ti's).

    nvidia-smi -q -d CLOCK Display GPU clocks.

    nvidia-smi -q -d SUPPORTED_CLOCKS Display supported clock settings.

    sudo nvidia-smi -ac memory,core Set application clock speeds. Check SUPPORTED_CLOCKS to see available memory/core combinations.

    sudo nvidia-smi -rhard reset GPU's (as power cycle)

    You can pick on particular cards with switch -i id where id is from 1 to number of cards you have.

    This is what I was playing with last night when my PSU died. @ennui's power throttling suggestion looks very much worth it. I didn't get to mess with the application clocks but could only seem to access them on my 750 and not the 750Ti's.
  • o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
    buechling said:

    i don't think there is a 175W limit? ( see above ). I think the limit is 75 W per PEG-Port ( special kind of PCI-X-Port, german: http://www.heise.de/ct/hotline/Was-ist-PEG-325734.html ), so we have 3*75W = 225W . i thought about connecting 6 cards per mainboard.. but these seld-built risers seem to be very risky.. so i will just use 3 cards per mainbaord, without risers..

    To the motherboard, a 6pin PCIe connector is rated at 75W and 8 pin rated to 150W. That has to power all the PCIe slots so 3 750Ti's might be fine at upto 40W each but a fouth could kick in the motherboard's power limiting to all the cards. I've also heard the 24pin connector powers slots too so am not too sure how much is actually available.
    nvidia-smi -q -d PERFORMANCE shows active triggers that limit a card's performance like power.
  • dominusdominus Member Posts: 36
    Genoil said:

    The gpu-devices flag was quickly thrown together without actually having multiple cards, so I'll have to look at it again when I got a machine with 2 cards.

    Attached is a Win64 binary with sp_ mods.

    Hashrate-wise, on my GTX780 it unfortunately doesn't do any better than what was already there. Actually a tiny bit worse (caused by the cudaDeviceScheduleBlockingSync). But apparently that dramatically lowers CPU usage, which is a good thing! No solution for the GTX750Ti problem yet..

    Tnx for that!

    It works, no change on 3x970 hashrate but no more cpu usage!
  • antonio8antonio8 Member Posts: 44
    @Genoil

    I think I know my issue but not hash improvement on the 750ti's.

    I am still getting 100% cpu usage but after doing further research I believe my issue is that I need to delete the DAG files and let it recreate them. Here is my dilemma.

    I am getting some crazy hash rates on my 750ti's rigs and I think it is because the newly created DAG is meshing with the old ones. I am seeing from 30 Mh/s to 200 Mh/s, I know crazy.

    Now I might just be wasting my time but for the next day or so I will let it run and see if I find anything solo. I was going to just run it on the pool and see if the hashes match up but I figured I would solo as I still do better solo'ing than pool mining.

    If I see no increase in blocks then I will delete the DAG files and reboot the computer and restart to see if gpu usage has dropped.

    Fun little experiment but I'll take a chance and see how it goes.
  • SuchFakeAccountSuchFakeAccount Member Posts: 14
    For me it made no difference 1. core is still @ 100%
  • 4gun4gun Member Posts: 16
    edited August 2015
    So it looks like a mined a block, but when i check my balance it says "0", but the block shows just fine at etherchain.org?!
    EDIT: Nevermind - figured it out.
    Post edited by 4gun on
  • buechlingbuechling Member Posts: 13

    buechling said:

    i don't think there is a 175W limit? ( see above ). I think the limit is 75 W per PEG-Port ( special kind of PCI-X-Port, german: http://www.heise.de/ct/hotline/Was-ist-PEG-325734.html ), so we have 3*75W = 225W . i thought about connecting 6 cards per mainboard.. but these seld-built risers seem to be very risky.. so i will just use 3 cards per mainbaord, without risers..

    To the motherboard, a 6pin PCIe connector is rated at 75W and 8 pin rated to 150W. That has to power all the PCIe slots so 3 750Ti's might be fine at upto 40W each but a fouth could kick in the motherboard's power limiting to all the cards. I've also heard the 24pin connector powers slots too so am not too sure how much is actually available.
    none of my Cards has a PCIe connector, ( i also have no riser ), so all of the power comes from the mainboard.. but i think is has enough.. in atx 24-connector we have 3x 12V. additionally there is an 8 pin connector next to my cpu, so we have additinal 4x 12V. ATX allows 8 ampere ( https://en.wikipedia.org/wiki/ATX#Power_supply , other source also speaks about 20 ampere for new cpu.. ), so we should have 672 Watt ?
  • buechlingbuechling Member Posts: 13
    edited August 2015
    I got it. Thank you for all the hints.. so for everybidy else: here is the ultimate guide for GTX 750 Ti on linux with 9,3 Mhash and 0% CPU:

    by the way: you only need a 16 GB Usb-Stick as hard drive.. and 4 GB RAM for the CPU ( but you really speed up compiling with 8 GB and can keep multiple DAG-Files with 32 GB Stick )
    Install Ubuntu Linux 14.03 x64

    sudo -s

    wget -O - http://llvm.org/apt/llvm-snapshot.gpg.key | sudo apt-key add -
    add-apt-repository "deb http://llvm.org/apt/trusty/ llvm-toolchain-trusty main"
    add-apt-repository -y ppa:ethereum/ethereum-qt
    add-apt-repository -y ppa:ethereum/ethereum
    add-apt-repository -y ppa:ethereum/ethereum-dev
    wget http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1404/x86_64/cuda-repo-ubuntu1404_7.0-28_amd64.deb
    dpkg -i cuda-repo-ubuntu1404_7.0-28_amd64.deb
    apt-get -y update
    apt-get -y upgrade

    apt-get -y install cpp-ethereum screen cuda build-essential git cmake libboost-all-dev libgmp-dev libleveldb-dev libminiupnpc-dev libreadline-dev libncurses5-dev libcurl4-openssl-dev libcryptopp-dev libjson-rpc-cpp-dev libmicrohttpd-dev libjsoncpp-dev libargtable2-dev llvm-3.8-dev libedit-dev mesa-common-dev ocl-icd-libopencl1 opencl-headers libgoogle-perftools-dev qtbase5-dev qt5-default qtdeclarative5-dev libqt5webkit5-dev libqt5webengine5-dev ocl-icd-dev libv8-dev

    git clone https://github.com/Genoil/cpp-ethereum
    cd cpp-ethereum
    nano cmake/EthCompilerSettings.cmake
    # remove "-Werror" around line 5
    nano libethash-cu/ethash_cu_miner.cpp
    # remove cudaDeviceSetSharedMemConfig(cudaSharedMemBankSizeEightByte); around line 140
    # then add cudaSetDeviceFlags(cudaDeviceScheduleBlockingSync);
    # then add cudaDeviceSetCacheConfig(cudaFuncCachePreferL1);
    cmake -DBUNDLE=miner -DETHASHCU=1
    make -j4
    reboot
    sudo -s
    cd cpp-ethereum/ethminer/
    screen
    ./ethminer -U -F http://(yourpool) --gpu-devices 0 1 2
    with 3 cards i now get 27,3 Mhash @ 270 Watt
  • buechlingbuechling Member Posts: 13

    @buechling,

    On linux, Nvidia System Managment Interface (nvidia-smi) is the command line tool for everything we need to do. Useful commands are:
    nvidia-smi -l displays table of live stats for all cards.

    sudo nvidia-smi -pl xLimit's power to x watts (30 to 38.5 on the 750/750Ti's).

    nvidia-smi -q -d CLOCK Display GPU clocks.

    nvidia-smi -q -d SUPPORTED_CLOCKS Display supported clock settings.

    sudo nvidia-smi -ac memory,core Set application clock speeds. Check SUPPORTED_CLOCKS to see available memory/core combinations.

    sudo nvidia-smi -rhard reset GPU's (as power cycle)

    You can pick on particular cards with switch -i id where id is from 1 to number of cards you have.

    This is what I was playing with last night when my PSU died. @ennui's power throttling suggestion looks very much worth it. I didn't get to mess with the application clocks but could only seem to access them on my 750 and not the 750Ti's.

    great, thank you..
    i also cannot access clocks on GTX 750 Ti, but i can access on GTX 960

    power limit does not work.. anything i need to consider?
    nvidia-smi -pl 30
    Changing power management limit is not supported for GPU: 0000:01:00.0.
    Treating as warning and moving on.
    Changing power management limit is not supported for GPU: 0000:02:00.0.
    Treating as warning and moving on.
    Changing power management limit is not supported for GPU: 0000:07:00.0.
    Treating as warning and moving on.
    All done.
    nvidia-smi
    Mon Aug 17 19:48:18 2015
    +------------------------------------------------------+
    | NVIDIA-SMI 346.82 Driver Version: 346.82 |
    |-------------------------------+----------------------+----------------------+
    | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
    | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
    |===============================+======================+======================|
    | 0 GeForce GTX 750 Ti Off | 0000:01:00.0 N/A | N/A |
    | 32% 42C P8 N/A / N/A | 52MiB / 2047MiB | N/A Default |
    +-------------------------------+----------------------+----------------------+
    | 1 GeForce GTX 750 Ti Off | 0000:02:00.0 N/A | N/A |
    | 30% 37C P8 N/A / N/A | 7MiB / 2047MiB | N/A Default |
    +-------------------------------+----------------------+----------------------+
    | 2 GeForce GTX 750 Ti Off | 0000:07:00.0 N/A | N/A |
    | 30% 30C P8 N/A / N/A | 7MiB / 2047MiB | N/A Default |
    +-------------------------------+----------------------+----------------------+

    +-----------------------------------------------------------------------------+
    | Processes: GPU Memory |
    | GPU PID Type Process name Usage |
    |=============================================================================|
    | 0 C+G Not Supported |
    | 1 C+G Not Supported |
    | 2 C+G Not Supported |
    +-----------------------------------------------------------------------------+
  • ennuiennui Member Posts: 8
    buechling said:

    @buechling,

    On linux, Nvidia System Managment Interface (nvidia-smi) is the command line tool for everything we need to do. Useful commands are:
    nvidia-smi -l displays table of live stats for all cards.

    sudo nvidia-smi -pl xLimit's power to x watts (30 to 38.5 on the 750/750Ti's).

    nvidia-smi -q -d CLOCK Display GPU clocks.

    nvidia-smi -q -d SUPPORTED_CLOCKS Display supported clock settings.

    sudo nvidia-smi -ac memory,core Set application clock speeds. Check SUPPORTED_CLOCKS to see available memory/core combinations.

    sudo nvidia-smi -rhard reset GPU's (as power cycle)

    You can pick on particular cards with switch -i id where id is from 1 to number of cards you have.

    This is what I was playing with last night when my PSU died. @ennui's power throttling suggestion looks very much worth it. I didn't get to mess with the application clocks but could only seem to access them on my 750 and not the 750Ti's.

    great, thank you..
    i also cannot access clocks on GTX 750 Ti, but i can access on GTX 960

    power limit does not work.. anything i need to consider?
    nvidia-smi -pl 30
    Changing power management limit is not supported for GPU: 0000:01:00.0.
    Treating as warning and moving on.
    Changing power management limit is not supported for GPU: 0000:02:00.0.
    Treating as warning and moving on.
    Changing power management limit is not supported for GPU: 0000:07:00.0.
    Treating as warning and moving on.
    All done.
    nvidia-smi
    Mon Aug 17 19:48:18 2015
    +------------------------------------------------------+
    | NVIDIA-SMI 346.82 Driver Version: 346.82 |
    |-------------------------------+----------------------+----------------------+
    | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
    | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
    |===============================+======================+======================|
    | 0 GeForce GTX 750 Ti Off | 0000:01:00.0 N/A | N/A |
    | 32% 42C P8 N/A / N/A | 52MiB / 2047MiB | N/A Default |
    +-------------------------------+----------------------+----------------------+
    | 1 GeForce GTX 750 Ti Off | 0000:02:00.0 N/A | N/A |
    | 30% 37C P8 N/A / N/A | 7MiB / 2047MiB | N/A Default |
    +-------------------------------+----------------------+----------------------+
    | 2 GeForce GTX 750 Ti Off | 0000:07:00.0 N/A | N/A |
    | 30% 30C P8 N/A / N/A | 7MiB / 2047MiB | N/A Default |
    +-------------------------------+----------------------+----------------------+

    +-----------------------------------------------------------------------------+
    | Processes: GPU Memory |
    | GPU PID Type Process name Usage |
    |=============================================================================|
    | 0 C+G Not Supported |
    | 1 C+G Not Supported |
    | 2 C+G Not Supported |
    +-----------------------------------------------------------------------------+

    you need a newer driver. i had this issue when using 34x drivers. currently i'm using 352.21.
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @buechling the CPU optimizations by sp_ is already in the git repo so you can skip that. For the rest: great tutorial. Definitely plan on following it.
  • buechlingbuechling Member Posts: 13
    edited August 2015
    ennui said:

    you need a newer driver. i had this issue when using 34x drivers. currently i'm using 352.21.

    sounds good.. hint. DO NOT USE:
    wget http://de.download.nvidia.com/XFree86/Linux-x86_64/352.30/NVIDIA-Linux-x86_64-352.30.run
    chmod 700 NVIDIA-Linux-x86_64-352.30.run
    ./NVIDIA-Linux-x86_64-352.30.run

    The distribution-provided pre-install script failed! Are you sure you want to continue? -> yes
    Would you like to register the kernel module sources with DKMS? -> yes
    Install NVIDIA's 32-bit compatibility libraries? -> yes
    Would you like to run the nvidia-xconfig utility to automatically update
    your X configuration? -> yes

    reboot


    nvidia-smi
    Failed to initialize NVML: GPU access blocked by the operating system


    ./ethminer -U
    no CUDA-capable device is detected
    instead, do:
    apt-get remove nvidia*
    sudo apt-get autoremove
    add-apt-repository ppa:xorg-edgers/ppa -y
    apt-get update
    apt-get install nvidia-352 libcuda1-352
    wget http://developer.nvidia.com/compute/cuda/7.5/RC/local_installers/cuda-repo-ubuntu1404-7-5-rc_7.5-7_amd64.deb
    dpkg -i cuda-repo-ubuntu1404-7-5-rc_7.5-7_amd64.deb
    sudo apt-get -y update
    sudo apt-get -y upgrade
    apt-get -y install cuda
    ( recompile from source )
    then we see:
    nvidia-smi
    +------------------------------------------------------+
    | NVIDIA-SMI 352.30 Driver Version: 352.30 |
    |-------------------------------+----------------------+----------------------+
    | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
    | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
    |===============================+======================+======================|
    | 0 GeForce GTX 750 Ti Off | 0000:01:00.0 On | N/A |
    | 35% 66C P0 36W / 38W | 1123MiB / 2047MiB | 100% Default |
    +-------------------------------+----------------------+----------------------+
    | 1 GeForce GTX 750 Ti Off | 0000:02:00.0 Off | N/A |
    | 34% 61C P0 33W / 38W | 1087MiB / 2047MiB | 99% Default |
    +-------------------------------+----------------------+----------------------+
    | 2 GeForce GTX 750 Ti Off | 0000:07:00.0 Off | N/A |
    | 32% 55C P0 34W / 38W | 1087MiB / 2047MiB | 100% Default |
    +-------------------------------+----------------------+----------------------+

    +-----------------------------------------------------------------------------+
    | Processes: GPU Memory |
    | GPU PID Type Process name Usage |
    |=============================================================================|
    | 0 1168 G /usr/bin/X 35MiB |
    | 0 2990 C ./ethminer 1078MiB |
    | 1 2990 C ./ethminer 1078MiB |
    | 2 2990 C ./ethminer 1078MiB |
    +-----------------------------------------------------------------------------+
    now we can set the power limit. i recommend:
    nvidia-smi -pl 30

    as you can see in this table, we save additional 28 Watt for 3x 750 Ti

    Limit 35 W - 27,9 Mhash - 267 W
    Limit 34 W - 27,8 Mhash - 257 W
    Limit 33 W - 27,8 Mhash - 253 W
    Limit 32 W - 27,7 Mhash - 250 W
    Limit 31 W - 27,7 Mhash - 245 W
    Limit 31 W - 27,7 Mhash - 245 W
    Limit 30 W - 27,7 Mhash - 239 W
    ( <30 not allowed )
    Post edited by buechling on
  • antonio8antonio8 Member Posts: 44
    edited August 2015
    Quick update. Lost power for about half the day while I was at work but from over night to now here is what my hash looks like with the 750ti doing crazy hashes.

    2 rigs of 960 and 970 doing about 70 Mh/s. Etherapps explorer shows my hash about 130 Mh/s now so the 750ti about 60 Mh/s but not sure if the speed is rising as that explorer is slow as molasses to update.

    Will see at the end of the day if it improves.

    So as of now the 750ti's are doing 12 Mh/s.

    EDIT: Looks like the cpu issues ramps my hashes wildly. I can get between 2 to 12 Mh/s depending on the load.
    Post edited by antonio8 on
  • farwarefarware Member Posts: 116
    4gun said:

    So it looks like a mined a block, but when i check my balance it says "0", but the block shows just fine at etherchain.org?!
    EDIT: Nevermind - figured it out.

    Please post your solution so others with the same problem wont have to search. Thanks
  • ptkptk Member Posts: 10
    edited August 2015
    buechling said:


    now we can set the power limit. i recommend:
    nvidia-smi -pl 30

    as you can see in this table, we save additional 28 Watt for 3x 750 Ti

    Limit 35 W - 27,9 Mhash - 267 W
    Limit 34 W - 27,8 Mhash - 257 W
    Limit 33 W - 27,8 Mhash - 253 W
    Limit 32 W - 27,7 Mhash - 250 W
    Limit 31 W - 27,7 Mhash - 245 W
    Limit 31 W - 27,7 Mhash - 245 W
    Limit 30 W - 27,7 Mhash - 239 W
    ( <30 not allowed )</p>



    750 Ti's are 60 watt cards, not 30/35/whatever and nvidia-smi is using the wrong numbers. The read and set values in smi work on a percentage basis so for example setting 27W limit on a supposedly 35W card means 46W limit on 60W in reality (77%). Measure your power consumption at the wall and don't trust software based power consumption figures.

    On another note, does anyone have a fix for 750 Ti's only doing 1-2mh/s on windows?

  • cryptletcryptlet Member Posts: 29
    @ptk There is no known fix. My 750Ti too hashing only at 2.2MHs
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @ptk it has my full attention, as I'm suffering from the problem as well. But no fix yet.
  • ptkptk Member Posts: 10
    @Genoil 8.8 mhs only works for me with 1 card and only in benchmark mode but I have no idea why even though I consider myself a seasoned miner and I have spent more time with different settings than I care to admit. In case of solo-/poolmining even with 1-2 mh/s per card, the more card I use the slower they start hashing. Some cards will take as long as 10-15 seconds to start hashing (meaning GPU usage is 0% for that period). So my uneducated guess is that for some reason the miner doesn't initialize the cards properly. Or my last longshot of an idea was that win7 have terrible file caching and so it might not use the dagger files properly but I have no basis to prove it.
  • corsarocorsaro Member Posts: 28
    cryptlet said:

    @ptk There is no known fix. My 750Ti too hashing only at 2.2MHs

    mine at 5 Mhs with shuffled version

  • antonio8antonio8 Member Posts: 44
    I am pretty much done messing with the 750ti rig.

    The crazy hashes would report but the machine bogs down so much that it does not make it worth it.

    I deleted the dag files in the eth folder in appdata with the latest release the has the cpu usage dropped but unfortunately for me it does no good. Still have 100% cpu usage.

    tried everything and it just does not work for my setup. Definitely something to do with the 750ti's. Not sure about my cpu usage as it is an AMD 1100t. Even tried to set affinity to two cores with task manager and it did not help.
  • scryptrscryptr Member Posts: 20
    @ antonio8-- I have a rig with 1 GTX 960 and 4 GTX 750ti. I set it up to mine solo with a wallet within my LAN. It mines, and I get a hash rate of up to 64,000,000 H/s that immediately tapers down to 15,000,000 H/s. On the computer with the wallet, I have a GTX 960 that hashes at a steady 10,500,00 H/s. SO, my 750ti cards are getting about 1Mh/s for any work cycle longer that about 10ms. My 750ti cards are on Win 8.

    The hash seems to be distributed across all the cards in the multi-card rig. A GTX 960 gets about 10.5Mh/s on both my machines. The 750ti cards "burst" at high capacity, then taper down to ~1Mh/s. All hash reports are for a combined total, there are no individual card hash-rate reports as on CudaMiner (C. Buchner) or the later CCminer.

    Further, on the multi-card rig, the Memory Control Unit of GPU 0 (a GTX 960) is at 100%, while the MCU on the 750ti cards is 1 or 2 digits (10% -20%).

    I've been solo-mining since Friday PM and solved 2 blocks (10 ETH). I am mining at about 25Mh/s average.

    @Genoil-- Is the work not being shared properly?

    --scryptr
  • antonio8antonio8 Member Posts: 44
    scryptr said:

    @ antonio8-- I have a rig with 1 GTX 960 and 4 GTX 750ti. I set it up to mine solo with a wallet within my LAN. It mines, and I get a hash rate of up to 64,000,000 H/s that immediately tapers down to 15,000,000 H/s. On the computer with the wallet, I have a GTX 960 that hashes at a steady 10,500,00 H/s. SO, my 750ti cards are getting about 1Mh/s for any work cycle longer that about 10ms. My 750ti cards are on Win 8.

    The hash seems to be distributed across all the cards in the multi-card rig. A GTX 960 gets about 10.5Mh/s on both my machines. The 750ti cards "burst" at high capacity, then taper down to ~1Mh/s. All hash reports are for a combined total, there are no individual card hash-rate reports as on CudaMiner (C. Buchner) or the later CCminer.

    Further, on the multi-card rig, the Memory Control Unit of GPU 0 (a GTX 960) is at 100%, while the MCU on the 750ti cards is 1 or 2 digits (10% -20%).

    I've been solo-mining since Friday PM and solved 2 blocks (10 ETH). I am mining at about 25Mh/s average.

    @Genoil-- Is the work not being shared properly?

    --scryptr

    scryptr

    We are in the same boat on our issues. The only difference is I am on Windows 7 and using driver 353.30

    I am seeing the exact same issues on my end but the cards ramp up to 18-27 Mh/s and down to about 2 mh/s. I also have the same issue with power usage but my 960's only use about 60-70% while the 750 ti's stay under 28%. My 970 does go up to about 91% though.

    What I can't figure out now is why my cpu usage pegs at 100% with the latest release.

    I have found 3 blocks and 1 uncle in the last 2 days after leaving the pool.

  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    edited August 2015
    I have tested tpruvot's CPU fix and it does indeed lower CPU stress. But it comes at the cost of 2-4% hashing power. I've merged his changes into my repo, with an additional launch param. If you don't care about CPU load, you can add --high-cpu-load.

    (updated binary to try. maybe this fixes the dreaded windows/gtx750 bug)
    Post edited by Genoil on
  • scryptrscryptr Member Posts: 20
    tp-modded ethminer--

    I tried the posted build, and the gpu load was indeed reduced. I also noticed that the cpu load was low, but I had good results with low cpu load with the sp-modded version. The sp-modded version does max out the gpu load, but my dedicated mining rig doesn't do anything but mine. Both versions performed with lower cpu load for me, and that is important, as I can do odd tasks when required without a struggle.

    Neither version has fixed the 750ti bug. I am considering loading Ubuntu on a USB stick so that I can dual-boot the mining rig, and keep the Windows system intact. I'd really like to be able to get full performance out of my 750ti cards. --scryptr
  • Epsylon3Epsylon3 Member Posts: 4
    edited August 2015
    The cpu fix was primary made for linux, the miner alone (on a pool) was using all the cores at 100% (i5-3570K ubuntu 14.04) ... well 100W
    Post edited by Epsylon3 on
  • Bensam123Bensam123 Member Posts: 62
    edited August 2015
    Weird bug. When using the miner (no matter the version) it tries using my AMD 4250 integrated graphics. The -G switch, even when using --opencl-platform or --opencl-device to change devices it will still try to use the 4250 and wont touch my normal mining GPUs. The weird thing about this is my 4250 is disabled in the bios and doesn't even show up in device manager. The 4250 is integrated into my GPU.

    However, I can use the -U switch to use cuda and switch to my normal mining GPUs. I have 970s I mine with.

    Also the --opencl-device doesn't work for more then one device even though it's worked in past versions. I'm using Genoils compiled version a couple posts up.

    Additionally the difference between --high-cpu-load and not using the flag is about 20% hashrate depending on the system.
    Post edited by Bensam123 on
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @Bensam123 generally speaking, the scope of my CUDA miner is limited to everything behind the -U switch. The --opencl-device switch should still work though (instead it should select a CUDA device), although I have replaces it with a more flexible --gpu-devices. Then again, that seems to be broken still.

    I have noticed that NOT using --high-cpu-load in combination with more than 2 --gpu-mining-threads can lead to severe performance drop.
  • buechlingbuechling Member Posts: 13
    ptk said:

    buechling said:


    now we can set the power limit. i recommend:
    nvidia-smi -pl 30

    as you can see in this table, we save additional 28 Watt for 3x 750 Ti

    Limit 35 W - 27,9 Mhash - 267 W
    Limit 34 W - 27,8 Mhash - 257 W
    Limit 33 W - 27,8 Mhash - 253 W
    Limit 32 W - 27,7 Mhash - 250 W
    Limit 31 W - 27,7 Mhash - 245 W
    Limit 31 W - 27,7 Mhash - 245 W
    Limit 30 W - 27,7 Mhash - 239 W
    ( <30 not allowed )</p>



    750 Ti's are 60 watt cards, not 30/35/whatever and nvidia-smi is using the wrong numbers. The read and set values in smi work on a percentage basis so for example setting 27W limit on a supposedly 35W card means 46W limit on 60W in reality (77%). Measure your power consumption at the wall and don't trust software based power consumption figures.
    the consumption ( 239W - 267W ) is of course measured at the wall..

  • Bensam123Bensam123 Member Posts: 62
    Genoil said:

    @Bensam123 generally speaking, the scope of my CUDA miner is limited to everything behind the -U switch. The --opencl-device switch should still work though (instead it should select a CUDA device), although I have replaces it with a more flexible --gpu-devices. Then again, that seems to be broken still.

    I have noticed that NOT using --high-cpu-load in combination with more than 2 --gpu-mining-threads can lead to severe performance drop.

    That could be true, I haven't tried it with less then two devices.

    Not sure what you meant about the scope of the cuda switch. Just stating what's happening. Two different issues.

    --opencl-device (when using OpenCL and -G) doesn't allow you to select more then one graphics card. For instance --opencl-device 0 1 will only use 0. Doing --opencl-device 1 will use device 1. It wont use more then one graphics card in the latest version. -G with the latest version without using --opencl-device wont even use more then one card by default.

    The second bug has to due with one of my systems that has a A4-4250 APU. The integrated graphics is disabled in the bios and doesn't show up in device manager.

    However using the -G switch it will try using the integrated graphics regardless of using --opencl-devices or --opencl-platform. I can't seem to stop it from using the IGP. Of course it doesn't work either.

    -U for cuda seems to work fine and the hashrate is about the same, although limited to 8 devices for some reason?

Sign In or Register to comment.