CUDA miner

1242527293069

Comments

  • restlessrestless Member Posts: 80
    Is mining on Win7 possible ? Tried again with 750Ti, but speed is ~ 200kh/s :(
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @restless only with compute 5.2 cards. 750ti is Compute 5.0
  • simplysimply Member Posts: 10
    I haven't read all pages in this thread, but the problem with windows 10 with NVIDIA cards is in the drivers. I have managed to get the same hashrate like windows 7, but only with the driver version 347.52. This driver version is for windows 7, but it works perfectly with windows 10. Hope that it will help to someone.
  • hawtdawghawtdawg Member Posts: 1
    It's a huge help to me. I mined some about 6 months ago using windows 10 and was getting 20+ mh/s with a 980ti, and couldn't for the life of me figure out why I was only getting 8 now that im mining again.
  • simplysimply Member Posts: 10
    Glad to help. If you continue to using the windows 10 new nvidia drivers you will getting lower and lower hashrate over time, because it is tied with the DAG size. Over time the DAG size increases and the hashrate of mining ethereum decreases
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    edited February 2016
    @simply this sounds like a fairly practical solution to the issues a lot of people are having with Win8/10. Thanks a lot fore testing and confirming it works. There is indeed quite a difference in driver implementation regarding GPU virtual memory addressing between Win7 and 8/10.

    btw even for GTX750Ti it should help a bit, altough the full 8.5MH/s can never be made even with Win7 drivers.
  • simplysimply Member Posts: 10
    I'm testing every new windows 10 driver, but the problem still remains. I own GTX970 (GV-N970WF3OC-4GD) and with the old windows 7 driver I get around 16.9 MHs and with new one it is only 7.3 MHs
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @simply yes I have extensively looked into this. Apparently the issue has raised some attention within NVidia, but no solution yet. More details & technical discussion here: https://devtalk.nvidia.com/default/topic/878455/gtx750ti-and-buffers-gt-1gb-on-win7/ (i thought to be gtx750 only issue at first, hence the topic title)
  • simplysimply Member Posts: 10
    @Genoil Btw I have a problem with versions 1.0.2 and 1.0.3. It gives me following error: CUDA error in func 'ethash_cuda_miner::getNumDevices' at line 112 : CUDA driver version is insufficient for CUDA runtime version.
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @simply yes i was awaiting that one sometime, had it too on one system. Ended up building from source on the machine that had it. Do you have CUDA toolkit installed by any chance?
  • simplysimply Member Posts: 10
  • 4gun4gun Member Posts: 16
    How much RAM do I need for a 7xGTX970 rig? It kind of works but it looks like it's dying at start- ethminer spits out on the monitor a character a second (after the dag files are created). But after a while (a minute or two) it starts hashing just fine averaging 18,5MHs/card. (win8.1x64/8GB). So my question @Genoil is will I gain any performance if I double the RAM or it's pointless?
  • happytreefriendshappytreefriends Member Posts: 537 ✭✭✭
    edited February 2016
    Check your CPU usage. Your CPU might be too slow. I get the same when I limit my AMD FX 6-core cpu to 2-cores.

    Also, 18.5MH per a GTX970 is VERY good.
  • kingcolexkingcolex Member Posts: 4
    I am getting around 10mh/s on my 960 but the issue is it is only picking up one card, I can't get the second card mining. Any ideas why?
  • kingcolexkingcolex Member Posts: 4
    BOSS said:

    And is it normal, that my 780Ti have 7MH/s?

    Not a maxwell card, I would guess so.
  • bearbear russiaMember Posts: 1
    edited February 2016
    hello
    i'm using gtx660 not OC and my hashrate ~7MH/s (+-0.5)
    its good or bad rate?
    and sorry at my english)))
  • SergeantSergeant Member Posts: 9
    @kingcolex - maybe need to add "--cuda-devices 0 1" to starting config. Help says that all cards should work by default but in my case they are not until I declare them explicitly (ethminer-0.9.41-genoil-1.0.3).
  • SergeantSergeant Member Posts: 9
    @bear - for GTX660 I think it's OK as soon as I'm doing ~10MH/s on GTX770
  • SergeantSergeant Member Posts: 9
    @Genoil - barabeku complained some time ago that v.1.0.3 does not submit shares on K520 in Win 7. I have similar problem: my GTX680 and 2xGTX770 do same. Interesting thing is that official ethminer works ok and cards make ~10 MH/s each. In ethminer-0.9.41-genoil-1.0.3 each card shows 16 MH/s (wow) but not a single share is produced for hours. I ran it with -S -U parameters as you suggested and it sticks to difficulty 20. Exactly as predicted.

    Any ideas of what to do next?
  • SergeantSergeant Member Posts: 9
    @bear what miner version, video driver version and OS you use? If by the chance you succeeded to make GTX660 work with genoil 1.0.3 miner on Win7, then there is still a chance for me also.
  • restlessrestless Member Posts: 80
    Can someone help with building miner under Ubuntu 15.04?
    My problem is that the build-machine is behind a firewall and trying generic etehereum build fails (firewall works as man-in-the-middle on https)

    But all I need is building just the miner, right?
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @Sergeant GTX680 and 770 are also Compute 3.0. I had already dropped support for 3.0 a while ago, but due to a similar issue with Compute 5.2, I had to roll back a few commits and ended up on a version that did still have 3.0 support. For 1.0.4, I'm actually removing 3.0 support again.

    There is a compute30 branch in my repo that has better performance in CUDA than the master repo when it would work, but it's a bit a behind on other features. different command lien switches, no CUDA scheduling support, etc..

    Ultimately I should be able to get full support for 3.0 in the master branch again. It's mostly a matter of reorganizing source code. But I don't have too much time to work on ethminer these days.

  • restlessrestless Member Posts: 80
    Can someone give a link to the built miner binary for Ubuntu 15.04?
    After 3 hours downloading and building I yet have to download&install cuda, then QT5webengine :(

  • restlessrestless Member Posts: 80
    and now stucked at building qt5webengine:
    qmake -r

    Unmet dependency: dbus-1
    Unmet dependency: fontconfig
    Unmet dependency: xi
    Unmet dependency: xscrnsaver
    Unmet dependency: xtst
    Unmet dependency: libpulse
    Unmet dependency: libpng
    Unmet dependency: harfbuzz
    Unmet dependency: libpci
    QtWebEngine will not be built.
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    Are you using my fork or the official repo? If you use my fork, you shouldn't have to build QT. For the official one I'm not sure, as it might be tied up with alethOne. Still on my todo list to clean up all stuff that ethminer doesn't need...
  • restlessrestless Member Posts: 80
    Now i tried your source

    It does seem to compile - using cmake from page 2 of this thread
    /tmp/ethminer/cpp-ethereum-master$ cmake -DBUNDLE=miner -DETHASHCU=1 -DCOMPUTE=50 -DMAXREGCOUNT=72

    Result is:
    ........

    creating build info...
    createBuildInfo()
    -- Configuring done
    -- Generating done
    -- Build files have been written to: /tmp/ethminer/cpp-ethereum-master

    aaaaand.
    Where should I find the binary :smile:

    all dependencies seem ok, except cpuid - -- Could NOT find cpuid (missing: CPUID_INCLUDE_DIR CPUID_LIBRARY)

    apt-get install cpuid doesn't solve it :/
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    You've just ran cmake. This means nothing is built yet, you have only generated the makefiles for Linux. You still have to build the project using "make" (and "make install" i believe, i'm mostly a Windows guy). BTW the cmake command line args you have supplied indicate you want to build for GTX750Ti: -DCOMPUTE=50). Is that correct? If you want to build for multiple compute versions, use this:

    cmake -DBUNDLE=cudaminer

    For Compute 5.2 only:

    cmake -DBUNDLE=cudaminer -DCOMPUTE=52

    If you have only GTX9x0 cards, this makes smaller binaries and faster compilation.

    MAXREGCOUNT is also not required. It's handled differently for a while now.
  • restlessrestless Member Posts: 80
    edited February 2016
    almost succeeded:
    [100%] Building CXX object ethminer/CMakeFiles/ethminer.dir/main.cpp.o
    Linking CXX executable ethminer
    ../libethash/libethash.so: error: undefined reference to 'vtable for CryptoPP::SHA3'
    /usr/bin/ld.gold: the vtable symbol may be undefined because the class is missing its key function
    ../libethash/libethash.so: error: undefined reference to 'CryptoPP::SHA3::Restart()'
    ../libethash/libethash.so: error: undefined reference to 'CryptoPP::SHA3::Update(unsigned char const*, unsigned long)'
    ../libethash/libethash.so: error: undefined reference to 'CryptoPP::SHA3::TruncatedFinal(unsigned char*, unsigned long)'
    ../libethash/libethash.so: error: undefined reference to 'typeinfo for CryptoPP::SHA3'
    collect2: error: ld returned 1 exit status
    ethminer/CMakeFiles/ethminer.dir/build.make:106: recipe for target 'ethminer/ethminer' failed
    make[2]: *** [ethminer/ethminer] Error 1
    CMakeFiles/Makefile2:506: recipe for target 'ethminer/CMakeFiles/ethminer.dir/all' failed
    

    PS:
    used https://github.com/ethereum/cpp-ethereum/issues/46
    and it worked.
    executable ethminer compiled :open_mouth:
    Jesus.
    Will try with gpu inside... but tomorrow.
  • aqalaqal Member Posts: 2

    I GTS250 graphics card -one general Mein ? or very old for such cases ?
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    aqal said:


    I GTS250 graphics card -one general Mein ? or very old for such cases ?

    Too old
Sign In or Register to comment.