Mining doesn't seem to be working

sjosephsjoseph Member Posts: 30
When I try to mine, I keep getting the following error:

I0519 17:19:56.763835 3420 ethash.go:214] Still generating DAG: 98%
I0519 17:20:01.300608 3420 ethash.go:214] Still generating DAG: 99%
I0519 17:20:06.317566 3420 ethash.go:214] Still generating DAG: 100%
I0519 17:20:06.319951 3420 ethash.go:203] Done generating DAG for epoch 2, it took 7m35.916652336s
I0519 17:20:54.422293 3420 miner.go:81] Can not start mining operation due to network sync (starts when finished)

Any thoughts on what is causing the issue. I am getting this issue the last 1-2 days. Prior to that it seemed fine.

Comments

  • Maren85Maren85 Member Posts: 41
    edited May 2015
    It tells you right there, in bold writing, you can't mine until you've fully downloaded the blockchain which can take upto 3 hours, the dag is different.

    It says so on most mining faq's and in most threads on this site and in your own error msg.

    Stop being in a rush to mine, what until you've caught up with the blockchain, then mine.
  • sjosephsjoseph Member Posts: 30
    I actually had it running overnight ( more than 3 hrs) and still got the error. Hence I assumed there might be some other issue in terms of network sync.
  • Maren85Maren85 Member Posts: 41
    I made the same mistake your making over and over, I used the Network Status Monitor to see what block the real chain was up to then just waited until I had got there too and starting mining and no problems
  • StephanTualStephanTual London, EnglandMember, Moderator Posts: 1,282 mod
    @sjoseph I was having that error this morning, wouldn't sync despite solid network connectivity, a reboot later and it was happy again.
Sign In or Register to comment.