Meteor DApp Cosmo - A Realtime Solidity Development Environment

2»

Comments

  • SilentCiceroSilentCicero Toronto, CAMember Posts: 159 ✭✭✭
    Just made an update to Cosmo, here is what was added:

    1. Contract Storage: your most recent contract is saved in the Browser's local store, so that you dont loose it in a crash or accidental close.
    2. RPC Setting Storage: your most recent RPC setting is now saved in the Browser's local store, you no longer need to re-enter it everytime you open Cosmo.
    3. Event handling: an event handling interface for watching events.
    4. Contract Templates: a few common Solidity template examples (i.e. coin, crowdfunding, simple storage, ballot and namereg).
    5. Upgrade to Web3.js v5

    If your having any trouble with the new build, please let me know either here or on Twitter. Cheers!
  • SilentCiceroSilentCicero Toronto, CAMember Posts: 159 ✭✭✭
    July 16th: just updated with latest web3.js v8.1, SOLJSON.js, and cleaned up accounts load staging.

    Repo available here:
    https://github.com/SilentCicero/meteor-dapp-cosmo

    Alpha here:
    http://meteor-dapp-cosmo.meteor.com/

    Still much to add and fix. But all in all, it's updated.
  • piyushthapa4piyushthapa4 Member Posts: 2
    looks cool.. Meteor is awesome hacking into the code thanks..
  • m88888mm88888m Member Posts: 3
    Hi SilentCicero,

    Thanks a lot for all the work, this looks awesome :)

    Could you please help me with the following issue:
    When I start your DAPP, I can connect to Geth successfully.

    However, unlocking my account does not seem to register.
    Please note that unlock=primary is depreciated, so I use unlock=3 (my third account is my main account).

    Here's the GETH console output (confirming the unlocked account):
    Account '3' unlocked. I0828 12:28:04.477920 26031 ipc_unix.go:104] IPC service started (/home/m/.ethereum_experiment/geth.ipc) instance: Geth/v1.1.0/linux/go1.4.2 datadir: /home/m/.ethereum_experiment coinbase: 0x2fe44e8e1d10caa2d03ec7810fb93d3e6a53ba9d at block: 3194 (Thu, 20 Aug 2015 16:09:16 CEST) modules: admin:1.0 db:1.0 debug:1.0 eth:1.0 miner:1.0 net:1.0 personal:1.0 shh:1.0 txpool:1.0 web3:1.0
    And here is the error I get from cosmo:
    Web3 Connected! HTTPProvider -> http://localhost:8080 Your contract is being deployed. This may take a minute... Error: could not unlock signer account
    What am I doing wrong?
    Thanks a lot :)
  • SilentCiceroSilentCicero Toronto, CAMember Posts: 159 ✭✭✭
    Hmm, have you tried with another account @m88888m? You may also want to try unlock=2 if your account is the third account, as I believe the account indexing starts at 0, for your first account and then continues upward from there.
  • m88888mm88888m Member Posts: 3
    edited September 2015
    Actually, you're right with the indexing, I was under the assumption that index value start at 1.
    So unlocking works now, if I set it to 0 (my first account, it has a Ether balance). It still does not work for setting it to any other account (where I also have Ether balance).
    So I assume I need to work with account 0 per default, correct?

    On another note: how can I adjust the gas Price limit within the DAPP? If I deploy with unlocked account 0, I get the message
    Your contract is being deployed. This may take a minute...
    Error: Exceeds block gas limit
  • FlanaganFlanagan Member Posts: 15
    Loving Cosmo at the moment, helping me a lot to understand Ethereum.

    One task I am finding difficult is iterating through data structures so I can view the contents.. I can write to them within the contract no problem, but how to retrieve the contents, preferably in Cosmo or via web3?
  • sansky09sansky09 Member Posts: 13
    This is looking great! Any chance of bringing in the web3-js?
    Regards,
  • sansky09sansky09 Member Posts: 13
    Quick question though. What is this little window that seems to be out of layout?
  • SilentCiceroSilentCicero Toronto, CAMember Posts: 159 ✭✭✭
    @sansky09 thanks for the find! Cosmo needs to undergo some major updates. I'll see what I can do over the next while. That looks largely visual, I may be able to provide a fix shortly.
  • jaguargjaguarg Member Posts: 15
    Hi,
    I got Cosmo up and running pretty smoothly - Very neat indeed, but how do I:
    a/ Remove the default contracts that are listed on left hand-side (Ballot, SimpleStore, NameReg, Coin, CrowdFunding)
    b/ How do I create my own contracts?

    Thanks
  • sansky09sansky09 Member Posts: 13
    I stupidly updated to the latest meteor 1.2 and now the app wont work! I am new to meteor so trying to figure out the change needed to source code. But any quick fix pointers would be great!
  • sansky09sansky09 Member Posts: 13
    edited September 2015
    Darn. Nothing worked ... just uninstalled/reinstalled Meteor. Works fine now.
  • jaguargjaguarg Member Posts: 15
    Hi am stuck with this js error:

    Uncaught Error: No such function: i18n

    help , please :-)
  • SilentCiceroSilentCicero Toronto, CAMember Posts: 159 ✭✭✭
    @jaguarg custom savable contracts will be available as a feature in the next release. Currently, the contracts available are just templates.

    @sansky09 updating Meteor may invalidate some of the functions or methods in Cosmo, I'd recommend avoiding that.

    @jaguarg that looks like a problem with the i18n tap. I'll see if I can fix it in the next commit. Just working on WeiFund right now :)

    Cheers,
    Nick.
  • ILethereumILethereum Member Posts: 34
    This is Great! Nice job.
  • ShruthiShruthi Member Posts: 3
    Cosmo is awesome! Works really well. When could we expect the account toggling feature? Currently I have multiple accounts and 'Transact' always uses my primary account address. Is it possible to force other accounts to execute transact without restarting geth?
  • gxugxu Member Posts: 18
    I got "meteor not found" after the installation:

    $ git clone http://github.com/SilentCicero/meteor-dapp-cosmo.git
    Start a local geth node:

    $ geth --rpc --rpcaddr="localhost" --mine --unlock=primary --rpcport="8080" --rpccorsdomain="http://localhost:3000" --loglevel=5 --maxpeers=0
    Start Cosmo using Meteor

    $ cd meteor-dapp-cosmo/app
    $ meteor
  • SilentCiceroSilentCicero Toronto, CAMember Posts: 159 ✭✭✭
    @gxu you need to have Meteor installed.

    $ curl https://install.meteor.com/ | sh
Sign In or Register to comment.