Data in contract deleted after peer connecting to private chain

Shadow358Shadow358 Member Posts: 10
Hello guys,

I am in an awkward situation.... I have a contract uploaded to my private chain which includes structs and some other fields. Everything worked fine at the beginning , I was able to make multiple structures and retrieve data from them using the JS API. A problem occurred when a friend of mine connected to my network and tried to use the contract from his AlethZero (v0.8.2) .. I tried to retrieve information from the same structs I had created before but it was not possible anymore.. the terminal showed the following error:

QSslSocket: cannot resolve TLSv1_1_client_method
QSslSocket: cannot resolve TLSv1_2_client_method
QSslSocket: cannot resolve TLSv1_1_server_method
QSslSocket: cannot resolve TLSv1_2_server_method
QSslSocket: cannot resolve SSL_select_next_proto
QSslSocket: cannot resolve SSL_CTX_set_next_proto_select_cb
QSslSocket: cannot resolve SSL_get0_next_proto_negotiated

So It was like all the data from my contract had flushed and gone forever..The contract was . I was not able to add new structs as well as like my contract was broken
Post edited by Shadow358 on
Sign In or Register to comment.