GPU Mining Software - NVIDIA/AMD?

124678

Comments

  • darkmatterdarkmatter Member Posts: 12 mod
    Has anyone tried ATI 260x's yet? If so, results?
  • eth001eth001 Member Posts: 14
    I have some problem who can help me thanks
    Warming USING 0: GeForce GTX 76
    up...
    Using device: GeForce GTX 760 (O
    Trial 1... 6813472
    Trial 2... 6900825
    Trial 3... 6813472
    Trial 4... 6813472
    Trial 5... 6813472
    *** [ 09:17:24 | main ] Stopping
    *** [ 09:17:24 | gpuminer ] Fini
    *** [ 09:17:25 | main ] Terminat
    min/mean/max: 6813472/6830942/69
    inner mean: 6842589 H/s
    Phoning home to find world ranki
    Error phoning home. ET is sad.
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @eth001 nothing wrong there. It looks a bit weird with two threads writing to the console at the same time. ET being sad is because the necmahmrking results server is offline: http://gav.ethdev.com:3000/

    hashrate is a bit disappointing for a 760 though. My 750 does better.
  • eth001eth001 Member Posts: 14
    @Genoil you mean I can mine eth now?
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @eth001 yes, but the real 'genesis' hasn't happened yet, so you can only mine eth on the testnet. but if you plan to mine real eth after the real launch, i would defintely make sure to get everything ready on the testnet.
  • timothyjcoultertimothyjcoulter Member Posts: 14
    edited May 2015
    I've gotten past the double thread issue by running it like this:

    eth.exe 2> out.tx

    And then tailing out.txt.

    Has anyone had success getting miniupnpc inlcluded on the Windows build? Without it, downloading the blockchain is very slow (I'm assuming that's the cause). I can download blocks from some peers by doing port forwarding with my router, but I only seem to get 1000 or so blocks per hour. Obviously that's too long.

    I get linker errors when I compile miniupnpc on its own and include the .lib file in cmake.
    Post edited by timothyjcoulter on
  • jzenjzen Member Posts: 49
    For those of you here that have successfully utilized gpu mining, would you please list the gpu's used, make and model, average sustained H/s rate foreach one, and on which operating system and version. Thanx!
  • TalkingAntColonyTalkingAntColony Member Posts: 9
    I can't get ethminer to do GPU mining with any parameters. Even with --opencl it does CPU. I'm on 64-bit Win8 and tried compiling both 32-bit and 64-bit versions of the latest working develop build.

    When CPU mining, the 64-bit version displays faster hashrates (nearly double) than 32-bit, but sometimes prints out new text very slowly.

    I'm using AMD 290x with i7 5930k.

    Anybody got any tips for getting it working on Windows?
  • jzenjzen Member Posts: 49
    @TalkingAntColony Did you pass the -DETHASHCL=1 flag to cmake when building?
  • zeelzebubzeelzebub Member Posts: 13
    edited May 2015
    R9-290x Ubuntu 64-bit, built cpp-ethereum on 5/12/2015, mining with alethzero. Averaging 23,000kH/s.
  • TalkingAntColonyTalkingAntColony Member Posts: 9
    @jzen thanks that did the trick
  • zeelzebubzeelzebub Member Posts: 13
    edited May 2015
    I'm running three GPU miners all Alethzero on Trusty 64 bit. One is an AMD R9-290x, it works fine; but my other two - an ATI HD5830 and an R9-270x are causing ethereum to halt with frequent messages of "Error GPU mining. GPU memory fragmentation?" - I've removed ~/.ethash a few times and rebuilt the DAG, but it's a continuing issue. It's too late to poke into it tonight, but I wanted to point it out in case I'm not the only one. Basically, they will mine for about 20 minutes before Alethzero becomes non-responsive. The system doesn't show any memory problems and I don't have tools to evaluate the GPU memory.

    Just a little more poking before I head to bed. I looked at (what I believe is) the DAG, under ~/.ethash/full-R23 ... and the files are the same on my good miners and failed miners. The md5sum is the same on all three, so the file isn't a problem. Not sure where else to look.

    My next trick is probably a joke - pulling power from the GPU's for awhile to find out if it will affect the onboard memory.
  • zeelzebubzeelzebub Member Posts: 13
    I'm currently considering that I may be using a non-compatible version of the AMD SDK or fglrx.
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @zeelzebub don't be fooled by the error message. It looks quite specific, but in fact it is thrown for any GPU mining error. If you really plan on digging into it, you should try out AMD's OpenGL/CL debugger . Can't use it myself as I don't own any AMD cards any longer. As for the HD5830, it probably doesn't have more than 1GB RAM , does it? Current DAG size is already 1.13GB, so it's not going to cut it.
  • eth001eth001 Member Posts: 14
    @Genoil
    7. create cpp-ethereum/build and go there
    when I cd build and run cmake , folder build is an empty folder? cmake warn ,there is no Cmakelist.txt in this directory
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @eth001 note the trailing ".." in

    8. cmake -DETHASHCL=1 -G "Visual Studio 12 2013 Win64" ..
  • attollosattollos Member Posts: 1
    Has anyone tried GPU mining on Mac Book Pro Retina ? I've built cpp-ethereum with necessary flags but whenever I try to benchmark or mine I get this:

    Benchmarking on platform: { "platform": "Apple", "device": "Intel(R) Core(TM) i7-5557U CPU @ 3.10GHz", "version": "OpenCL 1.2 " }
    Preparing DAG...
    Using platform: Apple
    Using device: Intel(R) Core(TM) i7-5557U CPU @ 3.10GHz(OpenCL 1.2 )
    Using platform: Apple
    Using device: Intel(R) Iris(TM)W aGrrmaipnhgi cusp .6.1.0.0(OpenCL 1.2 )

    ✘ 15:21:06|gpuminer0 Error GPU mining. GPU memory fragmentation?

    Thanks
  • eth001eth001 Member Posts: 14
    @Genoil
    E:\cpp-ethereum\build>cmake -DETHASHCL=1 -G "Visual Studio 12 2013 Win64" .
    CMake Error: Could not create named generator Visual Studio 12 2013 Win64
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    edited May 2015
    @eth001 I'm not sure what causes this. What versions of Windows/CMake/Visual Studio are you running?

    @atollos it tries to use both your CPU and iGPU. The gpuminer0 crashes, so CPU isn't supported. Try launching with an additional parameter --opencl-device 1. If this also fails, your MBP can't GPU mine.
  • arkanaprotegoarkanaprotego Member Posts: 3
    edited May 2015
    When I try to compile in VS2013 I get the following error:
    error C2783: 'std::shared_ptr<_Ty> std::make_shared(_Types &&...)' : could not deduce template argument for '_Ty' (D:\ethereum\cpp-ethereum\libevmasm\KnownState.cpp) d:\ethereum\cpp-ethereum\libevmasm\KnownState.h 74 1 evmasm
    Has anybody else run into this?
  • creoncreon Member Posts: 2
    Hi, I just wanted to report that I am also running into the "Error GPU mining" error. Its a multi GPU system, all NVIDIA Maxwell cards (2xTi750/2xGTX970) with CUDA OpenCL 1.1 on Linux Mint 64bit. The benchmark runs fine and outputs good hash rates. I can also see that the benchmark fills up about 1.2 GB of the GPU memory.

    However, when enabling the same configuration in the call to eth then I cannot see any change in the amount of memory occupied on the GPU and I keep getting an output like this:

    ⚡ 15:43:09|gpuminer0 Worker stopping 3.8672 s
    ✘ 15:43:09|gpuminer0 Error GPU mining. GPU memory fragmentation?
  • eth001eth001 Member Posts: 14
    @Genoil as you said I get some progress ,thank you ,but I cannot find some LIBRARYs in cmake could you help me !
    1.READLINE
    2.MINIUPNPC
    3.GMP_LIBRARY
    4.CPUID_LIBRARY
    5.ETH_JSON_RPC_STUB
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @eth001 you don't need these.
  • eth001eth001 Member Posts: 14
    @Genoil I got so many error in VS2013 while I complie
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @eth001 what do you need? I can create some binaries tomorrow.
  • eth001eth001 Member Posts: 14
    @Genoil I d like to miner with my GPU ,but I don`t know how to do
  • timothyjcoultertimothyjcoulter Member Posts: 14
    @Geniol I'd love a miniupnpc that works compiling with Visual Studio. I currently get linker errors trying to build it myself.
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @timothyjcoulter same here no luck. I used port forwarding instead
  • zeelzebubzeelzebub Member Posts: 13
    @Genoil - I just needed to install fglrx from the app repo and my error went away. fglrx may need to be added to the list of dependences on the wiki page for building a GPU miner under ubuntu.
  • zeelzebubzeelzebub Member Posts: 13
    My previous comment is mistaken. I needed to install the proprietary AMD driver prior to installing the dependencies listed on the wiki. Do not install the AMD SDK. (This corrected the GPU errors I received on ubuntu with alethzero)
Sign In or Register to comment.