I need help with an error when I try to install AlethZero on windows

EluavsMolochEluavsMoloch Member Posts: 4
I'm following the instructions on this site upon running the last command the compile fails and i get this error and I don't really know what it means:


Error 102 error MSB3073: The command "setlocal cmd /C "set PATH=C:/Users/Travis/Documents/eth/cpp-ethereum/extdep/install/windows/lib/cmake/Qt5Core/../../../bin;%PATH% && C:/Users/Travis/Documents/eth/cpp-ethereum/extdep/install/windows/lib/cmake/Qt5Core/../../../bin/windeployqt C:/Users/Travis/Documents/eth/cpp-ethereum/build/mix/Debug/mix.exe --qmldir C:/Users/Travis/Documents/eth/cpp-ethereum/mix/qml" if %errorlevel% neq 0 goto :cmEnd :cmEnd endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone :cmErrorLevel exit /b %1 :cmDone if %errorlevel% neq 0 goto :VCEnd setlocal cd C:\Users\Travis\Documents\eth\cpp-ethereum\build\mix\Debug if %errorlevel% neq 0 goto :cmEnd C: if %errorlevel% neq 0 goto :cmEnd cmd /C "(echo [Paths] & echo.Prefix=.)" > qt.conf if %errorlevel% neq 0 goto :cmEnd :cmEnd endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone :cmErrorLevel exit /b %1 :cmDone if %errorlevel% neq 0 goto :VCEnd :VCEnd" exited with code 1. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.CppCommon.targets 132 5 mix Error 104 error MSB3073: The command "setlocal cmd /C "set PATH=C:/Users/Travis/Documents/eth/cpp-ethereum/extdep/install/windows/lib/cmake/Qt5Core/../../../bin;%PATH% && C:/Users/Travis/Documents/eth/cpp-ethereum/extdep/install/windows/lib/cmake/Qt5Core/../../../bin/windeployqt C:/Users/Travis/Documents/eth/cpp-ethereum/build/alethzero/Debug/alethzero.exe " if %errorlevel% neq 0 goto :cmEnd :cmEnd endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone :cmErrorLevel exit /b %1 :cmDone if %errorlevel% neq 0 goto :VCEnd setlocal cd C:\Users\Travis\Documents\eth\cpp-ethereum\build\alethzero\Debug if %errorlevel% neq 0 goto :cmEnd C: if %errorlevel% neq 0 goto :cmEnd cmd /C "(echo [Paths] & echo.Prefix=.)" > qt.conf if %errorlevel% neq 0 goto :cmEnd :cmEnd endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone :cmErrorLevel exit /b %1 :cmDone if %errorlevel% neq 0 goto :VCEnd setlocal "C:\Program Files (x86)\CMake\bin\cmake.exe" -E copy C:/Users/Travis/Documents/eth/cpp-ethereum/extdep/install/windows/bin/libmicrohttpd-dll.dll C:/Users/Travis/Documents/eth/cpp-ethereum/build/alethzero/Debug if %errorlevel% neq 0 goto :cmEnd :cmEnd endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone :cmErrorLevel exit /b %1 :cmDone if %errorlevel% neq 0 goto :VCEnd :VCEnd" exited with code 1. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.CppCommon.targets 132 5 alethzero

Comments

  • EluavsMolochEluavsMoloch Member Posts: 4
    edited April 2015
    I haven't solved the issue yet but what I have found is that this is essentially a batch file that runs after compilation. It's trying to set the PATH environmental variable to set PATH=C:/Users/Travis/Documents/eth/cpp-ethereum/extdep/install/windows/lib/cmake/Qt5Core/../../../bin;%PATH%

    and do something else? still trying to figure out what the && symbol means in this context. however it seems like it's trying to do 2 things and one or both fail.

    I'm also confused because
    if %errorlevel% neq 0 goto :cmEnd
    will go to :cmEnd regardless of the value of %errorlevel% since :cmend is the next line or am I mistaken.

    I'll keep researching the problem.
Sign In or Register to comment.