Weird situation happened on my ethereum wallet

I use MetaMask as my ethereum wallet. I have two accounts in it. Today when I was entering my password to log in, the button "LOG IN" had no reaction. I tried many times, still no reaction. Then I saw two lines under "LOG IN" button which are "Restore account? Import using account seed phrase". So I did it and change my password according its request. Then I logged in with new password and only one account is shown (which I don't store ethereum in it). The one with ethereum is missing. Then I check Etherscan according to the address which stores my Ethereum, the coins is still there.

Could anyone tell me how to get access to my account? (I have keystore file). Thank you very much!


  • sinodasinoda Member Posts: 3
    I have already got my second account by importing keystore file. (I thought I have to download Ethereum wallet or Mist to import keystore file. But I found it can be imported in from MetaMask).

    I just wonder how did it happened? Why the "LOG IN" button failed? Why I use seed phrases to restore my accounts and only account one is seen? (the seed phrases are actually account two's)
  • kaleemmalikkaleemmalik Member Posts: 23
    Its really wierd situation.. one of my friend has face same situation..
  • heliowalletheliowallet Member Posts: 2
    Maybe, your browser has been cleaned up.
    Lead to Metamask lost wallet, do you still save "recovery phrase"?

    You can also use "recovery phrases" and Metamask at our project: HelioWallet.Com
Sign In or Register to comment.