Solution to Stop Windows 10 Automatic Updates - Create Metered Internet Connection for Rigs

asusrigasusrig Member Posts: 139
Ok so I had disabled the Windows Update Service for all my rigs yet somehow MS enables it again automatically. One rig was updated to 1803. I ignored it and the machine was able to mine for a few weeks. Then out of the blue I get DAG errors in Claymore when I try to run all 13 GPUs - they all have 8GB RAM and VM is set to 48GB RAM! I tried a few suggestions and none worked. I could not revert back to 1709 because more than 10 days had transpired since the update. I tried to reset the OS but this just wiped out all programs and still kept it at 1803. So I was forced to reinstall Windows 10 w/ 1709 updates all over again. Took me 5-6 hours to troubleshoot and get it back again.

I searched online and found this link below. The solution is to create a metered Internet Connection. You have to edit the registry. I did this and now if I go to Windows Update it will give an error message trying to download 1803 - see screenshot at bottom of post. So it works great. I've had it with these pesky Windows updates! Rig is working great again. MRGA!!!! (Make Rigs Great Again)

https://www.gpuminingresources.com/p/stop-windows-10-automatic-updates.html

"Windows 10 does not make it easy for you to disable Automatic Updates. You may be mining away uninterrupted for months, then you wake up one morning and your rig hasn't submitted any shares for hours. You reboot to find your graphics cards are no longer recognized, your OC settings are deleted, and your mining software immediately error-crashes. Oh great, an unannounced Windows 10 update.

Prevent Windows 10 from automatically installing updates with this quick guide. These changes still allow you to manually check for updates and install them when you're ready to install them."


Comments

  • SaphSaph Member Posts: 72
    This also doesn't work forever, eventually it'll fall off and deploy.

    The only way to truly resolve this is Windows10 Pro or higher.

    Disabling it with GroupPolicy is the only solution.
  • asusrigasusrig Member Posts: 139
    Saph said:

    This also doesn't work forever, eventually it'll fall off and deploy.

    The only way to truly resolve this is Windows10 Pro or higher.

    Disabling it with GroupPolicy is the only solution.

    Can you elaborate on Group Policy? The rigs have Windows 10 Enterprise.

    Thanks.
  • homerklezhomerklez Member Posts: 15
    So, a trick I used to use a while back was to set the date of the PC like years into the future. That way if it tried to download updates it'd fail the Security Certificate. It makes it difficult to browse the web because every web page gives you an error, but those PCs were just for mining so all I cared about was up time. But once I did that, I never had that issue again, I havent ran my rigs in a while, so I dont know if it still works with the latest updates, but those PCs are on old Windows 10 still hehe. :)
  • techtottechtot Member Posts: 338 ✭✭
    Best method I have seen is 1) Go into services 2) double click on windows update 3) go to "logon" tab 4) set the logon to any user account 5) set the password to an INVALID / BAD password for that account. 6) set the windows update service to disabled

    This is the simplest and most effective method I have seen. All other methods, including Group Policy settings "Fix themsevles". If you just disable windows update service, that is not good enough. It will turn itself back on. I am pretty sure this method of changing the acct/password for winupdate service is fool proof so far.
  • asusrigasusrig Member Posts: 139
    techtot said:

    Best method I have seen is 1) Go into services 2) double click on windows update 3) go to "logon" tab 4) set the logon to any user account 5) set the password to an INVALID / BAD password for that account. 6) set the windows update service to disabled

    This is the simplest and most effective method I have seen. All other methods, including Group Policy settings "Fix themsevles". If you just disable windows update service, that is not good enough. It will turn itself back on. I am pretty sure this method of changing the acct/password for winupdate service is fool proof so far.

    Hey thanks for this tip. I'll try it next time. Right now the machine that has been set to a metered connection has not updated. We'll see if that ever happens.
Sign In or Register to comment.