How to start a swarm daemon working with https?

LinkgearLinkgear Member Posts: 1
edited July 30 in Swarm
I started an swarm daemon under aws ubuntu 16.04 with the following command:
swarm --bzzaccount "206a09b1887a4fd79e44179c0d1fb1cb754a1465" \
--datadir ./Node/ \
--ens-api ./Node/geth.ipc \
--bzznetworkid 30388 \
--bzzport 5000 --httpaddr 283.31.83.216 \
--nodiscover \
< .bzzkey

--bzzapi http://linkgear.net:5000/

Our site is https://linkgear.net/. When a picture is loaded to the swarm, a user browser got an error:

Mixed Content: The page at 'https://linkgear.net/home/claim?id=5b5c6833226cba727c063163' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://linkgear.net:5000/bzz:/'. This request has been blocked; the content must be served over HTTPS."

My question is: how can we correct the error by switching the swarm instance to https? So far I haven't found any parameter for this, just wondering how https://swarm-gateways.net/bzz:/
/ was coded or configured.

Please shed some lights on it.

Thank you very much!
Simon
Sign In or Register to comment.