NVIDIA Mining Card P Series cannot tweak in headless Linux

wpsdwpsd Member Posts: 18
Hi, did anyone successfully overclock NVIDIA Mining Card ( P104, P102 ) on Linux

I recently just bought this 3 card to try whether I can tweak clock and memory clock on Headless Linux.
My OS is Ubuntu 16.04 , tried all the driver until latest 396

Once I give them a dummy xorg using dfp-edid.bin way, it directly go to P8 state on mining ( test only in claymore ) even without the coolbits / Regdwords option specify.
The watt in nvidia-smi is shown as 23w/100w, never get pass 23w.

But If I disable the dummy xorg it can run normally but "nvidia-settings" tweak will not work, which is something that is required to modify fan speed.

Anyone face this problem ?

My option works perfectly on many brand of GTX1070 , but not P104 or P102.

This is my xorg.conf for /etc/X11/xorg.conf
Section "Device" Identifier "Configured Video Device" Driver "dummy" VideoRam 16384 EndSection Section "Monitor" Identifier "Configured Monitor" HorizSync 5.0 - 1000.0 VertRefresh 5.0 - 200.0 ModeLine "1366x768" 72.00 1366 1414 1446 1494 768 771 777 803 EndSection Section "Screen" Identifier "Default Screen" Monitor "Configured Monitor" Device "Configured Video Device" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 Virtual 1366 768 EndSubSection EndSection

This is the xorg.conf that I pass to each GPU, "@[email protected]" is replace automatically by my script to the correct id
Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" 0 0 EndSection Section "Screen" Identifier "Screen0" Device "VideoCard0" Monitor "Monitor0" DefaultDepth 24 Option "UseDisplayDevice" "DFP-0" Option "ConnectedMonitor" "DFP-0" Option "CustomEDID" "DFP-0:/etc/X11/dfp-edid.bin" Option "Coolbits" "28" SubSection "Display" Depth 24 Modes "1024x768" EndSubSection EndSection Section "Device" Identifier "Videocard0" Driver "nvidia" Screen 0 Option "UseDisplayDevice" "DFP-0" Option "ConnectedMonitor" "DFP-0" Option "CustomEDID" "DFP-0:etc/X11/dfp-edid.bin" Option "Coolbits" "28" Option "AllowEmptyInitialConfiguration" "True" Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1" BusID "@[email protected]" EndSection Section "Monitor" Identifier "Monitor0" Vendorname "Dummy Display" Modelname "1024x768" EndSection

Comments

  • cjclm7cjclm7 Member Posts: 76
    edited June 2018
    Welcome to the Club... :#

    I confirm is possible configure successfully the Linux Ubuntu 16.04 (with overclock and undervolting) for "normal" Nvidia GPU such as GTX 1060. It is not easy but when done works flawless. Have a rig of 7 x Asus ROG Strix GTX 1060 6GB mining for months without touching it. The stability is fantastic.

    Unfortunately could not do the same method with the Asus P106 6GB (www.asus.com/Graphics-Cards/MINING-P106-6G/). Tried several times. Spent lots time on a test bench with one P-106. Could not achieve same results. I had same kind issues that you are facing with the P-104 and P-102: changes on the /etc/X11/xorg.conf do not stick (even if you protect the file). If you protect the configuration file then you cannot restart the machine. If you do not protect the file then you loose all the changes. It does not persist.
  • wpsdwpsd Member Posts: 18
    in my case the xorg stick, i can use nvidia-settings but the card decide to go to p8 instead :D . Even the fan speed is set correctly by nvidia-settings.

    My theory is maybe cuz P card doesnt have display. So that you shouldnt give "display" for this card on xorg config, but only "device".
  • wpsdwpsd Member Posts: 18
    You could try my script here if you use ubuntu 16.04
    https://github.com/wiryonolau/gputweak
Sign In or Register to comment.