PCIe slot not working after GPU flash

SaphSaph Member Posts: 72
edited March 2018 in Mining

I've got 12 of the same memory (hynix) 580s. First 6 work like a dream, flashed them all with the same bios and it worked perfectly.

On to the next rig, it plug everything in and it works straight away, detects all 6 cards.

I flash the cards with same bios as before (same memory, same brand, purchased together) and now one of the pcie slots fails to show up in windows.

The motherboard I'm using (tb250-btc pro 6 gpu ver) has a post screen that shows if your pcie slots are working, faulty or not being detected.

The motherboard post screen shows everything to be working fine, but windows won't detect one pcie slot since the flash.

The riser/gpus work perfectly on all other pcie slots, it's just this one that windows has decided to forget.



  • peshetomanpeshetoman Member Posts: 78
    my guess is that you used the same bios for all cards. My experience show that you should modify each bios one by one and return it to the card. Use saphire trixx to detect which card is not working. Then check if that PCI slot requires some modification from the bios. One of my cards required the bios to be set to default to work due the the processor in use. if that doesnt help reflash the card back to stock bios and see if that helps. then modify the stock bios with the one click patch.
  • SaphSaph Member Posts: 72
    Apologies for not updating with the fix.

    Uninstalled driver, reinstalled the driver.

    Connected cards one at a time, flashed one at a time.

    Worked immediately.
Sign In or Register to comment.