Gigabyte GA-Z270P-D3 only detecting 5 GPUs and subsequent boot error.

SaphSaph Member Posts: 72
Hello,

I've built a few rigs using other ASRocks motherboards and they've all picked up six GPUs without a problem.

I've picked up Gigabyte GA-Z270P-D3 (Revision 1.0) https://amazon.co.uk/gp/product/B01NCS9QS5/ref=oh_aui_detailpage_o05_s00?ie=UTF8&psc=1 and I can't for the life of me get six GPUs working.

I'm using AMDs mining driver and I've flashed the BIOS to F7 (the latest for this particular board).

Any combination of five GPUs works, as soon as six are connected it fails to boot.

Rig powers up and presents a black screen as soon as the 6th card is connected.

Tested 18 risers & all PCIe slots, they all work individually.

I'm completely stumped and can't for the life of me find an answer already online.

Assistance appreciated and rewarded for a fix, either paypal or eth transfer. (Unsure if I'm allowed to do this, apologies mods if not).

Thanks in advance.

Comments

  • Ericjh801Ericjh801 Utah, USAMember Posts: 369 ✭✭
    I think you are allowed to offer a reward, wouldn't see why not. Does it only come up with a black screen? Any other errors?
  • SaphSaph Member Posts: 72
    Perfectly black screen annoyingly doesn't bring up any errors.

    Soon as a 6th GPU is plugged into any PCIE slot it powers up, fails to boot and shows a black screen.
  • Ericjh801Ericjh801 Utah, USAMember Posts: 369 ✭✭
    edited January 2018
    Try updating your bios to this version :
    https://www.gigabyte.com/MicroSite/462/images/BIOS-Z270P-D3.zip

    Apparently lots of people having issues with F7 supporting 6 cards.


    Also make sure 4G encode is set to enabled in BIOS after you change versions.
  • SaphSaph Member Posts: 72
    I'll give it a try now, thanks. I'll happily wire £50 if I can get this working.

    Rebuild is happening tomorrow, I took it all apart thinking it might be a lack of power (voltage inload being high on the 580) so I'm just running 2 at the moment (and getting an awful 17mh/s).

    I'll flash the card with that bios and report back in tomorrow!
  • Ericjh801Ericjh801 Utah, USAMember Posts: 369 ✭✭
  • SaphSaph Member Posts: 72
    BIOS flashed as expected, fingers crossed it picks up all six cards tomorrow then I can worry about the hashrate next.

    Appreciate the reply.
  • Ericjh801Ericjh801 Utah, USAMember Posts: 369 ✭✭
    That's a step in the right direction! From what I've read you should be able to use 7 cards if you ever decide you want to add another. What size power supply you running?
  • SaphSaph Member Posts: 72
    PSU is a platinum 1000w which I wasn't expecting to mine with by itself but I was expecting it to boot.

    The BIOS above flashed properly, but it's now forced a 640 x 480 resolution that's getting in the way of using @Bios which annoying isn't scaling.

    Just one thing after another with this rig!
  • Ericjh801Ericjh801 Utah, USAMember Posts: 369 ✭✭
    You should be able to boot up 6 cards with that PSU. Mining would be another story, it would be very very close. I use 2x750w (1500w total) for 8 card rigs (rx 580's).

    I have a rig that's been a pain since day one. finally have it mining, just not dual mining as it crashes. I'll take the small wins at this point.
  • SaphSaph Member Posts: 72
    Did the bios you've linked do anything to your screen resolution & connections?

    I can remote to the rig now but it isn't picking up the HDMI connection.
  • Ericjh801Ericjh801 Utah, USAMember Posts: 369 ✭✭
    I don't have the exact board unfortunately just a pretty good troubleshooter. That bios was specifically made for that board and mining. Does one of the cards or the onboard have the monitor plugged into it? I use hdmi dummy connectors for all my rigs and haven't had an issue yet with remote resolution.
  • SaphSaph Member Posts: 72
    When I flashed the board I didn't change any of the BIOS settings back so it still had PCIE 1 selected as the default etc.

    Got it fixed now, it's been a long day.

    Should I be able to tweek the timings with Polaris or is that already "done" do you know?

    Thanks for all the help.
  • SaphSaph Member Posts: 72
    Just realized I've been a moron and I've tried to flash the GPU bios polaris has tweeked to my motherboard. Fortunately it didn't all me, I won't do that again.

    The 1070s just needed fixed with afterburner that was so much less effort!
  • Ericjh801Ericjh801 Utah, USAMember Posts: 369 ✭✭
    Awesome. Glad you are getting further with it. :) Hopefully all 6 work for ya
  • SaphSaph Member Posts: 72
    Final question for tonight! Killer assistance btw, shall send half reward tomorrow too tired to do it just now.

    ATI flash worked a treat and one card with the new GPU bios applied has jumped from 16/17 to 20 which is a definite start.

    Do you know if I need to flash each individual card one at a time with the new GPU bios or does it do all the cards currently plugged in?

    The reason I ask is I've two cards plugged in, one has jumped to 20, the other has remained at 17.
  • Ericjh801Ericjh801 Utah, USAMember Posts: 369 ✭✭
    You have to do it one at a time. I highly recommend you disconnect all other cards when flashing one too. Accidents/bad things have been known to happen. You can send reward whenever :) Glad I could help!
  • SaphSaph Member Posts: 72
    Hero, I've flashed them both (wouldn't let me comment) and the 2nd card is now running at 21 up from 17. Outstanding start, no clue how people are getting these at 25 stock. This has been a long night.

    Again will report back in with tomorrows findings re 6 GPUs, everything should be set up for just plugging it all in.
  • BigupBigup Member Posts: 1
    as stated above

    4G Encoding is a must, needs to be on

    i have 3 the same mobos with 7GPUs each and its working perfect, really superb mobo

    let me know if you need to know any specifics

    read this: https://www.gigabyte.com/microsite/462/mining.html

    and also flash the specific mining bios which it states in the table

    ive just looked and it seems they have updated since i last looked, i may give the new bios a go
  • Ericjh801Ericjh801 Utah, USAMember Posts: 369 ✭✭
    Hopefully all went well! :)
    Saph said:

    Hero, I've flashed them both (wouldn't let me comment) and the 2nd card is now running at 21 up from 17. Outstanding start, no clue how people are getting these at 25 stock. This has been a long night.

    Again will report back in with tomorrows findings re 6 GPUs, everything should be set up for just plugging it all in.

  • SaphSaph Member Posts: 72
    Update: F8a leads the the motherboard not booting. In the process of rolling back everything to F7. F7 only picked up 5 cards but it's better than it not booting at this point!
  • cryptoniumcryptonium Member Posts: 1
    edited February 2018
    I too picked up this board back in Dec 2017 and I never noticed any issues cause I started with just 4 GPUs. 2 weeks ago I got my fifth and sixth GPU for a total of 6 and at this point I needed a secondary PSU. Well this board does not play well with the F6 BIOS version and a secondary PSU either. It would not turn on the secondary PSU and if I turned it on manually before BIOS splash screen it would simply not boot. Also found out I was not able to flash the BIOS using the Q-Flash utility in the board. So after much searching found this post were a BIOS flash was possible (I guessed using Windows). So I loaded Windows on a thumb drive and the Gigabyte App Center updated me to F7 automatically from the web. Then I used the @App BIOS utility to finally flash to F8a. That was not easy either as the app was broken from start. It kept giving me a "flash.dll" loading error. So I grabbed the DLL from the BIOS app that did the auto-flash and copied it over then I was able to get past the error. Once the BIOS is flashed all previous settings are erased to I followed the mining guide mentioned above to set everything back. In addition to the guide settings I had to go back in to "BIOS" and set the "Windows 8/10 features" to "Other OS", "Storage Boot Option Control" to "Legacy" and "Other PCI devices" to "Do not launch" then save setting and exit. DONE booted up with all 6 cards and all worked perfectly. Since then I have setup a second miner with the same board and it all went smooth sailing with these steps. I hope this helps any of you who may still need this information. Cheers!
    Post edited by cryptonium on
  • SaphSaph Member Posts: 72
    Thanks for the reply buddy, really detailed. Turns out my board was faulty after all (nightmare)
Sign In or Register to comment.