GPU stops hashing in minutes, HELP

AmereumAmereum Member Posts: 6
edited October 2017 in Mining
I've been having problems with my rig for a whole week. I can't get it to run as good as it did when I first got it.

The problem started when I got the following:
1- "WATCHDOG: GPU0 failed to get OpenCL call"
2- Screen flickers..
3- Win10 notification about "WattMan settings have been reset due to system failure".
Here's my rig specs:
- Running Windows 10
- 3 GPUs of Sapphire RX580 Nitro+ 8gb (Hynix Memory)
- AMD BETA Blockchain Drivers
- Flashed ROM:

I have tried the following:
- Flashing Original FACTORY ROM, same issue happens, same card stops hashing..
- Reinstalling the blockchain drivers, same issue, same card..
- Running with NO OVERCLOCK, NO UNDERVOLTING, ETC.. same issue, same card..
- Changing the riser, same issue, same card..

When putting back stock rom and regular driver and running videos/games.. The same card works fine!

Should I migrate to Ubuntu Linux??

What else can I do before I switch?


  • ecs87ecs87 Dekalb, ILMember Posts: 339 ✭✭✭
    Have you tried to "reset" the OC on the cards after you flashed the original ROM back? Sometimes the cards keep the OC settings they previously had unless you "reset" them through the OC software.

    On another note...yeah...I'd recommend to stop running those drivers. They're beta for a reason. I've heard that AMD baked the blockchain fix into their most recent normal drivers. I'd take a look at that if I were you.
  • greatauror28greatauror28 Member Posts: 126 ✭✭
    I've been dealing with the stupid OpenCL error of my 8-gpu rig since last week until last night when I decided to upgrade to Win10 Fall Creator's Update and to the latest AMD driver 17.10.3.

    Just like that and the issue went away. I've been mining continuous now since 3AM and it's still running without dropping cards or any hiccups.

    Give it a try! Hope this help!
Sign In or Register to comment.