How to force p0 for gtx 1060 in linux

VenomCryVenomCry Member Posts: 5
Hello, i have 13 x gtx 1060 Gaming X 3GB and using AsRock h110Btc. I want to underclock my cards to reduce power consumption. I have reduced 1060 GTX power consumption to stable 65W while maintaining most of sol/s while mining zcash but on WINDOWS 10!
https://ibb.co/eXa0mv

I cant run windows 10 on my rig due it supports only 8 of same gpu type. My only option is to use linux.

Every linux os i run runs every card on 100W while getting about 280sols. I really need to drop that power consumption cause i pay about 0.15c per kwh.

I have trouble forcing p0 state for my gpu's on linux. I have easlily done in windows using nvidiaInspector. I have tried to force p0 state using xorg.conf file. I have done it partially(by default p0 is enabled but when i use ewbf it switches to p2 and stays in it).

I have also tried to force p0 by setting specific core/mem clocks but when i run nvidia-smi -q -d SUPPORTED_CLOCKS i get N/A for every gpu.
I have tried to force minimum power using nvidia-smi -pl 100 (100 is minimum i can set due to some driver limitations)

I have tried nvoc, ethos, simplemining os but without success.

Does anyone have an idea how to accomplish this ? Basically i need same thing i done in windows(nvidiaInspector) then set "CUDA force p2" to off. But there is no nvidiaInspector in linux.

Iam willing to give some reward in ZEC for a solution :)
Sign In or Register to comment.