Transaction returns Null from Contract

Hi everyone!

I'm trying to receive a response from a contract using the json-rpc transact api, but I always get null.

I'm running the master branch of cpp-ethereum.

One other weird phenomenon i'm experiencing is when I try to use the storageAt api with a freshly created contract.
Before I get any valid response, it requires me to send an empty transaction to the contract. It doesn't even matter if it's added to a block or not, after you issue a transaction, storageAt will return a valid response.

Any suggestions?

Comments

  • mids106mids106 Member Posts: 188 ✭✭✭
    At this point the JSON RPC transact from cpp-ethereum doesn't return anything unfortunately.

    As for the storageAt, could it be that the contract first needs to be mined?
  • ejasonejason Member Posts: 2
    Thanks for replying so fast :)

    I waited for the contract to be mined. Unfortunately it's not that..

    Also, I tried building the develop branch just to make sure it has not already been solved, but I got the same results.
Sign In or Register to comment.