1st Rig unstable please help

QuantraQuantra Member Posts: 22
edited March 2017 in Mining
Just started ethereum mining as a hobby and I'm struggling to get my rig stable. I get OpenCL hang after 6-10 hours at stock settings and hash rate fluctuates between 23 Mh/s and 24.7 Mh/s and sometimes drop to 19 Mh/s or 20 Mh/s for a few moments.

My rig...

2x Asus Radeon RX 480 8GB Dual Video Card
Gigabyte GA-F2A88XM-D3HP Micro ATX FM2+ Motherboard
XFX XT 600W 80+ Bronze Certified ATX Power Supply
AMD A4-6300 3.7GHz Dual-Core Processor
60GB Kingston SSDNow
8GB Corsair 1600 DDR3
Standard ATX case - no risers

Windows 10
Claymore dual miner 8.1
Driver 16.11.5
17-18GB Virtual memory, aero desktop disabled

I tried various 17 drivers but they don't make any difference. -gser 2 in claymore doesn't help either. Temps are held at 75C fans are 65% and 34%.

I've tried power limit -10 makes hash rate fluctuate a bit more and can't do more than -15 without crashes.
Tried memclocks one card can go to 2100 the other 2050 without crashing quickly. Not run the cards for any length of time at these clocks.
I read about -25 power and 2200 clocks so I think this is too low.

My feeling is the PSU is weak and I'd really appreciate some advice before I invest in a 1000W future proof PSU based on my hunch. Cheers.
Post edited by Quantra on

Comments

  • yodiyodi Member Posts: 265 ✭✭
    edited March 2017
    Hi and welcome
    we all have gpu hang sometimes , rarely when you find the limit of each GPU, psu is not the 1st reason
    better is to flash bios , i don't know what is the best straps for asus , search a bit , you just have to copy the timings (straps)
    1500 or 1600 or 1750 , depend of what memory is inside (samsung, etc, use gpuz to know it) to others higher, then save that and flash with it, with admin command prompt from atiwinflash folder.

    atiwinflash -f -p 0 nameOfYourSave.rom

    you will get a better Hashrate (~29Mh/s) and less consummation

    then i recommand to use WattTool (not trixx , not msi AB, etc) in the box with Memory you can push MHz to 1900~2000 and mV to 940 , and with time try to push more MhZ and lower mV (min 890) and see if crash or not, and then in the GPU box on P7 you can had 1100 to MHz or less , and around 900~1000 to mV, ajust Fan target Temp around 60° to get your fans running higher and power max Temp 75~ then save like gpu1.ini , etc

    then you need to get autologin in windows , and .bat files to autoreboot when hang , and to load WattTool settings you saved.
    Ask if you need more details for .bat after your flash :)

  • QuantraQuantra Member Posts: 22
    Thanks yodi I really appreciate the help. Good to know the fluctuations/hangs are normal and I need to flash the bios before I can clock further.

    I've not flashed a gfx card bios before so will have a read up. GPU-Z says it's Samsung memory in both cards.

    WattTool looks good I tried Quick Tweak and Radeon Settings, didn't get on with either so been using claymore miner settings for power/mem clock so far.

    I set up a reboot.bat today, tested it by running the bat but it's not crashed for 9 hours so not proper tested.

    Rig is in my office so need to keep fans reasonable volume, at least during working hours. Should be fun =]
  • QuantraQuantra Member Posts: 22
    Oops just updated OP I got 8GB cards not 4GB
  • yodiyodi Member Posts: 265 ✭✭
    edited March 2017
    pleasure ,
    do not forget to have shortcut of your "ethereumStart.bat" in start menu (path c:\user\yourUserName\appdata(hide_directory)\roaming\microsoft\windows\StartMenu\programs\"starting") or else .
    i get myself a shorcut of the starting folder to change what is starting easly.

    with that when windows 10 login, miner start automaticaly

    and use delay for everything can load on startup before miner start.

    example

    timeout /t 30
    setx GPU_FORCE_64BIT_PTR 0
    setx GPU_MAX_HEAP_SIZE 100
    setx GPU_USE_SYNC_OBJECTS 1
    setx GPU_MAX_ALLOC_PERCENT 100
    setx GPU_SINGLE_ALLOC_PERCENT 100
    EthDcrMiner64.exe -r 1 ..........

    the 2nd .bat you'll need to auto start is your WattTool settings , because it don't auto load your save .ini
    must look like something like that in the WattTool folder , depend of you saveName.ini
    if you don't get timeout it won't load correctly at logon.

    timeout /t 20
    start WattTool-0.92.exe gpu1.ini gpu2.ini gpu3.ini ... etc (depend of number of gpu/saves)

    edit : and for windows autologin 2 ways
    1 - in exec. type : netplwiz , and uncheck user have to enter pass.
    or
    2 - modify registry (search for windows auto login regedit)
  • QuantraQuantra Member Posts: 22
    Just gone to flash the bios on my cards following this guide https://steemit.com/ethereum/@yogibear/mine-more-ethereum-with-rx470-rx480-bios-mods

    I saved the original BIOS using ATI Flash and tried opening it with polaris editor. I get a message that says "This BIOS is less than the standard 512KB size. Flashing the BIOS may corrupt your graphics card."

    The saved BIOS is 256KB. Is it safe to proceed?
  • QuantraQuantra Member Posts: 22
    I went ahead and ignored that message. Copied 1750 timings to 2000. Now each card does 28.0MH/s yay getting there, thanks again =]

    I still can't overclock them though 2050 memclock is unstable 2100 crashes after a few mins. This is with 0 powlim. Not been able to use WattTool as it has no scroll bar and my remote desktop is 640x480 so I can't see all the options to change them. So I'm still using claymore options.

    I was running GPU1 at 2050 but when I put GPU0 to 2050 it made GPU1 hang within minutes.

    Set the target temp to 70 and get 72C 91% fan and 68C 55% fan. The backside of GPU0 seems to be very hot, I used an IR temp gun at got 90C readings behind die. I know these aren't accurate but it makes me worry about a fire.

    I tried the cards in the machine one at a time, they both do same speeds as above but with more like 35-40% fan speed only. There is a gap between the cards but it seems when they are both in GPU0 gets hot.

    Not sure where to go from here. Perhaps get a riser and move one card out of the case?
  • AlnemerAlnemer Member Posts: 5
    don`t use high overclock

    to get stable use 2000 or less for mem and 1150 for gpu clock
  • QuantraQuantra Member Posts: 22
    I spent some more time tried different timings and changing core/mem clock speed with WattTool. I couldn't get anything better than what I had which was -12 powlim, 1750 timings, 2000 mem clock 27.9Mh/s pretty steady on each card.

    The temps with -12 powlim are better, the fan spins at 80% on the hot card. Then I tried standing the case upright and this went to 75%. Power draw is about 85W in GPU-Z and my IR temp gun readings are more like 80C.

    I'm going to leave this as is now and earn some Ethereums for more mining gear =D Pretty happy for my first go. I was hoping for more like 31-32Mh/s as these are 8GB RX480 but considering the actual price 28 isn't too bad.
  • yodiyodi Member Posts: 265 ✭✭
    edited April 2017
    you must have access to a full screen or un zoom it
    if you have sapphire rx480 8gb samsung use jukebox mod , the vdrop+

    download vdrop+

    if you don't care of electricity search for heliox one


    keep in mind each card are different , my self i have 6 rx480 8g (samsung) like yours ?

    1 is running 1115/2030
    2 are running 1115/2035
    3 are better 1115/2070
    with -84 mv or 940 in wattTool (dont use powlim etc ...) if you are dual mining you can try -ethi , and -dcri lower for cards hangs


    (don't worry about 256KB or 516kb it depend how modder has saved the .rom, jukebox are 512 if i remember, (256 is the better way to save i think but no really matter here)


    after flash all my cards were running good some hours , but then the lower get hangs ... then i adjust

    Post edited by yodi on
  • QuantraQuantra Member Posts: 22
    Normally I have a monitor plugged in but it's kinda awkward at home. With no monitor chrome remote desktop is 640 x 480 and I can't change it. Also without monitor GPU0 runs a little faster. But I plugged in monitor and did try WattTool.

    I don't have Sapphire cards they were 20% more expensive than my Asus DUAL cards. Hard to find anything about these cards for mining but from what I read the expensive Asus cards aren't well liked. So for the budget ones I should probably expect them to be a bit hot and noisy. But they do have Samsung memory.

    What Mh/s do you get with your cards? I'm trying to tune for speed and noise so it's much like tuning for power as I need temps and fan speeds down.

    Here's where I'm at with the powlim method for now.






  • yodiyodi Member Posts: 265 ✭✭
    edited April 2017
    a good downvolt will be 75w ~ 80w for only ETH
    1750 straps is the good one to copy , did you try 1500 straps ?

    rx480 must be 29 ~ 30 mhs easly, push memory clock to 2040~ 2070
    core clock is not important for ethereum you can lower it 1115~

    post original bios
  • QuantraQuantra Member Posts: 22
    Sure I tried 1500 straps and got blue screen, 1600 straps and hashrate constantly moving between 25-29Mh/s

    So above is with 1750 straps. Original bios is here: https://drive.google.com/open?id=0B8AJgHwO7kiuMVJhcDlnUDVZbkU
  • sigb0ysigb0y Member Posts: 5
    yodi said:

    pleasure ,
    timeout /t 20
    start WattTool-0.92.exe gpu1.ini gpu2.ini gpu3.ini ... etc (depend of number of gpu/saves)

    edit : and for windows autologin 2 ways
    1 - in exec. type : netplwiz , and uncheck user have to enter pass.
    or
    2 - modify registry (search for windows auto login regedit)

    Do you have some examples how to use WattTool ?
  • yodiyodi Member Posts: 265 ✭✭
    edited April 2017
    Quantra said:

    Sure I tried 1500 straps and got blue screen, 1600 straps and hashrate constantly moving between 25-29Mh/s

    So above is with 1750 straps. Original bios is here: https://drive.google.com/open?id=0B8AJgHwO7kiuMVJhcDlnUDVZbkU

    the powertune is low compare to sapphire one & other did you try to push memory 2000 to 2050 ?

    try this on one card to see (hash , powersave, stability...) dont forget to downvolt -100mV or 940 to wattTool
    (what psu do you have?)

    fast-files.com/getfile.aspx?file=135260


    Post edited by yodi on
  • QuantraQuantra Member Posts: 22
    Cheers. I tried downloading it but can't get it from that site, keep getting bounced around adverts/security warnings. What did you change in it?
  • yodiyodi Member Posts: 265 ✭✭
    Quantra said:

    Cheers. I tried downloading it but can't get it from that site, keep getting bounced around adverts/security warnings. What did you change in it?

    sorry i use one of the 1st site i found with google ... i just see this one is bad
    this one seem better
    dual8gRx480.rom
  • QuantraQuantra Member Posts: 22
    I spent far too long on this yesterday but got to try a few things out, got a monitor plugged in and tried Watt Tool properly.

    Main difference I found was by not using powlim and underclocking in Watt Tool everything was more stable. The power usage in GPU-Z is much more steady and it would appear lower temps for similar average power draw.

    Very cool thing is I don't need any initialisation scripts. Whatever I set in Watt Tool is remembered by claymore dual miner or the driver or the OS or something?! So basically so long as I don't use another OC tool or set options in Claymore I just have to set it once in WattTool and that's it, even survives reboots.

    Biggest difference on temps/power was from underclocking the GPU but changing the voltage here didn't appear to do anything. I even tried 100 but no change. Should I be able to see it change in GPU-Z under VDDC? I think this might be due to the bios, all the voltages there don't look like voltages rather codes for automatic modes so maybe if I change them there then I can change them in Watt Tool. Changing the memory voltage had a very small effect until it was too low it became unstable, it didn't seem to change the power reading in GPU-Z or temps, hence I went with 950 even though 900 appeared to work fine also.

    I had a look at the bios you posted and I saw you upped the max power to 110, copied 1750 timings to 2000 and upped mem clock to 2050. So I tried with the max power up to 110 in one of my bios and it made no difference. I also wonder if I can learn more about editing these bios and rather than copy paste the 1750 timings actually unpack them and choose the timings. When I find more time I will open up a Boysie's bios and take a look at how he sets up for the Sapphire or XFX or w/e, hopefully I can learn something.

    My PSU is XFX XT 600W 80+ Bronze Certified ATX Power Supply. All my gear is in the OP.

    So right now I have this...

    GPU0
    memclock = 2100
    memvolts = 950
    gpuclock = 1125
    gpuvolt = 900 (but doesn't appear to do anything)
    hashes = 28.7 - 28.9 Mh/s
    temp = 75C
    fan = 60%
    power draw = 83W max 81.7W avg (GPU-Z)

    GPU1
    memclock = 2030
    memvolts = 950
    gpuclock = 1100
    gpuvolts = 900 (as above)
    hashes = 27.8 - 28.2 Mh/s
    temp = 57C
    fan = 44%
    power draw = 81W max 80W avg (GPU-Z)

    I can push the memclock to 2125 for GPU0 but it makes hash rate jump between ~25 - 29.5 Mh/s and I don't find anymore shares just more crashes but I can possibly push this a little higher than 2100 :P GPU1 can't even go to 2050 without hanging after 20 mins or so but this does mean a lower gpuclock is fine.

    Thanks again for the help. This is a lot of fun =]
  • yodiyodi Member Posts: 265 ✭✭
    i lower the core clock to ...
    it's changing the consumation and had no impact of ETH hashrate .. you didn't flash it ?

    better is to see the watt at the wall

    you will have to get platinium psu when if you'll get more gpu's (it s very better with watts)

  • QuantraQuantra Member Posts: 22
    Yes sorry clock speed too =] I mean I was already testing clock speed and everything else except the max power so I only tried this change in my bios as I think there is no difference to setting clock speeds on the bios vs WattTool. So no I didn't flash the bios you made but I did try everything in it. If you are interested in the result of those settings in your bios I will flash it next time at the office and let you know.

    I got still got an eye on my PSU, had a random reboot today with no blue screen error, event viewer or miner logs. Could have been a short power cut at the office I just don't know. In a few months I plan to make an up to 6 card rig to run at home will defo go gold/platinum for that and invest in a power meter plug thing.
Sign In or Register to comment.