Trouble sending ether using Geth

deathstonedeathstone Member Posts: 2
Hi all,

First time poster her, been a lurker for some time. I started mining a while back and have been successful in accruing a few ethers. I had been keeping these ethers on my local geth accounts i.e. geth.accounts[0] and geth.accounts[1] respectively.

Recently I wished to transfer some ether into my cex account as a trial, and ran the following command after unlocking my account:
eth.sendTransaction({from: eth.accounts[0], to:'MyCexEthAddress', value: web3.toWei(0.05,"ether"), gas:21000});
When I ran this command I received the following error:
 Error: Exceeds block gas limit
        at web3.js:3119:20
        at web3.js:6023:15
        at web3.js:4995:36
        at <anonymous>:1:1
After searching a few places (stackexchange and reddit itself), I stumbled upon a possible [reason](

check current block gas limit by running - eth.getBlock("latest"). If you supply more gas than this value, you will face 'Exceeds block gas limit' error

When I checked my gasLimit in the genesis.json file, I found out it had a value of 5200 and the suggested solution was to modify this value in the genesis.json file which was suggested against by this answer.

Could you kind folks here at r/ethereum help me out with my predicament? I have also followed the sendTransaction convention of including the gas in the command as suggested in this reddit thread. Same error.

I'm using Geth/v.1.5.6-unstable version.


Sign In or Register to comment.