Setup Ethereum on ubuntu 12.04

Can someone have a full explanation about how to install ethereum on Ubuntu 12.04 step by step (Video steps will be fantastic) cause, this is really confusing me, specially there are many clients and don't know which one I should go for, but I'm planning to implement dapps as @Stephan_Tual‌ mentioned on one of my post ( Please advice and thank you in advance.


  • StephanTualStephanTual London, EnglandMember, Moderator Posts: 1,282 mod
    I know you required a step by step explicitely, but so far the closest we have is Maxime Quandalle's modification of Maran's script at:

    Tested to work on RC10, should work for 11.
  • StephanTualStephanTual London, EnglandMember, Moderator Posts: 1,282 mod
  • eteflamingoeteflamingo Member Posts: 20
    Thank you @Stephan_Tual for your information, I decided to go with python. Now I successfully run pyethereum with serpent, I read @vitalik post ( it's was awesome and easy, I followed every step he did with no errors but, when it comes to get involved in peers network by running this command pyethereum/ -r I get this:

    Bottle v0.12.7 server starting up (using WaitressServer())...
    Listening on
    Hit Ctrl-C to quit.

    serving on

    after a few seconds it throws this following errors:

    Exception in thread Thread-8:
    Traceback (most recent call last):
    File "/usr/lib/python2.7/", line 551, in __bootstrap_inner
    File "/usr/local/lib/python2.7/dist-packages/pyethereum-0.0.1-py2.7.egg/pyethereum/", line 33, in run
    File "/usr/local/lib/python2.7/dist-packages/pyethereum-0.0.1-py2.7.egg/pyethereum/", line 269, in loop_body
    recv_size = self._process_recv()
    File "/usr/local/lib/python2.7/dist-packages/pyethereum-0.0.1-py2.7.egg/pyethereum/", line 105, in _process_recv
    File "/usr/local/lib/python2.7/dist-packages/pyethereum-0.0.1-py2.7.egg/pyethereum/", line 129, in _process_recv_buffer
    getattr(self, func_name)(data)
    File "/usr/local/lib/python2.7/dist-packages/pyethereum-0.0.1-py2.7.egg/pyethereum/", line 258, in _recv_GetChain
    sender=Peer, peer=self, block_hashes=data[:-1], count=idec(data[-1]))
    File "/usr/local/lib/python2.7/dist-packages/pyethereum-0.0.1-py2.7.egg/pyethereum/dispatch/", line 200, in send
    response = receiver(signal=self, sender=sender, **named)
    File "/usr/local/lib/python2.7/dist-packages/pyethereum-0.0.1-py2.7.egg/pyethereum/", line 406, in handle_local_chain_requested
    assert chain_manager.get(block_hashes[-1]).is_genesis()

    Please advice and thank you in advance.
  • mquandallemquandalle FranceMember Posts: 50 ✭✭
    The installer is for Ubuntu 14.04 and it won't work for version 12.04.
  • eteflamingoeteflamingo Member Posts: 20
    Hi @mquandalle I installed go-ethereum on ubuntu 14.04 but, when I run this command cd $GOPATH/src/ && ethereal I get this "ethereal: command not found". Please advice.
  • kharvtrankharvtran Member Posts: 12
    make sure you close the current terminal and open a new one to run the above command cd $GOPATH/src/ && ethereal
  • eteflamingoeteflamingo Member Posts: 20
    Thank you @kharv for your response, I opened a new terminal and the command worked but I get this errors: runtime: newstack called from g=0x93cf4140
    m=0x93d02000 m->curg=0x0 m->g0=0x93cf41e0 m->gsignal=0x93cf4140
    fatal error: runtime: wrong goroutine in newstack

    runtime stack:
    /usr/lib/go/src/pkg/runtime/panic.c:464 +0x5f
    /usr/lib/go/src/pkg/runtime/stack.c:212 +0x90
    /usr/lib/go/src/pkg/runtime/asm_386.s:246 +0x68

    goroutine 1 [IO wait]:
    net.runtime_pollWait(0xb3d01a18, 0x72, 0x0)
    /build/buildd/golang-1.2.1/src/pkg/runtime/netpoll.goc:116 +0x5e
    net.(*pollDesc).Wait(0x93d3f0f8, 0x72, 0xb3cff8e0, 0xb)
    /usr/lib/go/src/pkg/net/fd_poll_runtime.go:81 +0x32
    net.(*pollDesc).WaitRead(0x93d3f0f8, 0xb, 0xb3cff8e0)
    /usr/lib/go/src/pkg/net/fd_poll_runtime.go:86 +0x30
    net.(*netFD).ReadFrom(0x93d3f0c0, 0x83a24948, 0x400, 0x400, 0x0, ...)
    /usr/lib/go/src/pkg/net/fd_unix.go:231 +0x280
    net.(*UDPConn).ReadFromUDP(0x93cf31e0, 0x83a24948, 0x400, 0x400, 0x93d7cbc0, ...)
    /usr/lib/go/src/pkg/net/udpsock_posix.go:67 +0xd2, 0x0, 0x0, 0x0)
    /root/go/src/ +0x3b9, 0x9, 0x3, 0x93d69f40)
    /root/go/src/ +0x76
    /root/go/src/ +0x231

    goroutine 3 [syscall]:
    /usr/lib/go/src/pkg/os/signal/signal_unix.go:21 +0x1e
    created by os/signal.init·1
    /usr/lib/go/src/pkg/os/signal/signal_unix.go:27 +0x31

    goroutine 4 [syscall]:

    goroutine 6 [syscall]: +0x31
    /root/go/src/ +0xe7
    created by
    /root/go/src/ +0x8a

    goroutine 7 [select]:*DB).compactionError(0x93d6aa80)
    /root/go/src/ +0x18c
    created by
    /root/go/src/ +0x3b5

    goroutine 8 [select]:*DB).compaction(0x93d6aa80)
    /root/go/src/ +0x571
    created by
    /root/go/src/ +0x3ef

    goroutine 9 [select]:*DB).writeJournal(0x93d6aa80)
    /root/go/src/ +0x111
    created by
    /root/go/src/ +0x404. Please advice thanks
Sign In or Register to comment.