Unable to build alethzero client on Ubuntu 14.04

Hello all,

i'm trying to build the alethzero client on my Ubuntu 14.04 x86-64 system. I've run apt-get to make sure that I have all of the packages required. However, I still get these errors:

cmake ../cpp-ethereum -DCMAKE_BUILD_TYPE=Release -- Found Crypto++: /usr/include/cryptopp, /usr/lib/libcryptopp.so
-- System Crypto++ version found is smaller than 5.6.2.
-- System Crypto++ not found, broken or too old. We use LSLOC-NOTFOUND
Installation path: /usr/local
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
LSLOC
linked by target "ethereum" in directory /home/bbrelin/src/projects/ethereum/cpp-ethereum/libethereum
linked by target "testeth" in directory /home/bbrelin/src/projects/ethereum/cpp-ethereum/test
linked by target "eth" in directory /home/bbrelin/src/projects/ethereum/cpp-ethereum/eth
linked by target "alethzero" in directory /home/bbrelin/src/projects/ethereum/cpp-ethereum/alethzero

-- Configuring incomplete, errors occurred!

Here are the libraries that I have in /usr/lib

ls -l /usr/lib/libcrypto*
-rw-r--r-- 1 root root 19188432 May 2 2012 /usr/lib/libcrypto++.a
lrwxrwxrwx 1 root root 13 May 2 2012 /usr/lib/libcryptopp.a -> libcrypto++.a
lrwxrwxrwx 1 root root 14 May 2 2012 /usr/lib/libcryptopp.so -> libcrypto++.so
lrwxrwxrwx 1 root root 16 May 2 2012 /usr/lib/libcryptopp.so.9 -> libcrypto++.so.9
lrwxrwxrwx 1 root root 20 May 2 2012 /usr/lib/libcrypto++.so -> libcrypto++.so.9.0.0
lrwxrwxrwx 1 root root 20 May 2 2012 /usr/lib/libcrypto++.so.9 -> libcrypto++.so.9.0.0
-rw-r--r-- 1 root root 5209376 May 2 2012 /usr/lib/libcrypto++.so.9.0.0


It seems like I've got the wrong version of libcrypto++, should I not be using the standard build via apt-get?

-- redmage123

Comments

Sign In or Register to comment.