Peer handshake fails on Private Network

good_joongood_joon Seoul,KoreaPosts: 2Member
I've build webthree-umbrella both on Windows 8.1 and Ubuntu 15.10.
I'm trying to run 2 nodes in private network mode with custom Genesis Info (config.json).

like this
{
"sealEngine": "Ethash",
"params": {
"accountStartNonce": "0x00",
"maximumExtraDataSize": "0xFF",
"tieBreakingGas": false,
"minGasLimit": "0x1388",
"gasLimitBoundDivisor": "0x0400",
"minimumDifficulty": "0x02000",
"difficultyBoundDivisor": "0x0800",
"durationLimit": "0x0d",
"blockReward": "0x4563918244F40000",
"registrar" : "",
"networkID" : "0xA1"
},
"genesis": {
"nonce": "0x0000000000000000",
"difficulty": "0x02000",
"mixHash": "0x0000000000000000000000000000000000000000000000000000000000000000",
"author": "0x0000000000000000000000000000000000000000",
"timestamp": "0x00",
"parentHash": "0x0000000000000000000000000000000000000000000000000000000000000000",
"extraData": "0x",
"gasLimit": "0x1388"
},
"accounts": {
"0096bb9802b14f72ba4cdbd105127fe57a1dafae": { "wei": "10000000000000000000000000000000000"},
"0047d27a61e384403d875239cbc462896044213e": { "wei": "20000000000000000000000000000000000"}
}
}

And I ran eth for each platform with options as belows
[Ubuntu]
./eth --config $ETH_HOME/res/config.json --master 1111 --json-rpc --json-admin 0000 --admin-via-http --no-bootstrap --listen 30302 --remote "192.168.0.122" --port 30301 --db-path $ETH_HOME/db_goodjoon2 --verbosity 99 --json-rpc-port 8546 --ipc --upnp off


[Windows]
.\eth.exe --config d:\ethereum\res\config.json --master 1111 --json-rpc --json-rpc-port 8545 --json-admin 0000 --admin-via-http --listen 30301 --remote "192.168.0.60" --port 30301 --db-path d:\ethereum\db_goodjoon --verbosity 9 --admin-via-http -o full --upnp off --peerset "require:69f5b6b3d0b4e2736b83be5456225032f3f8200bce1c2aa645c2a1fe2d6b90a7f6dc4bd05ef2c90685d774d085b4df1736189107adc1478a3ecf4774e18ea752@192.168.0.60:30301"

I've ran ubuntu node first and then windows 8.1.
But they does not connect to each other and ubuntu just make output as belows (I've grep p2p logs only)

⧎ ▢ 20:56:20.126|p2p Connecting to ##2b5a4f08… @ tcp://192.168.0.122:30301
⧎ ▢ 20:56:20.170|p2p p2p.connect.egress sending auth to tcp://192.168.0.122:30301
⧎ ▢ 20:56:20.224|p2p p2p.connect.egress receiving ack from tcp://192.168.0.122:30301
⧎ ▢ 20:56:21.972|p2p Handshake Failed (I/O Error: End of file )
⧎ ▢ 20:56:21.972|p2p Disconnecting tcp://192.168.0.122:30301 (Handshake Failed)

What's wrong with my options? I just want to setup my private network..

Answers

  • AugustoLAugustoL ArgentinaPosts: 8Member
    Hi, didi you solve it? im having a similar error or teh same, Im running the geth client with the same genesis and network id and the perrs dosent get recognized between each other.
Sign In or Register to comment.