How to add yourself to the stats dashboard (it's not automatic)

2»

Comments

  • AmazingAmazing Posts: 12
    @StephanTual sorry for blasting this page, and I don't even know how many people are reading it. The problem is that after I list, my propagation time is so slow I immediately start to lag behind. Anyone knows how I can improve this time, and stay up-to-date?
  • AmazingAmazing Posts: 12
    I reinstalled using eth instead of geth, and I am listed to the stats page, and I am up-to-date with the blocks, but I am listed as red and only connected to one peer. When I run web3.admin.net.nodeInfo() I get the client as running port: 0
  • jstefanopjstefanop Posts: 41
    Is there anyway to get your local node health info from geth console? Similar to all the awesome stats displayed on ethstats? For example i want to know what my node latency and propagation time is.
  • index932index932 Posts: 10
    I have used one of the resources available above to setup this and I see the following. Why is my 'Watching' shows disabled and how do I make sure I am appearing on the https://ethstats.net/ Please advise.

    ==> Restarting processes
    [PM2] Spawning PM2 daemon
    [PM2] PM2 Successfully daemonized
    [PM2] Process launched
    [PM2] Process launched
    ┌──────────┬────┬──────┬──────┬────────┬─────────┬────────┬─────────────┬──────────┐
    │ App name │ id │ mode │ pid │ status │ restart │ uptime │ memory │ watching │
    ├──────────┼────┼──────┼──────┼────────┼─────────┼────────┼─────────────┼──────────┤
    │ eth │ 0 │ fork │ 7540 │ online │ 0 │ 0s │ 2.473 MB │ disabled │
    │ node-app │ 1 │ fork │ 7546 │ online │ 0 │ 0s │ 11.586 MB │ disabled │
    └──────────┴────┴──────┴──────┴────────┴─────────┴────────┴─────────────┴──────────┘
  • bitswapperbitswapper Posts: 3
    I tried going to the URL for the skype channel, and the page doesn't load at all. So how do you get the 'secret' key for app.json?
  • cubedrocubedro BucharestPosts: 2
    index932 said:

    I have used one of the resources available above to setup this and I see the following. Why is my 'Watching' shows disabled and how do I make sure I am appearing on the https://ethstats.net/ Please advise.

    ==> Restarting processes
    [PM2] Spawning PM2 daemon
    [PM2] PM2 Successfully daemonized
    [PM2] Process launched
    [PM2] Process launched
    ┌──────────┬────┬──────┬──────┬────────┬─────────┬────────┬─────────────┬──────────┐
    │ App name │ id │ mode │ pid │ status │ restart │ uptime │ memory │ watching │
    ├──────────┼────┼──────┼──────┼────────┼─────────┼────────┼─────────────┼──────────┤
    │ eth │ 0 │ fork │ 7540 │ online │ 0 │ 0s │ 2.473 MB │ disabled │
    │ node-app │ 1 │ fork │ 7546 │ online │ 0 │ 0s │ 11.586 MB │ disabled │
    └──────────┴────┴──────┴──────┴────────┴─────────┴────────┴─────────────┴──────────┘

    The watching option is used by pm2 for watching the folders for changes. It has nothing to do with the node, so you're good. To make sure everything is fine just check the logs running: pm2 logs 1
  • cubedrocubedro BucharestPosts: 2

    I tried going to the URL for the skype channel, and the page doesn't load at all. So how do you get the 'secret' key for app.json?

    The skype channel link is this
  • bitswapperbitswapper Posts: 3
    So when I try "pm2 start app.json" I get "/usr/bin/env: node" I'm running on ubuntu 15.10. It looks like /usr/local/lib/node_modules/pm2/bin/pm2 wants to run a program named "node" but I don't seem to have it. ANy idea on how to get it?
  • bitswapperbitswapper Posts: 3

    So when I try "pm2 start app.json" I get "/usr/bin/env: node" I'm running on ubuntu 15.10. It looks like /usr/local/lib/node_modules/pm2/bin/pm2 wants to run a program named "node" but I don't seem to have it. ANy idea on how to get it?

    Ah - I did "sudo apt-get install nodejs-legacy" and that installed the needed program "node" apparently. Not sure if that's the right way to fix it tho...
  • t0mit0mi AustriaPosts: 12
    can anyone tell me why my node shows 0KH/s? My own rig mines to my node with 40 MH/s.
  • t0mit0mi AustriaPosts: 12
    t0mi said:

    can anyone tell me why my node shows 0KH/s? My own rig mines to my node with 40 MH/s.

    if anyone else wanna know, use geth 1.4.0-unstable
  • TTHTTH Posts: 3
    I am running an ethereum nodes and would like to register it on ethstats. I do not have any WS key, neither skype running on my machine. Any other solution to get a key ? I would prefer not installing skype on my Linux box for many reasons
  • TTHTTH Posts: 3
    The link to get ws secret was dead, as already mentioned. Now it is ok and I get the key.
  • goodc0regoodc0re Posts: 1
    I can't join skype to get a key, is there an alternative way?
  • donaldtrump2016donaldtrump2016 Posts: 7
    The windows version does not seem to be working. It keeps on spawning a node cmd line and then it quits and then it pops up again for another minute or so....
  • donaldtrump2016donaldtrump2016 Posts: 7
    Windows version is working for me.
  • aswinkaswink Posts: 1
    @donaldtrump2016 hey can you explain how you got the windows versino to be running ? my app stops trying to execuite eth.sh file. Don't remember seeing any bash files inside!
    May be i an learn from you...
  • tungsonmtptungsonmtp Posts: 1
    Because Skype is Microsoft crap.
  • AwesomeboyAwesomeboy Posts: 7
    Please share what and how you did it
Sign In or Register to comment.