3GB Mining Rigs stopped mining ETH/ETC

FreyrFreyr Member Posts: 6
I have several rigs with whicht I have been mining ETH, they have all been working well untill yesterday. Each machine that has had to restart the miner or do a complete reboot will not load the DAG anymore. The rigs that didnt reboot/restart miner yet are still mining ETH. From what I gather the DAG should be ~2.4GB right now which shouldnt be a problem for these cards.

The error message when miner starts: Cannot allocate big buffer for DAG
All rigs have GTX1060 3GB cards, Using the Claymore miner (Phoenix has same problem) and the Virtual memory is set over 16GB.

Does anyone have any ideas why this happened?

Comments

  • JukeboxJukebox Member Posts: 639 ✭✭✭
    Freyr said:

    and the Virtual memory is set over 16GB.

    How many cards in the rig and what exact virtual memory setting?
    What to check - add '-di 1' option to startup string, save, run and inform here what happens.
  • FreyrFreyr Member Posts: 6
    Each rig has 6 cards, the Virual Memory is set as: Start 16000 & Max 32000
    All Rigs are exactly same (Hardware, OS, software & settings)

    A few rigs are still mining ETH however I expect as soon as they crash or reboot for whatever reason they wont be able to start mining ETH again. The rigs that couldnt start mining ETH anymore are now mining ZEC so there are no hardware faults or whatever.

    The '-di' option only starts the 1st GPU (with these settings) but gives the same error as soon as the DAG should be loaded into GPU memory.

  • iamnoobplzhelpiamnoobplzhelp Member Posts: 238 ✭✭
    I had a similar problem with my PC that just has a single 1060 3GB. I mine on it when I'm just browsing.

    I had to closer my browser then it worked okay.

    Try closing all other applications, start mining, then restart the other applications.
  • JukeboxJukebox Member Posts: 639 ✭✭✭
    edited March 16
    Freyr said:

    Each rig has 6 cards, the Virual Memory is set as: Start 16000 & Max 32000
    All Rigs are exactly same (Hardware, OS, software & settings)

    A few rigs are still mining ETH however I expect as soon as they crash or reboot for whatever reason they wont be able to start mining ETH again. The rigs that couldnt start mining ETH anymore are now mining ZEC so there are no hardware faults or whatever.

    The '-di' option only starts the 1st GPU (with these settings) but gives the same error as soon as the DAG should be loaded into GPU memory.

    Show me your whole start.bat content. Try to help.
  • asusrigasusrig Member Posts: 126
    The DAG might be less than 3 GB but all of your 3GB per card is not available to them either. When we purchased 1060 cards a few months ago they were all 6 GB models to avoid this situation. Most of the cards in our rigs have 8 and 11 GB.

    https://www.reddit.com/r/EtherMining/comments/84jjkv/3gb_1060_will_die_at_epoch_180/#bottom-comments

    From a poster in link above:

    "There's not a hard point where they won't work any more. It depends on what else is stuffed into your card's memory.

    Some folks running Windows already cannot use 3GB cards. Others should be good until much closer to when the DAG is actually 3GB.

    I expect that the number of people with 3GB cards that cannot mine will increase next month, when ETH has a DAG of ~2.5GB, and the number will grow through the rest of the year until the DAG breaks 3GB."
  • peshetomanpeshetoman Member Posts: 78
    Try reinstalling windows and disabling the updates.
  • FreyrFreyr Member Posts: 6
    Jukebox said:

    Show me your whole start.bat content. Try to help.

    setx GPU_FORCE_64BIT_PTR 0
    setx GPU_MAX_HEAP_SIZE 100
    setx GPU_USE_SYNC_OBJECTS 1
    setx GPU_MAX_ALLOC_PERCENT 100
    setx GPU_SINGLE_ALLOC_PERCENT 100
    EthDcrMiner64.exe -epool eu1.ethermine.org:4444 -ewal 0xMyWallet.miner01 -epsw x -r 1 -dbg -1

    Try closing all other applications, start mining, then restart the other applications.

    Only have the bare minimum programs started, Tried mining without MSI afterburner. Still doent work, so dont think that is it.
    asusrig said:

    There's not a hard point where they won't work any more. It depends on what else is stuffed into your card's memory.

    I figured ETH would hit POS before reaching the DAG size that a 3G card couldnt handle anymore, I cannot imagine what else could be stuffed in the memory since there are no other applications running and other exact same rigs also using the same MSI GTX Armor 3G cards are still running!
    Will keep my eye on that reddit thread, thanks.

    Try reinstalling windows and disabling the updates.

    The systems update functions were all disabled during initial OS installation, The only contact they have is with either the pool or my remote desktop. However if I really really cant find a way to get them working again I will try that in a few days.
  • jsanzspjsanzsp Member Posts: 195 ✭✭
    edited March 20
    same problem here all gtx 1060 stop mining. Cannot allocate big buffer - Not enough graphics memory ...
    Has anyone tried ethos or similar or in old windows versions?
  • jsanzspjsanzsp Member Posts: 195 ✭✭
    edited March 20
    Ok solved in one rig at the moment. add command -eres 0 in start.bat
  • FreyrFreyr Member Posts: 6
    jsanzsp said:

    Add command -eres 0 in start.bat

    Thanks alot! that worked for all rigs with 3G cards!
    I hope you figure out the problems with your other cards soon.
    Cheers :)
  • jsanzspjsanzsp Member Posts: 195 ✭✭
    - eres 0 dont work now. I'm thinking, go linux,
    windows eats 600mb of vram on each gpu
  • Ericjh801Ericjh801 Utah, USAMember Posts: 362 ✭✭
    Grab the newest version of Claymore (11.6). He modified it so you can still mine ETH with 3gb cards for a bit longer.
  • Wasp0Wasp0 Member Posts: 48
    GO LINUX, windows SUCKS! SMOS or HIVE (Other Linux Miners available).

    Why battle with windows, ditch it, remove you hard drive from your system, get a 8Gb (16Gb better) USB and go for uninterrupted mining.
  • Miner8472Miner8472 Member Posts: 109
    -eres 0 does work for me on 3gb cards windows 10
  • agenteagente Member Posts: 4
    Miner8472 said:

    -eres 0 does work for me on 3gb cards windows 10

    not now. Stop working for me.. even if with 36000 buffer. I will try claymore 11.6
  • Miner8472Miner8472 Member Posts: 109
    i can report that it has stopped working for me again today for 3gb
  • techtottechtot Member Posts: 336 ✭✭
    I dont think it was an update that caused it. DAG Size+ Win 10 = no ether mining with 3GB. The good news is that Win 7 still hashes away fine with 3GB cards, and of course linux, perfectmine.io , ethos, and SMOS still work. I have heard that server 2012/2016 still works fine also..but will require a reinstall unless someone knows a trick.
  • Miner8472Miner8472 Member Posts: 109
    Version 11.6 claymore works for me on Windows 10.
  • techtottechtot Member Posts: 336 ✭✭
    when did that release come out? what day exactly..i tried some older claymores that did not work. Also what version of windows 10? (type "ver" and should get a response like Microsoft Windows [Version 10.0.16299.309])
  • Ericjh801Ericjh801 Utah, USAMember Posts: 362 ✭✭
    11.6 came out on 3/30. Link to official release info : https://bitcointalk.org/index.php?topic=1433925.0
    You can see the download links from there.
    The machine i had running on 3gb still was/is on version [Version 10.0.16299.371] I've moved onto another coin though for now.
  • techtottechtot Member Posts: 336 ✭✭
    cool. thanks. ill try that combo for the rigs that stopped working. yes, zcash and monero are almost better now..
  • Ericjh801Ericjh801 Utah, USAMember Posts: 362 ✭✭
    I switched back to ETH. 3gb card still working great.
  • lablettlablett Member Posts: 320 ✭✭
    My new 580's with 8GB are mining ETH. My older 7950's are mining UBIQ and hey are pulling 23 Mh/s each and based on the current prices older cards are better off mining UBIQ!!!!
  • jsanzspjsanzsp Member Posts: 195 ✭✭
    Solved instaling Windows 7 in one rig and SMOS (linux) in other rig.
  • jsanzspjsanzsp Member Posts: 195 ✭✭
    Wasp0 said:

    GO LINUX, windows SUCKS! SMOS or HIVE (Other Linux Miners available).

    Why battle with windows, ditch it, remove you hard drive from your system, get a 8Gb (16Gb better) USB and go for uninterrupted mining.

    the problem with linux is the power consumption in AMD cards. in nvidia cards unvervolt woks OK.
  • rmhrmh Member Posts: 399 ✭✭✭
    jsanzsp said:

    Wasp0 said:

    GO LINUX, windows SUCKS! SMOS or HIVE (Other Linux Miners available).

    Why battle with windows, ditch it, remove you hard drive from your system, get a 8Gb (16Gb better) USB and go for uninterrupted mining.

    the problem with linux is the power consumption in AMD cards. in nvidia cards unvervolt woks OK.
    Voltage offset bios mod works great with linux, the ghetto-style kernel patching is also a method for undervolt, amdgpu + ohgodatool mostly seems working and i heard that with roc-smi, you can do anything.
  • SaphSaph Member Posts: 68
    You've got weeks, maybe a month or two at best on 3gb cards. This is expected and working as intended, the recent difficulty drop has been 3gb cards dropping like flys.
  • Ericjh801Ericjh801 Utah, USAMember Posts: 362 ✭✭
    Current DAG size is 2.42 GB for ETH (https://investoon.com/tools/dag_size) I think it will be a lot longer than a month depending on what OS you are running. Windows 10 will be the first to drop and linux the last so just keep that in mind memory usage wise. Claymore does a good job extending memory in Win10 for now.
Sign In or Register to comment.