HDMI Dummy Problem: RX580 rig uses more power and Claymore gives memory errors

asusrigasusrig Member Posts: 99
The RX580 cards in my rigs are not reporting temps or fans to Claymore when nothing is plugged into any of the display ports of the cards. My 1070 ti cards don't have this problem and correctly report fan speeds and temps regardless if there are HDMI dummies plugged into the cards.

I have tested this twice now with the same issue.

When I plug the HDMI dummy into one card and remote into it with RDP Claymore will not show fan speed or temps in the console or from another computer via Claymore Manager. Even if I restart Claymore the stats are not displayed. I then close RDP and VNC into the rig. When I start up Claymore I do get temps and fan speeds. Claymore Manager also report the speeds. But Claymore then constantly restarts because of memory errors. I do have overclocking set pretty high and the RX580 cards are mining at around 31.65 - 31.70 mh/s each.

I then close the VNC app and remote back in via RDP. When I then start the mining software my UPS errors out because the cards are drawing more power than they should. They are also mining at lower speeds, around 30.5 mh/s.

The only solution I have is to remove the HDMI Dummy and reboot the rig. When it first happened a few weeks ago I did not realize what was going on and ended up reinstalling the drivers. However it appears not to be necessary and once the dummy is removed and the rig rebooted all is fine again, except I can't see the temps / fan speeds.

I installed Awesome Miner and that does allow me to get those stats from the rig but you have to go through a bunch of steps for each rig to get the data. It would have been really great if Claymore's Manager could report these stats without the use of a dummy.

It seems the 4k dummy places a lot of stress on the card because it now thinks it should display an image. Not sure if anyone else has noticed this. I think you can go further with overclocking when the cards don't have any monitors or dummies plugged into them.

Comments

  • Ericjh801Ericjh801 Utah, USAMember Posts: 350 ✭✭
    That's interesting. I'm having the issue where claymore only shows Temp/Fan speed for 1 GPU out of the 8. I'm using a headless DVI in the motherboard graphics though instead of on one of the miners. I started it via RDP, maybe I should try starting it via VNC/Teamviewer. You'll have to let me know if you figure out something.
  • cjclm7cjclm7 Member Posts: 72
    I do not even understand why you need those HDMI plugs on a AMD GPU in first place...

    If you running on Windows just keep it simple and use MSI Afterburner to control Fans (set fan control and adjust graph there).

    Is first time I heard about using HDMI dummy plugs on a AMD RX580. If it works perfectly without them why you need complicate it?
  • asusrigasusrig Member Posts: 99
    cjclm7 said:

    I do not even understand why you need those HDMI plugs on a AMD GPU in first place...

    If you running on Windows just keep it simple and use MSI Afterburner to control Fans (set fan control and adjust graph there).

    Is first time I heard about using HDMI dummy plugs on a AMD RX580. If it works perfectly without them why you need complicate it?

    It is not to control the fan speeds. It is to keep an eye on the cards to make sure everything is working as it should. I don't even use Afterburner for the RX580 cards. They have a modified bios and Afterburner is not needed. The fan speeds are set with Trixx.

    With Awesome Miner I discovered that two RX580 cards on one rig had fan speeds of 65% and the rest were at 50%. I could have logged in remotely via RDP / VNC and checked it with HWinfo, Trixx etc. but that is time consuming. It is much easier to keep tabs on fan speeds and temps in a small interface like Claymore Manager that reports them all in one line. Have you ever used Claymore Manager? Without the dummy the RX580 cards do not report fan speeds and temperatures to Claymore's miner.
  • asusrigasusrig Member Posts: 99
    Ericjh801 said:

    That's interesting. I'm having the issue where claymore only shows Temp/Fan speed for 1 GPU out of the 8. I'm using a headless DVI in the motherboard graphics though instead of on one of the miners. I started it via RDP, maybe I should try starting it via VNC/Teamviewer. You'll have to let me know if you figure out something.

    Not sure. My rigs have seven 1070 ti cards and six RX580 cards running off a single Asus Mining Expert motherboard. So that complicates it further compared to your setup I believe.
  • Ericjh801Ericjh801 Utah, USAMember Posts: 350 ✭✭
    edited February 12
    I ended up getting mine to function correctly last night. The way I did it was to reboot them with a dummy plug on the motherboard video card (DVI) then use teamviewer to connect and restart Claymore. After that, all 8 showed Temps/Fan speeds. Not sure why it doesn't like being started via RDP but this seemed to work. Just a thought to try if you have an onboard card so it thinks video is being fed to a none mining card.

    Note i'm using Windows 10 and the newest AMD drivers (18.x) Also using Claymore 10.5.
  • asusrigasusrig Member Posts: 99
    Ericjh801 said:

    I ended up getting mine to function correctly last night. The way I did it was to reboot them with a dummy plug on the motherboard video card (DVI) then use teamviewer to connect and restart Claymore. After that, all 8 showed Temps/Fan speeds. Not sure why it doesn't like being started via RDP but this seemed to work. Just a thought to try if you have an onboard card so it thinks video is being fed to a none mining card.

    Note i'm using Windows 10 and the newest AMD drivers (18.x) Also using Claymore 10.5.

    I have an onboard Intel HD video card (Asus Mining Expert Motherboard) and there is a dummy plugged into it. That dummy helps because without it one of the Nvidia or AMD cards would drop hash rate when you RDP or VNC into the rig. With the dummy in the Intel GPU there is no drop in the hash rates when I RDP or VNC to the rig.

    I'll try Teamviewer to see if that changes it. I don't like the latest AMD drivers because you have to set compute mode individually (six times in my case) for each card in the rig. And even then I have found that the cards are drawing more power and maxing out my UPS. The best driver in my experience has been the block chain beta driver from AMD. But maybe that is why temps are not reported as yours.

    I have found another workaround. HWinfo64 will allow you to connect networked computers so you can monitor all their sensors. And you can turn of sensors that you are not interested in. I'll be able to monitor all rigs with that software from my personal computer and get fan speeds, temps, power usage etc. Pretty cool software.
  • Ericjh801Ericjh801 Utah, USAMember Posts: 350 ✭✭
    I've been using HWinfo64 but didn't know you could connect, i'll have to check that out. As far as the new AMD drivers, you don't have to do them one at a time, there is a registry edit you can do to manually set them all to compute mode, just reboot and done. (I did 8 at once, no problems).

    You'll have to let me know if team viewer works any better. Starting on another rig today, picked up a RX 480 8gb card locally for $220! :)
  • asusrigasusrig Member Posts: 99
    Ericjh801 said:

    I've been using HWinfo64 but didn't know you could connect, i'll have to check that out. As far as the new AMD drivers, you don't have to do them one at a time, there is a registry edit you can do to manually set them all to compute mode, just reboot and done. (I did 8 at once, no problems).

    You'll have to let me know if team viewer works any better. Starting on another rig today, picked up a RX 480 8gb card locally for $220! :)

    Hey thanks for that tip! Do you have a link to that registry edit?

    What's really cool about hwinfo is you can have multiple columns side by side so it would be possible to view a ton of GPUs on one screen. I use a 40" 4k which helps to monitor things.

    Claymore Manager is still the best though to get a quick overall view of the cards in a compact interface. There is some room for improvement but it is very handy. I wish the Zcash miners had something comparable.

    Awesome Miner is also very cool and can work with most miners but not free so I'll pass on that.

    Not a bad deal with that 480! Pretty soon you'll be pushing 2 GH/s
  • rmhrmh Member Posts: 381 ✭✭✭
    asusrig said:

    Do you have a link to that registry edit?

    add this DWORD to the below registry path: KMD_EnableInternalLargePage, set value to 2 to enable compute mode

    "HKLM\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\XXXX"
    where "XXXX" is the card number.
    for example:
    HKLM\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0001
    HKLM\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0002



  • asusrigasusrig Member Posts: 99
    rmh said:

    asusrig said:

    Do you have a link to that registry edit?

    add this DWORD to the below registry path: KMD_EnableInternalLargePage, set value to 2 to enable compute mode

    "HKLM\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\XXXX"
    where "XXXX" is the card number.
    for example:
    HKLM\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0001
    HKLM\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0002



    Thanks!
  • asusrigasusrig Member Posts: 99
    edited February 17
    Ericjh801 said:

    I ended up getting mine to function correctly last night. The way I did it was to reboot them with a dummy plug on the motherboard video card (DVI) then use teamviewer to connect and restart Claymore. After that, all 8 showed Temps/Fan speeds. Not sure why it doesn't like being started via RDP but this seemed to work. Just a thought to try if you have an onboard card so it thinks video is being fed to a none mining card.

    Note i'm using Windows 10 and the newest AMD drivers (18.x) Also using Claymore 10.5.

    This also worked for me. Dummy in onboard video. Connected to rig via VNC instead of RDP and started Claymore. Temperatures are reported.

    But the problem is I get memory error messages from Claymore and the hashing keeps resetting. This is because I am running an extreme memory setting in Claymore's command line. When I remove the higher memory speed setting it works fine and report temperatures.

    When I connect via RDP and start Claymore the cards hash fine with the extreme settings but no temperatures or fan speeds are reported.

    I have two rigs running with extreme settings (190 mh/s for 6 cards) and 1 rig with the reduced memory setting (186 mh/s for 6 cards) but with temps / fans speed reported. Will be comparing how they perform on Nanopool over a week and see if the extreme setting really translates into more profit.


  • asusrigasusrig Member Posts: 99
    rmh said:

    asusrig said:

    Do you have a link to that registry edit?

    add this DWORD to the below registry path: KMD_EnableInternalLargePage, set value to 2 to enable compute mode

    "HKLM\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\XXXX"
    where "XXXX" is the card number.
    for example:
    HKLM\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0001
    HKLM\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0002



    We just finished a new rig with 9 RX580 cards (Sapphire and Asus mix). Not sure if it is because we used the latest driver which could be beta but when we changed the registry per your method the cards were all still stuck in Graphics Mode.

    Tried this tool in link below which sets the registry settings automatically.

    https://bitcointalk.org/index.php?topic=2815803.0

    The registry is set but it makes no difference. Does the computer have to be rebooted or shutdown for it to work? We rebooted also and even then the cards were in Graphics mode after the setting. Only solution is to set manually to compute mode and I am not going through that mess.

    The trusty Beta Blockchain driver that I prefer could not be used in this instance because Windows crashes after logging on. I am thinking maybe that driver does not support more than 8 GPUs but Windows would crash even with 5 Sapphire and 3 Asus cards.
  • Ericjh801Ericjh801 Utah, USAMember Posts: 350 ✭✭
    The beta blockchain drivers only support 8 cards. You have to use the newer AMD ones (18.2.2 is what i'm on) and it supports more (but I don't have anymore than 8 yet). Usually you just have to modify that registry key and reboot and you are done. All else fails, manual method (yay?, 30 mins wasted time).
  • asusrigasusrig Member Posts: 99
    Ericjh801 said:

    The beta blockchain drivers only support 8 cards. You have to use the newer AMD ones (18.2.2 is what i'm on) and it supports more (but I don't have anymore than 8 yet). Usually you just have to modify that registry key and reboot and you are done. All else fails, manual method (yay?, 30 mins wasted time).

    Yes we tried 18.2.2 which was labelled as "Optional" on AMD's site and I guess that means it is Beta itself. It did not work well and we received errors in Windows about missing files or could not load some dll files. Removed with DDU and reinstalled and still same errors. And cards would mine at 18-20 mh/s after applying the Registry hack. Setting the cards individually into Compute Mode worked but that is just too time consuming.

    Last night after I made this post I decided to try 18.2.1. Installed without issues and no error messages, ran the automated hack to fix the registry. Tried Claymore and cards were still hashing at 20 mh/s except for one or two that were around 31 mh/s. Ran the automated tool again to reset them all to Graphics Mode. And then set them all back to Compute Mode. Rebooted the rig.

    Ran Claymore again and one by one the cards started to hash at over 31 mh/s. Some would be at 20-26 for a minute or two but eventually they all settled in at 31.4 - 31.7.



  • asusrigasusrig Member Posts: 99
    edited February 22
    Ericjh801 said:

    The beta blockchain drivers only support 8 cards. You have to use the newer AMD ones (18.2.2 is what i'm on) and it supports more (but I don't have anymore than 8 yet). Usually you just have to modify that registry key and reboot and you are done. All else fails, manual method (yay?, 30 mins wasted time).

    EDIT: This is a double post because post above ended up in SPAM box and was recovered by Moderator.

    It was 18.2.2. That driver gave us errors when Windows first started (missing dll files etc.). I removed the driver and tried 18.2.1 and got it working finally after running the automated registry hack!


    Post edited by asusrig on
Sign In or Register to comment.