Problems with Parity on RasPi

csaarcsaar GermanyMember Posts: 2
Hi guys,
i'm happy to join this community, i have been following it the last few months.
I decided to setting up an old Raspberry Pi 2 as wallet, because i dont want to use an online wallet.

Flashed this Pariy image on my sd-card, subsequently I configured the basic pi settings (update/upgrade, static ip, crontab, ..). After this I installed nginx to expose the ui (using this config.
Everytime I try to acces the webinterface I get following error message:
Connecting to the Parity Node. If this informational message persists, please ensure that your Parity node is running and reachable on the network.


Anyone has an idea, how I can fix this?

###

Additionally installed software:
nginx, locate, screen

Already tried to restart the pi, parity process is running:

pi@ethnode-e3b0c442:~ $ systemctl status parity ● parity.service - Ethereum Parity client daemon Loaded: loaded (/etc/systemd/system/parity.service; enabled) Active: active (running) since Mon 2017-10-16 21:16:06 CEST; 2h 6min ago Main PID: 709 (parity) CGroup: /system.slice/parity.service └─709 /usr/bin/parity --warp --cache 256

Starting sudo parity:
pi@ethnode-e3b0c442:~ $ sudo parity 2017-10-16 21:40:28 Starting Parity/v1.6.8-beta-c396229-20170608/arm-linux-gnu/rustc1.17.0 2017-10-16 21:40:28 State DB configuration: fast 2017-10-16 21:40:28 Operating mode: active 2017-10-16 21:40:28 Configured for Foundation using Ethash engine 2017-10-16 21:40:32 Network port V4(0.0.0.0:30303) is already in use, make sure that another instance of an Ethereum client is not running or change the port using the --port option. RPC address 127.0.0.1:8545 is already in use, make sure that another instance of an Ethereum client is not running or change the address using the --jsonrpc-port and --jsonrpc-interface options.

Thanks, greetings Chris

Comments

Sign In or Register to comment.