Why Memory Clock Not Effecting ETH Hash Rate??

AVPAVP Member Posts: 13
So for some reason my memory clock has absolutely no effect on my ETH hash rate.

Everywhere I read, everyone is saying that its the memory clock that has most impact on ETH hash rate, but I see absolutely no increase between 1750 -> 2150.

The only way I'm able to bump up the hash rate is increasing GPU clock, its a very slight bump, going from 1050 -> 1125 gives me a bump of 0.75 MH.

Using Sapphire RX 470's 4GB Nitro (Non +).

I tried modded bios, 1500, 1425 & even 1375 straps. I'm undervolting GPU, but not touching the memory voltage.

But no matter what I do memory clock has no effect on hash rate.

What could be wrong and any way to fix this? Do I need to overvolt GPU memory?

Answers

  • sutheksuthek Member Posts: 185
    and your hashrate is....?
    and your memory is.....?

    talking about hashrate and didn't even post your hashrate...
    talking about memory clock and don't even talk about your memory.

    swing and a miss for your first ever post.
    Asking for help without posting anything remotely useful.
  • AVPAVP Member Posts: 13
    suthek said:

    and your hashrate is....?
    and your memory is.....?

    talking about hashrate and didn't even post your hashrate...
    talking about memory clock and don't even talk about your memory.

    swing and a miss for your first ever post.
    Asking for help without posting anything remotely useful.

    Sure, please see details below:

    1050 / 1950 = 24.5MH
    1050 / 2100 = 24.5MH
    1050 / 1750 = 24.5MH

    If I bump GPU core to 1125 I see a slight increase:
    1125 / 1950 = 25.2MH
  • EtherminerJayEtherminerJay Member Posts: 157
    Copy your second highest strap to your highest strap and up the mem clock via the bios too.

    Any other tweaks try using MSI afterburner or something similar
  • AVPAVP Member Posts: 13

    Copy your second highest strap to your highest strap and up the mem clock via the bios too.

    Any other tweaks try using MSI afterburner or something similar

    For me this would be copying 1750 -> 2000

    I have not tried that yet, so I'l give it a shot right now and share my results. Thanks for suggestion.
  • EtherminerJayEtherminerJay Member Posts: 157
    edited August 12
    Yes perfect. I have done this on all of my cards and had good results on them.

    Whats the mem clock set to in bios (polarbios editor)? If the standard is 2000 try going up to 2200.

    Any other tweaks try via msi afterburner or something similar. Let me know how you get on
  • AVPAVP Member Posts: 13
    Just tried it and using 1750 straps lowered my hash rates from 24.5MH to 22.4MH.

    As far as strap go 1500 or 1425 straps give me best results so far. But no matter what memory speed has no effect. Now I'm certain that I am successfully setting memory speed as I'm able to confirm it in GPU-Z. I have tried setting memory speed in TRIXX & in BIOS. Still nothing..

    I have no idea whats going on..
  • sutheksuthek Member Posts: 185
    99% sure you have hynix memory and basically are doing everything wrong.
  • AVPAVP Member Posts: 13
    OK quick update:

    So changing Memory Clock whilst already running Claymore miner makes no difference in hash rate. Only after I restart Claymore, or set the memory clock before starting the miner, only then I can see a change in hash rate.

    I'm able to change GPU clock during miner operation and see the difference, but not memory clock. For memory clock changes to take effect I have to restart the miner. Not sure if this is the same for everyone... (feel free to share your observation on this)

    So now I'm able to hit 26.48MH @ 1125 / 2100 with 1500 strap
  • EtherminerJayEtherminerJay Member Posts: 157
    What driver De you using
  • AVPAVP Member Posts: 13
  • EtherminerJayEtherminerJay Member Posts: 157
    And what version of Windows? Win 10?

    https://www.monitortests.com/forum/Thread-AMD-ATI-Pixel-Clock-Patcher

    Download and run the amd pixel patcher, links in the first box at the top.

    Restart after you've done this
  • AVPAVP Member Posts: 13

    And what version of Windows? Win 10?

    https://www.monitortests.com/forum/Thread-AMD-ATI-Pixel-Clock-Patcher

    Download and run the amd pixel patcher, links in the first box at the top.

    Restart after you've done this

    Isn't that only for newer drivers when your card isn't recognized after bios flash??
  • EtherminerJayEtherminerJay Member Posts: 157
    Haven't you edited your bios, give it a shot it takes aboit 3 seconds to download and run
  • AVPAVP Member Posts: 13
    Thanks. I'm familiar with that patcher its needed for newer versions of AMD Drivers that do Bios signature check. This isn't an issue for 16.9.2 drivers which I'm using.

    In either case I ran it. But it made no difference in my situation.

    I'm able to see slight hash rate difference but I need to set it before launching the miner. Having a few stability issues at the moment.

    BTW using Windows 10.
  • EtherminerJayEtherminerJay Member Posts: 157
    Not exactly true in my experience - Only the other day after modding one of my RX 480 cards when I rebooted not every section via MSI afterburner was available - Ran pixel patcher restarted and it they were then available

    Using Crimson 19.7.2 Win 10 on my Rig currently

    How many cards do you have

  • AVPAVP Member Posts: 13
    I'm running a rig w/ 5 RX 470s at the moment.

    In any case I got this issue resolved. For anyone else facing the same:

    For some reason if memory speed is changed while the miner is already running there is no change in the hash rate. If I restart the miner or set the speed before starting the miner I'm able to see expected hash rates.
Sign In or Register to comment.