Gforce GTX 970 strix problem, very low hasrate(tryed everything what i could find)

Gskill666Gskill666 Member Posts: 1
edited July 2017 in Mining
Hello everyone.
I recently build myself a rig with 3 GTX 970 strix 4GB OC (https://www.amazon.com/GeForce-Overclocked-256-bit-DisplayPort-Graphics/dp/B00NJ9BJ8G)
I am currently running Win7 64bit. The miners are working with both claymore and Genoil, the problem is i get a very low hashrate.
I the the 347 driver and the 361 driver, same result for both around 3-4 MH/s for each card.
I have tried every forum tread i could find on this topping, setting it to P0 state was impossible since i get N/A when i try to get the clock list (read its some nvidia bug will try to fix it later).

For the moment i am trying to figure out what the problem is.

Here are the .bat file codes i am trying to run.(My wallet address is is changed so no problem there )

For claymore:
(Miners i tryed are Claymore's Dual Ethereum+Decred_Siacoin_Lbry_Pascal AMD+NVIDIA GPU Miner v9.2 , and v9.6)
EthDcrMiner64.exe -epool eth-eu.dwarfpool.com:8008 -ewal My Wallet Address

Genoil: (OpenCPL)
ethminer.exe -G -F http://eth-eu.dwarfpool.com:80/My Wallet Address

I am welcome to any suggestion at the moment, i tried with MSI afterburner to get some more out of it but nothing.

Here are some screenshots of Nvidia Inspector for each card (i have no idear why they run in P2 state tryed to set it to P0 no luck till now)




Here is my Hashrate (ethminer-0.9.41-genoil-1.1.6-pre > Ethermine-Stratum-CUDA)






Post edited by Gskill666 on

Comments

  • JosephTDJosephTD Member Posts: 23
    edited July 2017
    I suggest using Claymore v9.7
    and using these specific drivers
    And you should be seeing around 16 to 17 hash, and if that does not work check if your GPU's are getting enough power.
    http://www.nvidia.com/download/driverResults.aspx/81877/en-us
  • xpointxpoint Member Posts: 17
    install all windows update, then will start work, if not then reinstall windows with new version
  • keraj37keraj37 Member Posts: 5
    edited July 2017
    I am mining with my GTX 970 on Windows 10 x64 in average 15.5mh/s - that is the max I could get.
    I had exactly same hashrate as you (2-4mh/s).

    Here is what I did and maybe will help you too:

    1. Instead of CUDA mine on OpenCL - with CUDA 6.5 build I could get max 10.2mh/s. With OpenCL it jumped to 15.5mh/s and I could use my build of genoil fork.
    2. I use 347.88 driver: http://www.nvidia.com/download/driverResults.aspx/83080/en (make sure to prevent Windows to automatically update the drivers!)

    Still it is low for that card - I think it should be at average 18-20mh/s, but is much better then initial 2-4mh/s :).

    I will try to improve this rate.

    EDIT - I see actually that you use same setup - so could you please use this ethminer build: https://github.com/Genoil/cpp-ethereum/blob/110/releases/cuda-6.5/ethminer-0.9.41-genoil-1.1.7-cuda6.5.zip, and check if it is better?

    Also check my bath file I use: https://github.com/keraj37/ethminer_setup/blob/master/ethermine.org.pool.bat

    setx GPU_FORCE_64BIT_PTR 0 setx GPU_MAX_HEAP_SIZE 100 setx GPU_USE_SYNC_OBJECTS 1 setx GPU_MAX_ALLOC_PERCENT 100 setx GPU_SINGLE_ALLOC_PERCENT 100 ethminer.exe --farm-recheck 200 -G -S eu2.ethermine.org:4444 -FS eu2.ethermine.org:4444 -O 0xffffffffffffffffffffff.foo

  • ckailianckailian Member Posts: 28
    keraj37 said:

    I am mining with my GTX 970 on Windows 10 x64 in average 15.5mh/s - that is the max I could get.
    I had exactly same hashrate as you (2-4mh/s).

    Here is what I did and maybe will help you too:

    1. Instead of CUDA mine on OpenCL - with CUDA 6.5 build I could get max 10.2mh/s. With OpenCL it jumped to 15.5mh/s and I could use my build of genoil fork.
    2. I use 347.88 driver: http://www.nvidia.com/download/driverResults.aspx/83080/en (make sure to prevent Windows to automatically update the drivers!)

    Still it is low for that card - I think it should be at average 18-20mh/s, but is much better then initial 2-4mh/s :).

    I will try to improve this rate.

    EDIT - I see actually that you use same setup - so could you please use this ethminer build: https://github.com/Genoil/cpp-ethereum/blob/110/releases/cuda-6.5/ethminer-0.9.41-genoil-1.1.7-cuda6.5.zip, and check if it is better?

    Also check my bath file I use: https://github.com/keraj37/ethminer_setup/blob/master/ethermine.org.pool.bat

    setx GPU_FORCE_64BIT_PTR 0 setx GPU_MAX_HEAP_SIZE 100 setx GPU_USE_SYNC_OBJECTS 1 setx GPU_MAX_ALLOC_PERCENT 100 setx GPU_SINGLE_ALLOC_PERCENT 100 ethminer.exe --farm-recheck 200 -G -S eu2.ethermine.org:4444 -FS eu2.ethermine.org:4444 -O 0xffffffffffffffffffffff.foo

    Hi Keraj!

    Mind sharing on how you change to OpenCL instead of CUDA?

    Thanks!

  • Spal92Spal92 Member Posts: 2
    Did you work out what was wrong?
    I am having the same issue with my Asus GTX 970. Read all the forums, but cannot find solutions.
    Using Windows 7, Nanopool and Claymore v10.0 Tried different drivers such as 347.52, 347.88, got 3Mh/s with these, with the most recent driver (388.31) I got 9Mh/s.
    Any suggestion?
  • rgjoycergjoyce Member Posts: 1
    using your batch file. I get a max of 10Mh/s but it does show a lot of other times, of 4Mh and 7Mb too, so it looks like it's averaging the 8Mh I'm getting with claymore.
    As for the Spal92 question of how I get 8+Mh/s :smile:
    I had to upgrade to windows 10. This way, the NVidia control panel has an option for compute performance. It is this option that will get you from 3 to 7. and then increase your memory clock speed bit by bit until your PC locks up or you have problems. but take note as you change it. After you reboot, set it to the last stable setting and leave it. I can get it up to 8.5MH/s

    One thing I cannot understand though is why, the 970 gets such a low rate wheras the 470 and 480 get 20-30MH/s
    How does that work?
Sign In or Register to comment.