ROG STRIX B250F GAMING motherboard for Eth mining

chirash333chirash333 Posts: 19Member
Hi,

I am trying to setup a 6 GPU Rig. I am using ROG STRIX B250F GAMING motherboard. I have been successful in connecting 4 RX 480 8gb OC Sapphire onto it. But as soon as i go over that, it starts showing errors.

Has anyone been using this board . I was facing Code 12 issue earlier. then driver crashed.

Specs

ROG STRIX B250F GAMING
Sapphire RX 480 OC 8GB (4 as of now, want to connect 6)
8GB DDR4
G4400 3.3 GHz Dual Core CPU
Win 10 Pro 64 bit

Please suggest what should i do to get all 6 GPU working.

Regards
Chirash

Best Answer

«1

Answers

  • chirash333chirash333 Posts: 19Member
    Hi, i was able to get out of code 12 by turning the x16 slot to x2 mode.

    However i could only run 5 GPU as the sixth one doesnt get detected.

    Apparantly this board is doing some lane sharing which is preventing it to do that. But 5 r running
  • drizzt_do_urdendrizzt_do_urden Posts: 181Member ✭✭
    Yeah the same thing with the gigabyte z170 board. MSI Z170A Pro carbon was fixed with a BIOS update. did you check the asus support page if they have a new BIOS for your board?
  • lucyblucyb Posts: 2Member
    Hi I'm in a similar situation you were in chirash. I changed to x2 and 5 gpus show up but still with a error. I did x4 and 3 show up but no error. any other ideas as to what you changed In the bios?
  • chirash333chirash333 Posts: 19Member
    There are a couple of settings ASUS support guys told me to change.
  • lucyblucyb Posts: 2Member
    Hey that worked with 5 thanks. have you managed to get 6 to work? I have yet to try
  • chirash333chirash333 Posts: 19Member
    @lucyb your WC. No, 6th one dosenot get detected at all. this configuration also is not really stable, but is getting the job done.

    Let me know if you get the 6th one up. (I guess a custom BIOS should do)
  • MandakhMandakh Posts: 1Member
    @chirash333 Disabling CPU graphics let Windows 10 to detect 6th GPU. But GPUs on PCI-E x16 are dropped regularly.
    This is an interesting post about hardware sharing conflicts.
    https://bitcointalk.org/index.php?topic=1614479.msg16254145#msg16254145
    I'm gonna try to disable onboard sound, network and USB3.1 interface.
  • fabiojndfabiojnd Posts: 4Member
    edited April 28

    Good morning, I need help, I can not get the 4 riser, I need at least 5, it can help, Which version of bios? What are the parameters in bios? Thank you!
    Post edited by fabiojnd on
  • chirash333chirash333 Posts: 19Member
    fabiojnd said:


    Good morning, I need help, I can not get the 4 riser, I need at least 5, it can help, Which version of bios? What are the parameters in bios? Thank you!

    What MB AND CARD R U USING?
  • fabiojndfabiojnd Posts: 4Member
    using STRIX B250F GAMING and riser 1x to 16 usb 3.0
  • chirash333chirash333 Posts: 19Member

    There are a couple of settings ASUS support guys told me to change.

    @fabiojnd , hope you have made these changes and set vram to 16gb minimum. My also disabled audio and USB in bios. And go 1by1 when u r plugging GPUs.

    Keep. Checking in device manager and don't use the latest driver. Use the one that came with CD.

    There is something wrong with this board but 4 can run easily
  • fabiojndfabiojnd Posts: 4Member
    After inserting the 4 riser the machine is restarting

    There are a couple of settings ASUS support guys told me to change.

    @fabiojnd , hope you have made these changes and set vram to 16gb minimum. My also disabled audio and USB in bios. And go 1by1 when u r plugging GPUs.

    Keep. Checking in device manager and don't use the latest driver. Use the one that came with CD.

    There is something wrong with this board but 4 can run easily

    Thanks for the information, with the help of your information I'm already running 6 riser, Thanks!
  • daniegolas81daniegolas81 Posts: 5Member
    Hi Friend, I have the same Motherboard Asus Strix B250F and 4 Asus Strix RX 480 8Gb I'm planning to buy two more, after you change all the settings above mentioned it's still working good the six GPU?
    Thanks.
  • chirash333chirash333 Posts: 19Member
    fabiojnd said:

    After inserting the 4 riser the machine is restarting

    There are a couple of settings ASUS support guys told me to change.

    @fabiojnd , hope you have made these changes and set vram to 16gb minimum. My also disabled audio and USB in bios. And go 1by1 when u r plugging GPUs.

    Keep. Checking in device manager and don't use the latest driver. Use the one that came with CD.

    There is something wrong with this board but 4 can run easily

    Thanks for the information, with the help of your information I'm already running 6 riser, Thanks!
    Great! How stable it is?

    For me everytime my PC reboots it would miss out a card . Then i need to plug GPU in one by one.

    What GPU are u using?
  • chirash333chirash333 Posts: 19Member
    @fabiojnd , u still active dude?
  • daniegolas81daniegolas81 Posts: 5Member

    @fabiojnd , u still active dude?

    Hi, I did it! It is possible works with the 6 GPU in the motherboard, I have installed 6 Asus strix RX 480 8Gb, you have to install 1 by 1 and make all the modification above mentioned, works good with ETH-DCR Dual mining, (24.5Mh/s ETH) and (738Mh/s DCR) per card, I still don't know how to Overclock the cards with the risers, The asus Tweek do not detect the cards when is extended with risers, Aura also doesn't work.
  • JawboneJawbone Posts: 44Member
    What is the benefit to doing one by one? Do you install the driver again each time?
  • daniegolas81daniegolas81 Posts: 5Member
    Jawbone said:

    What is the benefit to doing one by one? Do you install the driver again each time?

    I tried to Install all together and one give me error, you need to install the driver just one time, the next card will install automatically, but you can do it as the way you want, may be you need to expirience by yourself...
  • newtechznewtechz Tokyo, JapanPosts: 63Member
    I have asrock fatal1ty h270 performance to got same code 12 things. I hate this when i got on Z170 mobo.

    I got 2 GPUs(3 of code 12 error) to 5 GPUs work with this setting.

    - Top of lower Usable Dram
    Dynami to minimum(1GB on my situation)
    - PCIE1 ~ 6 Link Speed
    Auto to Gen1


  • fabiojndfabiojnd Posts: 4Member
    @Daniegolas81
    After installing the video card drive, you connect 1 rise at a time, until completing the 6 connections, if any device fails to enter the control panel, device manager and disable the card with error and try to enable again. I hope it helps!
  • cliffordwhcliffordwh Posts: 3Member
    @fabiojnd I'm really struggling to get it to work with just 4 cards. Running windows 10 and then it just freezes.

    All PCIE set to gen1 and i followed the settings posted above.

    Could you explain what you mean 1 by 1. Are they all plugged in when you put the power on? When you say connect 1 rise at a time do you power off then power on everytime?

    Thanks
  • cliffordwhcliffordwh Posts: 3Member
    edited May 9
    no stress i got it! i turned off 4g decoding and everything worked. What exactly does that do?

    Edit: no luck still freezing. Going to try upper the ram from 4gig to 8gig.
    Post edited by cliffordwh on
  • chirash333chirash333 Posts: 19Member
    BOYS, i have 6 GPU running on this stupid ass board. i mean i am running a biostar TB85 and withing 30 mins i was done and havenot looked back. But this board after too much settings was able to get 6 running. but still very unstable i must say
  • chirash333chirash333 Posts: 19Member

    no stress i got it! i turned off 4g decoding and everything worked. What exactly does that do?

    Edit: no luck still freezing. Going to try upper the ram from 4gig to 8gig.

    @cliffordwh , Just in case u want to know what 4g Decoding does. It allows real time memory management to allow more GPU's to be plugged in. Used in GRIDs.

    How is it going for you now. How stable is it?
  • chirash333chirash333 Posts: 19Member
    edited May 27
  • RoughCoinRoughCoin Posts: 5Member
    Hello all,

    Having the same problem with a shitty Asus STRIX h270f GAMING MOBO that wouldn't accept a 4th card...the BIOS is up to date. Short of banging on it I have tried everything.

    Will try the [GEN 1] setting, then enable 4g decoding. I hope this works cos I am going crazy.

    Also, GPUs are not overclocking well with new drivers. Any help please.

    Cheers
  • chirash333chirash333 Posts: 19Member
    friend on mine was able to get your mobo running after doing these settings. So good luck!
  • RoughCoinRoughCoin Posts: 5Member
    edited June 1
    I do not have the settings you have got about "mode settings" but I changed everything to [GEN1] but still the system wouldn't start up with a 4th card....No BIOS, just CPU fan spinning and blank screen.

    I also turned off a number of onboard components and USB ports.

    I am running Windows 10 PRO, 8Gb RAM, 120GB SSD, 3 GTX 1050Ti WF OC, Corsair RM1000W PSU...and drivers that came with CD.

    I am out of options.....also please could some recommend a good mobo and brand that is in stock which can host 6 GPUs without this stress.

    Cheers

    UPDATE: Done it! Takes my system forever to boot up though. Enabled Vt-d and Above 4G Decoding.......Thanks a zillion guys...mining@53Mh/s
    Post edited by RoughCoin on
  • 1234xm1234xm Posts: 20Member
    newtechz said:

    I have asrock fatal1ty h270 performance to got same code 12 things. I hate this when i got on Z170 mobo.

    I got 2 GPUs(3 of code 12 error) to 5 GPUs work with this setting.

    - Top of lower Usable Dram
    Dynami to minimum(1GB on my situation)
    - PCIE1 ~ 6 Link Speed
    Auto to Gen1


    i have the sam mobo, but i cannot run more then one GPUs...only the 16x slot is working, the rest i cannot to get working. I update bios, tried all of the setting, which i found here, try also anyother, not helped.

    when i start, only main GPU fan start doing, the rest 3 gpus just turn a mm, but then shout down.

    any help please. i am getting really angry on that mobo...
Sign In or Register to comment.