Biostar TB85 & Asrock H81 - 6th RX480 Card Crashes on Windows Startup

maomaopopmaomaopop Posts: 8Member
edited March 13 in Mining
I need some guidance on a new rig I am working on. As soon as 6th GPU is installed, Windows won't boot and goes BSOD. 5x GPUs runs smoothly without any issue.

[Edit] : My secondardy Asrock H81 BTC rig with 6x GPUs also crashes with the same error code at Windows bootup.



Hardware
Biostar TB85 Motherboard / Asrock H81 BTC.
Sapphire RX 480 8GB Nitro+ x 6 units.
Corsair AXi 1500W PSU.
GPU Bios Un-mod.
All GPU's riser runs on 2 connection per molex from PSU (PSU has 3x rails of molex connector).
Motherboard's molex connection are powered with 2 separate SATA to molex rails from PSU.
Bios PCIE all sets to "Gen 1".
Windows 10 OS with Crimson ReLive Edition 17.2.1


What I Have Tried
Swap "confirmed" working GPUs & risers (I have extra GPUs and riser).
Run only 5 GPUs but plug 5th GPU to PCI-E 6th Port.
Remove molex additional power to motherboard.
Swap with another Coolermaster V1200w PSU.
Switched GPU to silent bios.
Run with all GPU modded bios bootstrapping 1625 memory timing (Bios signature patched).

I suspect power but since AXi has sufficient juice so I suspect bios settings or something I messed up.
It is driving me nuts...please help. I will buy coffee/beer/wine and sandwiches.
Post edited by maomaopop on

Comments

  • theneogeo1982theneogeo1982 Posts: 512Member ✭✭
    You shouldn't power the motherboard molex if you have powered risers.... Check your bios to PCIE is set to gen1?
  • maomaopopmaomaopop Posts: 8Member
    @theneogeo1982 , yes I have checked that PCIE is set to Gen1.
  • theneogeo1982theneogeo1982 Posts: 512Member ✭✭
    Tried switch cards? risers? different slots?
  • maomaopopmaomaopop Posts: 8Member
    Yes, I had few GPUs and riser that confirmed working. Yes, I swapped slot 5 to 6 and back and forth.
  • theneogeo1982theneogeo1982 Posts: 512Member ✭✭
    In event viewer can you find out the error code? Maybe bad install of windows 10?!?! Happened to me once
  • maomaopopmaomaopop Posts: 8Member
    It won't boot Windows. But if i remove the 6th card, it will boot fine. I also reinstall a new Windows 10. Same issue.
  • theneogeo1982theneogeo1982 Posts: 512Member ✭✭
    Can you install ubuntu or linux or ethOS to see if issues persists with those OS
  • maomaopopmaomaopop Posts: 8Member
    ya, i am trying other OS now.
  • bhanu545bhanu545 Posts: 52Member
    Try uninstalling AMD catalyst and plug 6th gpu and boot windows, if it works then change mobo booting to intel graphis(IGE) instead of PEG. this way your computer boots with intel graphics and still u will be able to work all your 6 gpus.
    The above method will not work for 7gpus.
  • sigb0ysigb0y Posts: 5Member
    Do you have enough RAM installed? Also try to disable the internal GPU of the mobo.
  • mujuujmujuuj Posts: 2Member
    @maomaopop did you solved this problem? Please help me to solve this
  • emperorneroemperornero Posts: 29Member
    edited March 31
    You have not patched the AMD drivers and set your pagefile to 16 GB.
    I had this issue before.

    Unplug all but 1 GPU.
    Set pagefile to 16 GB in advance system settings. Google it if you don't know how to change this.
    Download and run the Pixel Clock Patcher AMD Driver Patch.
    Then restart.
    Then shutdown and install all GPUs.
    Wait for all GPUs to be detected. They will all code 43 but that's fine that's what we want.
    Run the Pixel Clock Patcher again.
    Restart.

    Enjoy :)
  • steffen83steffen83 Posts: 2Member
    edited April 21
    my config is nearly the same as maomaopop's
    asrock btc rev2, 6x sapphire 480 nitro+, even the same PSU.
    When I install drivers above a certain crimson version
    ( I have to try it once again, but i think it was above a 17.1),
    I get a bsod. even with patched drivers.
    i haven't installed any AB,Twixx or something.
    Cleaned the system with DDU and then installed the drivers.
    I'am on 16.11.5 now, and that works ok for me.
    all other drivers have one more problem: the fans are suddenly spinning at 100% or stopping at all causing the system to reboot.
    Now its not really a problem, but i wonder what to to, if i install a rx580...
    so maybe asrock has to update their bios or the problem belongs to amd...
    Has anyone an asrock btc v2 with win 10, 6x rx480 running with the actual drivers?
  • SebsSebs Posts: 2Member
    I am having the same problem with a biostar Tb-250 BTC and 6 RX580s. I can use 4, everything above that gives me the error. I think it has to be a driver issue. The question is, what can be done about it?
  • lablettlablett Posts: 112Member
    edited April 24
    Hi guys, I have the same problem but I have made some progress. I have been mining for years and bought some new kit for a new rig. I have an Asrock h61 BTC and 6 x 580's.

    Stage 1: You first need to check the hardware. so disable the onboard graphics card and run DDU to remove all drivers. now in Windows device manager you should see your 6 cards. These could be under video or other section. This stage 1 proves you hardware can see all the cards.

    Stage 2 is where you install the driver and this where I am stuck. I am installing 17.4.3 and I get the blue screen of death when the 6th cards tries to be driver enables.
    Post edited by lablett on
  • lablettlablett Posts: 112Member
    I have tried the 'Pixel Clock Patcher AMD Driver Patch' and it does not seem to work with AMD Driver 17.4.3!
  • lablettlablett Posts: 112Member
    ok after much battling I have come to the conclusion it is a driver issue. I guess I should have stuck with the 480's! With just 5 cards and some Waterman tuning I am happy with the results. I'm getting around 23mhs on each card and pulling 80w per card. I have a 480 in my gaming rig so I might flash one one the 580's down to a 480.
  • steffen83steffen83 Posts: 2Member
    last working driver is 17.1.2
    17.2.1+ only gives a bsod when starting windows. driver patch makes no difference.
    @lablett
    Do the 580's work with an older driver ? ex. 17.1.2 ?
    normally not, because the 580's came out later, but on the other side its only an upgraded 480.
    I wonder if its possible to run 5x480's with 17.1.2 and 1x580 with a higher driver-version?
  • lablettlablett Posts: 112Member
    The 580's will only work, well are recognised, with 17.4.3. I am so tempted to downgrade the 580 to 480.
  • lablettlablett Posts: 112Member
    I took the BIOS from a 480 and loaded it into the 580. MS windows still thinks it is a 580 so I may have hit a blocker.
  • lablettlablett Posts: 112Member
    update : 17.4.4 was an even worse driver. Also I blew up one card when I moved the rig...
Sign In or Register to comment.